Solved

Users cannot access Filshares in 2008

Posted on 2008-10-29
7
270 Views
Last Modified: 2012-05-05
hi friends,

i have created a folder called "Userhome". Each user has its own named folder which i have shared as username$ and gave full access rights. in the security tab, each user has "full control" to his folder.

strangely, i can map the share as FS1\userhome\username$        and the user can see all folders get listed. but he cannot access them.

anyone an idea whats wrong?
0
Comment
Question by:boxexpert
  • 3
  • 2
  • 2
7 Comments
 
LVL 32

Expert Comment

by:nappy_d
ID: 22830380
What are the share prmissions you have created?

You mention you have set the NTFS permissions, but what about the share permissions?
0
 
LVL 5

Expert Comment

by:AncientFrib
ID: 22830398
Ensure your users atleast have "Change" share permissions.
0
 
LVL 32

Expert Comment

by:nappy_d
ID: 22830427
On the the share permissions. I always set the share permissions to full control and let the NTFS permissions handle the rest.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:boxexpert
ID: 22830597
so did i, but still certain users cannot access their own folders,regardless if the have full control on it. very strange...
0
 
LVL 32

Expert Comment

by:nappy_d
ID: 22830634
Does the Everyone group on the share havs "Full Control" permissions?

Can you list out the permissions or show some screen shots.
  • The properties of your shared permissions
  • The properties of the NTFS permissions on a user directory
0
 

Author Comment

by:boxexpert
ID: 22831036
only the user has full control to his own folder.

anyway, i just copied the contents of the folder to a separate HD,delete the foilder on the server and will copy it back.

ill report the outcome of that action
0
 
LVL 5

Accepted Solution

by:
AncientFrib earned 500 total points
ID: 22831467
I would force the ownership on all child objects:

Right Click > Properties > Security > Advanced > Owner Tab > Select owner and check "Replace owner on all subcontainers" > Click OK

Then I would force NTFS permissions on all child objects too:

Right Click > Properties > Security > Ensure user has full control of object > Advanced > Check "Replace permission entries on all child objects" > Click OK
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you migrate a Terminal Server licenses server inside the 2008 server family, you can takte advantage of the build-in migration tool. If you like to migrate an older 2003 Server (and the installed client CALs) to a 2008 R2 server for example, you …
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question