Solved

enabling remote desktop in Home Premium

Posted on 2008-10-29
26
1,005 Views
Last Modified: 2013-11-21
I am trying to enable Remote Desktop in Vista Home Premium 32 bit. I think that i have made the necessary registry hacks and firewall changes but I can't get the computer to listen on the RDP port of 3389. The command netstat -a | find /i "3389" doesn't show any listening. I have double checked the Windows firewall as well as the services. I figure that I am missing something pretty minor, however, i can't figure out what that may be.

Any suggestions on a fix would be greatly appreciated.
0
Comment
Question by:LostInWindows
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 10
  • 3
26 Comments
 
LVL 13

Expert Comment

by:dhoffman_98
ID: 22830691
Perhaps what you are missing is that Vista Home Premium does not support Remote Desktop... officially.

There are many hacks out there on the net that talk about how to implement it in Vista Home Premium, but as it is not officially supported, this site is probably not the best place to ask questions about how to hack the OS to provide something it is not supposed to support. Try google.
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22831141
Isn't there be a way to enable a specific port number?
0
 
LVL 13

Expert Comment

by:dhoffman_98
ID: 22831614
Services enable port numbers by becoming active. If the firewall is blocking that port, you have to add an exception to the firewall.
0
The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

 
LVL 1

Author Comment

by:LostInWindows
ID: 22833196
That is what has me puzzled. I manually added a firewall exception for port 3398 and enabled it. Yet, still when I enter     netstat -a | find /i "3389"    I don't show any result
0
 
LVL 13

Expert Comment

by:dhoffman_98
ID: 22833644
Netstat won't show a result unless you have an active listener that has opened the port connection. If you are not seeing it, then it means the process is not connecting to the TCP/IP stack to open a connection.

Make sure the MSTSC process is actually running.
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 22838350
Hi LostInWindows,

Try:

1. Download termsrv.zip here: http://www.unet.fi/sub/termsrv.zip
2. Extract Termsrv.zip to a temp directory
3. Start Command Prompt in Administrator mode (Run As Administrator)
4. Run the corresponding batch file for your Vista edition
5. Allow TCP Port 3389 on Windows Firewall or any other firewall product.
6. Done

Let me know if this helps.

Cheers
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22840349
JoWickerman, I did all of your suggestion. My problem is I can't get the PC to listen on port 3389
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 22840461
Oh ok. Did you check that "Allow connections from computers running any version of Remote Desktop (less secure)" is clicked?
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22840493
I don't think that shows in Home Premium. I will be at the site later this morning, i will double check.
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 22840595
Cool. Let me know!
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22873316
The remote assistance advanced icon shows to allow all requests. However, because it is a "home" product, the RDP portion of the window is hidden. I thought it might be worthwhile to do a netstat -an and see what is listening.
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 22884840
Any luck?
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22885648
The PC is in an office and the user was sick on Monday and Tuesday. I hope to find out today. If she isn't in I will drop by.
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22907061
The problem that I have is that I have customized the firewall to open port 3389. However, when I do a netstat -an then I find that Port 3389 is not listening. How do I turn on the port to listen. The netstat -an output follows:

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:5357           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:5800           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:5900           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:6646           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:10172          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49152          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49153          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49154          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49155          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49156          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49157          0.0.0.0:0              LISTENING
  TCP    127.0.0.1:10172        127.0.0.1:49202        ESTABLISHED
  TCP    127.0.0.1:10172        127.0.0.1:49203        ESTABLISHED
  TCP    127.0.0.1:10172        127.0.0.1:49395        ESTABLISHED
  TCP    127.0.0.1:49202        127.0.0.1:10172        ESTABLISHED
  TCP    127.0.0.1:49203        127.0.0.1:10172        ESTABLISHED
  TCP    127.0.0.1:49395        127.0.0.1:10172        ESTABLISHED
  TCP    192.168.2.25:139       0.0.0.0:0              LISTENING
  TCP    192.168.2.25:10172     192.168.2.33:55299     ESTABLISHED
  TCP    192.168.2.25:10172     192.168.2.33:55300     ESTABLISHED
  TCP    192.168.2.25:10172     192.168.2.33:55301     ESTABLISHED
  TCP    192.168.2.25:49162     192.168.2.2:445        ESTABLISHED
  TCP    192.168.2.25:49679     216.49.94.13:80        TIME_WAIT
  TCP    [::]:135               [::]:0                 LISTENING
  TCP    [::]:445               [::]:0                 LISTENING
  TCP    [::]:5357              [::]:0                 LISTENING
  TCP    [::]:49152             [::]:0                 LISTENING
  TCP    [::]:49153             [::]:0                 LISTENING
  TCP    [::]:49154             [::]:0                 LISTENING
  TCP    [::]:49155             [::]:0                 LISTENING
  TCP    [::]:49156             [::]:0                 LISTENING
  TCP    [::]:49157             [::]:0                 LISTENING
  UDP    0.0.0.0:123            *:*
  UDP    0.0.0.0:500            *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:4500           *:*
  UDP    0.0.0.0:5355           *:*
  UDP    0.0.0.0:56640          *:*
  UDP    0.0.0.0:59297          *:*
  UDP    127.0.0.1:1900         *:*
  UDP    127.0.0.1:54889        *:*
  UDP    127.0.0.1:57453        *:*
  UDP    127.0.0.1:57459        *:*
  UDP    192.168.2.25:137       *:*
  UDP    192.168.2.25:138       *:*
  UDP    192.168.2.25:1900      *:*
  UDP    192.168.2.25:6646      *:*
  UDP    192.168.2.25:54888     *:*
  UDP    [::]:123               *:*
  UDP    [::]:500               *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:5355              *:*
  UDP    [::]:59298             *:*
  UDP    [::1]:1900             *:*
  UDP    [::1]:54886            *:*
  UDP    [fe80::34d4:13cb:3f57:fde6%9]:1900  *:*
  UDP    [fe80::34d4:13cb:3f57:fde6%9]:54887  *:*
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 22930838
Try:

Run command prompt -> net localgroup "Administrators" "NT Authority\Network Service" /add
Go to the c:\windows\registration -> Rightclick and add full control to the administrator and everyone account on that folder.
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22940346
I have done the changes. Now I get a Username and passowrd screen. However, my login attempt is refused. I even tried from withing the office on the same workgroup and I get a message: "This computer can't connect to the remote computer. Try connecting again or contact the owner of the remote computer"
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22946634
Attempt to increase points
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 22959615
You'll have to connect as Administrator on the local PC...

Did you change the remote desktop users settings?
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 22961164
This is Vista. The account I want to connect to has Admin privileges, however, the administrator account is disabled by default.
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 23002714
Can you enable the admin account? Or create an account with admin rights?
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 23034577
The workstation has 1 account on it. It has Admin rights enabled.
Like I mentioned earlier now when I attempt to log in I get a log on screen for username and password, however, I see the following message:
"This computer can't connect to the remote computer. Try connecting again or contact the owner of the remote computer"
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 23055394
What happens if you use the credentials of the user whose account is on the PC. The one with the admin rights? For testing purposes, ask the user for her password, she can change it later again...
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 23055503
When I try that account from inside the company workgroup I get the Remote Desktop Logon Screen then the message "This computer can't connect to the remote computer. Try connecting again or contact the owner of the remote computer"
From Outside of the workgroup  I get the message  "This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator."
0
 
LVL 16

Accepted Solution

by:
JoWickerman earned 500 total points
ID: 23086053
Hhhmmm... Spoke to a Microsoft representative. You'll have to upgrade to Vista business or Ultimate for this to work properly.
0
 
LVL 1

Author Closing Comment

by:LostInWindows
ID: 31511132
OK. It seems unreasonable of MS to charge over $200 to upgrade from Premium to Business. You would think that they would have a Vista to Vista upgrade that would be more reasonably priced.
0
 
LVL 16

Expert Comment

by:JoWickerman
ID: 23086188
Yeah... I agree with you there...
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After having deployed hundreds of thousands of Terminal Services seats worldwide, I still see all the time people asking me that same old question: "If TS/RDS is that reliable why are you telling me I should reboot it that often? My DC/SQL/Exchange/…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question