Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

How do I force IE to open a new tab rather than a new window when clicking on a link in Outlook Express?

Posted on 2008-10-29
16
Medium Priority
?
695 Views
Last Modified: 2013-12-08
I recently installed Firefox 3 and made it my default browser. I decided that I liked IE better, so I switched my default browser back to IE. Now, however, if I have IE and Outlook Express open simultaneously, and then click on a link in Outlook Express, a new IE window will open. It used to open a new tab in the existing IE window, which I much prefer. I cannot figure out how to restore the former behaviour. In an attempt to resolve this, I uninstalled Firefox, and upgraded IE from version 7 to version 8 beta, to no avail. It still insists on opening a new window rather than a new tab. How can this be fixed?

Nathan
0
Comment
Question by:nzeiset
  • 7
  • 5
  • 4
16 Comments
 
LVL 97

Expert Comment

by:war1
ID: 22831539
Hello nzeiset,

In IE go to Tools > Internet Options > Advanced tab.  Check the box next to "Reuse window for launching shortcuts".  Click OK. Restart the computer. Test.

If no joy, some links will always open a new window.   That is how the link is created.

Hope this helps!
war1
0
 

Author Comment

by:nzeiset
ID: 22832562
Hello war1,

This box is already checked. However, it says "Reuse window for launchnig shortcuts (when tabbed browsing is off)." Since I have tabbed browsing turned on, I suppose this setting does not apply, unless you are referring to a different setting.

Nathan
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22832850
nzeiset--IE Tools|Internet Options|General tab|Tabs|Settings|"Open links from other programs in" section.
Make sure the "A New Window" button is not checked.  Check one of the others according to your preference.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 97

Expert Comment

by:war1
ID: 22832923
Check the box, select OK. Restart the computer.

If no joy, reset IE settings. Go to Tools > Internet Options > Advanced.  Click on "Reset" button. Click OK. Close all browsers. Reboot the computer.
0
 

Author Comment

by:nzeiset
ID: 22834115
jcimarron,

"A New Window" is not checked, but the problem remains.

war1,
I reset the IE settings as described, but I did not delete personal settings, as I didn't want to lose my history. Now, however, when I click on a link in Outlook Express, nothing happens.

Nathan
0
 
LVL 97

Expert Comment

by:war1
ID: 22834882
1. On the desktop, double-click My Computer.  
2. On the Tools menu, click Folder Options, and then click the File Types tab.  
3. In the Registered File Types list, click URL:HyperText Transfer Protocol, click Advanced, and then click Edit.  
4. In the Actions box, type open.  
5. In the Application used to perform action box, locate Firefox (firefox.exe), and then click Open.
6. In the Application box, type Firefox, and then click OK.
0
 

Author Comment

by:nzeiset
ID: 22879150
war1,
Sorry for my delayed response. It's a busy time for me.
I want to use IE, not Firefox. I already have IE in place in the boxes that you described above.

Nathan
0
 
LVL 97

Expert Comment

by:war1
ID: 22879851
To open links from OE, you need to register the following files

1. You may need to register some dll files
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q281679&sd=tech
1. Quit all programs that are running.
2. Click Start, and then click Run.
3. Type regsvr32 urlmon.dll, and then click OK.
4. When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK.

If using Vista and you get an error, run regsvr32.exe from an elevated command prompt. To get an elevated command prompt, right-click on the "Command Prompt" shortcut and select "Run as Administrator".

If this does not resolve the problem, repeat steps 2 through 4 for each of the following files (in step 3, replace Urlmon.dll with each of the file names below):

Shdocvw.dll
Actxprxy.dll
Oleaut32.dll
Mshtml.dll
Browseui.dll
Shell32.dll

OR
Run this script if using IE6
http://windowsxp.mvps.org/IEFIX.htm

2. If no joy, try this fix here
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Q_22807984.html
0
 

Author Comment

by:nzeiset
ID: 22880169
I tried to register the dll files as suggested. I was able to register them all except Mshtml.dll. When I tried to register it, I got this message:
Mshtml.dll was loaded, but the DllRegisterServer entry point was not found.
This file cannot be registered.
The problem was not solved. Still nothing happens when I click on a link in an email.
I did not try the next suggestion because I'm not running IE6; I'm running IE8 beta.
The last suggestion linked to ideas that were mentioned earlier.
Nathan
0
 
LVL 97

Expert Comment

by:war1
ID: 22880244
As a last resort, uninstall IE8 Beta.  The beta part may be causing the error.
0
 

Author Comment

by:nzeiset
ID: 22880327
I could do that, but I was having the same issue with IE7.
Nathan
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22881020
nzeiset--"I was able to register them all except Mshtml.dll"
FWIW--That is normal behavior in IE7.  There is no entry point.
0
 

Author Comment

by:nzeiset
ID: 22907569
OK, I uninstalled IE8 beta. Same issues, so I uninstalled IE7, rebooted, and reinstalled IE7. Before I reinstalled IE7, I also messed with the settings in URL:HyperText Transfer Protocol under Folder Options, File Types. I think they reverted back to the default settings when I reinstalled IE7. Here are the current settings in the "open" action:
Application used to perform action:
"C:\Program Files\Internet Explorer\IEXPLORE.EXE" -nohome %1
Use DDE
(checked)
DDE Message:
"%1",,-1,0,,,,
Application:
IEXPLORE
DDE Application Not Running:
(blank)
Topic:
System
Now, if IE is closed when I click on a link in Outlook Express, IE will open to the correct page. However, if IE is already open when I click on a link in Outlook Express, IE will come to the front and be in focus, but it does nothing else. The link does not open in either the current page or a new tab. The focus remains at the page that was opened before I clicked on the link.
0
 
LVL 50

Accepted Solution

by:
jcimarron earned 1000 total points
ID: 22909315
nzeiset--For what it is worth, my URL:HyperText Transfer Protocol  Action window has
Application used to perform action:
"C:\Program Files\Internet Explorer\IEXPLORE.EXE" -nohome
Topic:
WWW_OpenURL
The other values are the same as yours.
0
 

Author Closing Comment

by:nzeiset
ID: 31511183
It's working now! Apparently removing "%1" was the issue, at least here at the last.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22923374
nzeiset--Glad to hear the good news.  I have learned something.
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had to do a bit of research to find the answer to this question so I thought I'd share my results.  Due to our outdated mainframe systems, we need to downgrade IE9 to IE8 in order to stay compatible.  We also needed to downgrade Java.  In order to…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This Micro Tutorial will demonstrate how nuggets on the Web are formatted by using Chrome Developer Tools. These tools would not only view the site's CSS but it can also modify it and save the CSS to use on your own site.
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

886 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question