• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 315
  • Last Modified:

switch from KDE 4.1 to 3.x

I have opensuse 11 and KDE 4.1
I want to switch to KDE 3.5 (or whatever is the latest 3.x)
How do I do this?
Will my personal data, such as the mail in Thunderbird, remain intact?
0
allelopath
Asked:
allelopath
  • 7
  • 7
1 Solution
 
torimarCommented:
Hi,

you can, without any problem, have KDE 3.x alongside KDE 4.x installed on SuSE.

Insert your Install DVD, open YAST's software installation module, search for KDE and select all packages from the latest KDE 3.x version.

Once installed, you can change the window manager through logging out and selecting KDE 3 in the session dropdown box on the login screen.

If you wish to make KDE 3 your default window manager, this is also done via YAST, but unfortunately, I can't tell you exactly where it is that you find the option (no SuSE box at hand presently). But I'm sure you'll find it yourself.

Of course, changing the window manager will not harm any of your data in any way. Just like putting on another sweater does not make you lose your arm ;)

ps:
If you are certain to not want KDE 4 ever again, reboot to see whether your default manager has successfully changed, then uninstall KDE 4 via YAST.

0
 
allelopathAuthor Commented:
In Yast, it says I already have installed "kdebase3-runtime", but kde3 is not an option in the session dropdown box.
0
 
torimarCommented:
KDE3 consists of much more than only that one package. In order to select the KDE3 metapackage, do this:
In Yast, in the Filter dropdown box, select 'Pattern', not 'Search'.

If you then wish to make KDE3 your default, do this here:
Yast - security & users - user management - advanced.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
allelopathAuthor Commented:
ok, i installed KDE3 by finding it in the Pattern filter.

>>Yast - security & users - user management - advanced.
There is no 'user management', there is user and group administration, but under there, there is no 'advanced'
but still, i can log out and select KDE3 from there
but when I do so, it says
"Could not start kstartupconfig. Check your installation"
I tried restarting the machine, but I get the same error.
I also installed something called xcfe and that works.
0
 
torimarCommented:
Hmm. Did you try to run KDE as another user, or even a new user?

Anyway, I can only guess that there is something wrong with your /home directory permissions.

(For the following, replace *username* by the login name of the user you normally use.)

- login as root (in xfce or kde4)
- check whether the folder /home/*username* exists (if not, create it)
- in a terminal window, type: chown -R *username*:users /home/*username*

Log out, log in as *username* with kde3 selected.


As to making KDE3 your default, sorry for the wrong info.
I have never run an English language installation of SuSE, and I may be mixing up versions (been with it since version 5).
Try:
YaST > /etc/sysconfig Editor > Desktop > Window Manager > Default_WM

That should work. If not, I'm going to check when I get home.

0
 
allelopathAuthor Commented:
I've edited /etc/sysconfig/windowmanager by changing "startkde4" to "startkde3"
Performed the chown command as you suggested (though I think it was not needed and so had no effect)
Logging on as my regular use or as root, I still get same message .
I created a new user, same thing
:(
0
 
torimarCommented:
This is very strange.

I have researched the issue all day long, but in practically all of the reported cases, this could be resolved by either resetting ownership/permissions, or by recreating the home folder.

In your case, it doesn't even work with root, although root does have universal permissions and by default has a home folder. I can't make sense of this.

Here are a few more suggestions:
- as root, uninstall KDE3 completely and re-install it
- in Yast > Install/Remove Software, selct Extras > Check System
- as root, run the command 'kstartupconfig' in a terminal, and copy/paste the error messages here
- as root, do the same with the command 'kdeinit'
- could you also copy/paste the contents of your etc/fstab file here?
0
 
allelopathAuthor Commented:
- as root, uninstall KDE3 completely and re-install it
tried that. no dice. more to come.
0
 
allelopathAuthor Commented:
DId the check system, and it removed some kde4 files
Now it won't start kde4 either.
Error is "Could not start kdeinit4"

kdostartupconfig: error while loading shared libraries: libkdefx.so.4: cannot open shared object file :No such file or directory

same thing with kdeinit



0
 
torimarCommented:
This is ever so strange.

Anyway, the time sure has come to try a repair install. First, make sure to backup all files in your home/<username> directory to an external USB stick or hard drive. The contents of that folder is mostly hidden, so make sure hidden files are showing up.
Now your settings, data, email etc. should be safe.

Then boot from the installation DVD, and select a Repair install when asked.

I've never gone through a Repair Installation myself, so I don't know how interactive it will be. In case you get a choice of packages to install, make sure that next to KDE3 you select at least one additional window manager, like Xfce or Gnome.
Then let it run and let's hope for the best.
0
 
allelopathAuthor Commented:
I did a repair install, neither kde works.
xfce still does.

hold on while I see if I can fix it ...
0
 
torimarCommented:
More and more, this looks like a critical dependency conflict.

Maybe once, when you were still trying to familiarize yourself with SuSE, you installed a package and ignored the conflict warnings given by YaST. That is generally a bad thing to do. Resolving a conflict or refraining from the installation is a better way of keeping one's system clean.

If you still have the patience, do the following:
- Uninstall KDE3 completely
- Uninstall KDE4 completely
- Reboot
- Uninstall all packages you yourself installed since the original installation
- Looking at the YaST logs in /var/log/YaST2/y2logRPM will help remind you of what you installed
(type:
sudo tail -n 50 /var/log/YaST2/y2logRPM | less
to see the last 50 lines of entries, if necessary, increase the number)
- Reboot
- Re-install KDE3
0
 
allelopathAuthor Commented:
I just reinstalled the whole system.
I was able to backup everything, so no data lost.
Thank you very much for all your effort.
0
 
torimarCommented:
I wish you happy computing with SuSE :)
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now