• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1730
  • Last Modified:

Can't ping Virtual Server from host or other servers and Virtual Server can't ping anyone else.

We have a Dell poweredge 2950 with Broadcom NIC hosting 4 Virtual Servers. After removing Symantec Endpoint Manager we cannot ping any of the VMs from the host or other servers. The VMs can ping themselves but cannot ping anything else including their host. We have a static IP set up and the host and VMs all use the same subnet mask and default gateway and the same DNS servers. I have tried shutting them down, removing the NIC config and readding it but to no avail. There is only one NIC enabled on the host.

These are all Virtual Server 2005 VMs with the latest hotfixes and service packs. I've checked the services that are running on another host and each of it's VMs and all of the services running are the same as well as all of the NIC settings (except of course they have different IP addresses) including the subnet and the gateway.

I can start the VMs up and log into them just fine from Virtual Server Management Console.

Thanks!
0
GCIT_Manager
Asked:
GCIT_Manager
  • 6
  • 6
1 Solution
 
brent_caskeyCommented:
On the virtual switch settings, is the external nic bound to the switch that the VMs are configured to use? I frequently see that the adapters get switched around very easily with the BCOM 5708's that you have on the 2950.

Also, are using teaming with the Broadcom nics, if so, you will need to add the BASP virtual adapter as the host nic in the virtual adapter settings.

0
 
GCIT_ManagerAuthor Commented:
NIC 1 has always been enabled and the other is disabled.

I'm not sure what 'teaming' is.

I'm not sure what BASP virtual adapter is.

I removed the NIC from the VM in the config while it was shut down. then added back in the only NIC the OS sees (since 2nd is disabled).

Incidentally one of these VMs was critical so I moved it to another host, removed and added the new NIC back in and it came up just fine with pinging working. Which makes me think it's not a setting in the OS of the VM. I can't move all our VMs to the 2nd host though.
0
 
brent_caskeyCommented:
Try this,

1. Open the Administration Website.

2. In the navigation pane, under Virtual Networks, point to Configure and then click the appropriate virtual network.

3. Under the settings for the virtual network, make sure that your NIC is selected and not Private, or Internal or None - guest only is selected.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
GCIT_ManagerAuthor Commented:
I don't see "private" as an option. Attached is a picture of the options when i click the drop down menu for the NIC.
VS8-NIC.jpg
0
 
brent_caskeyCommented:
What version of drivers do you have installed? There were some issues with older versions of the drivers and VS2005. You might want to uninstall the current drivers and install the hard drive version of the drivers from support.dell.com.
0
 
GCIT_ManagerAuthor Commented:
drivers for the NIC on host?

what do you mean hard drive drivers?

we're using poweredge 2950 with W2K3 R2 x64
0
 
brent_caskeyCommented:
Update the drivers on the host with this set of drivers: http://ftp.us.dell.com/network/Bcom_LAN_12.4_W2K3_8_64_A03.exe
0
 
GCIT_ManagerAuthor Commented:
Through the wizard when i point it to those drivers it says mine are more up to date. I have the BCM5708C drivers version 4.4.15.

When I say "I have disk" and point to driver file directly, it show all these "monolithic" drivers. See picture.
VS8-NIC-Drivers.jpg
0
 
brent_caskeyCommented:
Dont load the monolitic drivers - in fact with the BCOM drivers, you have to use the installer to get the drivers in correctly.

I dont think it is a driver issue at this point.

I am going to have to do some more research on this one.
0
 
GCIT_ManagerAuthor Commented:
Thanks Brent. I appreciate the help.
0
 
brent_caskeyCommented:
There might have been an issue with the Symantec software leaving something tied to the nics. When you go to the properties of the NIC, do you see any symantec drivers / components?

You may need to delete the virtual switch as well. Delete the VNC file for the virtual switch and in the properties of the nic, uncheck the Virtual Machine network. Click ok and then go back into the properties of the nic and select the virtual machine network. You will need to restart the Virtual Server service in order to be able to add the nic back into a virtual switch. (This will also restart the VMs so make sure they are shut down or in a saved state.)

Let me know if that fixes anything.
0
 
GCIT_ManagerAuthor Commented:
That did it!

I shut down the VMs. Moved the two VNC files to another folder. Went in and recreated the Virtual networks, removed the old NIC settings from the VMs, and then added this new one back in!

One thing to note: I didn't take a chance and just removed both VNC files though possibly I could have just removed the "External" NIC config file. In the External NIC i didn't turn DHCP on. But on the new Internal one I did turn it on and left default settings. I did this mostly because our other host has it set up this way. What I'm not sure about is if I should give it the same subnet as the other host's internal DCHP NIC setting (virtual NIC that is) or leave it alone.

In any case the VMs work again!

Thank you so much.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now