Solved

"Media is write protected" when attempting to modify contents on NFS export mapped through SFU.

Posted on 2008-10-29
6
1,225 Views
Last Modified: 2013-12-02
When attempting to modify contents on a NFS export, mapped via Software Services for Unix, receive error: "Media is write protected". When mapping from client, UID & GID are correct.

- /etc/exports:
/mnt/local *(rw,no_root_squash)

- ls -al:
drwxr-xr-x    3 1067 1039 4096 Oct 24 12:09 directory/

- mount command from XP client:
U:       \\server\mnt\local      UID=1067, GID=1039
                                                rsize=8192, wsize=8192
                                                mount=soft, timeout=0.8
                                                retry=1, locking=yes
                                                fileaccess=755, lang=ANSI
                                                casesensitive=no

From the XP client, the directory is marked read-only. Also, access is extremely slow.

Any help would be greatly appreciated. I've been working on this issue for a week.
0
Comment
Question by:ovnadmin
  • 3
  • 3
6 Comments
 
LVL 23

Expert Comment

by:ComputerTechie
ID: 22925735
it look like a users oermission Error.
make sure user has permission to list folder and read and execute.
CT
0
 

Author Comment

by:ovnadmin
ID: 22929023
The user, 1067, has full permission to the directory.

- ls -al:
drwxr-xr-x    3 1067 1039 4096 Oct 24 12:09 directory/
0
 
LVL 23

Expert Comment

by:ComputerTechie
ID: 22930017
on /mnt/local *(rw,no_root_squash)  they need more access change to drwxr-xr-x
CT
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:ovnadmin
ID: 23046286
drwxr-xr-x is the access level
0
 
LVL 23

Accepted Solution

by:
ComputerTechie earned 500 total points
ID: 23051741
After you export the nfs  you come back and change your /etc/exports file, the changes you make may not take effect immediately. You should run the command exportfs -ra to force nfsd to re-read the /etc/exports   file. If you can't find the exportfs command, then you can kill nfsd with the -HUP flag (see the man pages for kill for details).  
 try this check hosts.allow to make sure you haven't forgotten to list any new client machines there.
Also check the host listings on any firewalls you may have set up
 CT
0
 

Author Closing Comment

by:ovnadmin
ID: 31511307
Without making any further permission changes, ran exportfs -ra and remapped the nfs mount in windows. This did the trick. Thank you so much!
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question