Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Proxy Settings will not update changes via Group Policy

Posted on 2008-10-29
9
Medium Priority
?
2,936 Views
Last Modified: 2013-12-08
On our domain, we use AD Group Policy to push out proxy settings to the computers/users.  We also have enabled "Make Proxy Settings per machine."
"Disable changing proxy settings" is NOT configured at all.

Now, I'm trying to push out a change to the proxy settings.  We have added an exclusion to the sites that bypass the proxy.

Logging in as a regular user that already has a local profile created (ie... they've logged in to that workstation before) fails to update the proxy settings with the new exclusion, and they cannot access the site.  If I use Group Policy Management to run the GP Results for that user on that machine, the report says that they have the new exclusion, but the local workstation doesn't appear to update properly.

However, if I log in to that workstation as an administrator, the new proxy settings are downloaded and applied to ALL users, including the old regular user who coudn't receive the update before the admin login.  We have 90 workstations spread out over 200 miles, and I'm not keen on logging in to every workstation as an administrator to force the update.

Why won't the ammended proxy settings replicate to the workstations when a regular user logs in even though GP Management says that they should have the new setting?  Is there a way to force this change without logging in to every workstation administratively?
0
Comment
Question by:Hayzeus
9 Comments
 
LVL 5

Expert Comment

by:marques_salazar
ID: 22835559
You could try having them open a command prompt and type:   gpupdate /force   then see what happens.
0
 
LVL 35

Expert Comment

by:Joseph Daly
ID: 22835583
Under the group policy in GPMC on the delegation tab do you have the authenticated users with Read permission?

Also you may want to try right clicking on the gpo linked to the OU and select enforce on the menu.

Finally on the client machine try running GPUPDATE /FORCE a couple times followed by a reboot.
0
 

Accepted Solution

by:
chadpants earned 750 total points
ID: 22836269
A couple of things we had to try when we had a similar situation in our environment:

- In GPMC under Computer Configuration->Administrative Templates->System/Group Policy set Loopback Processing mode to Enabled- Replace.

- Drill down into your sysvol folder and make sure to give Everyone read permissions on the Policies folder. We had given read permissions to Authenticated Users, but we were applying the policy to computer objects, which are not considered authenticated users.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:Hayzeus
ID: 22836733
Hi, thanks for the replies.  Here is some more information:

1)  Yes, had already tried gpudate /force to no avail
2)  Several reboots (because you never know when a fourth reboot will fix something lol)
3)  Authenticated users have read/apply permisssions in all areas

I have double-checked the Sysvol permissions, and you are correct in that the Everyone group is not there, but Auth Users is.  Just as an aside, computer objects which have been authenticated in a domain environment are considered part of the Authenticated Users group.

Any other changes made to the policy update properly.  It's just the proxy settings that are not getting updated.
0
 
LVL 35

Expert Comment

by:Joseph Daly
ID: 22836812
Very big longshot here but there isnt another policy somewhere that might be assigning proxy server info is there. Possibly your default domain profile.
0
 

Author Comment

by:Hayzeus
ID: 22836838
Good question, but the answer is no.  There are other GPs being applied, but I have ensured that there are no contradictory settings in the other GPs.  As a secondary verification, I have run the GP Results Query tool to confirm that the computer *should* have the new setting.  For some reason, the new exclusion setting is only picked up after an administrative logon/logoff.
0
 
LVL 35

Assisted Solution

by:Joseph Daly
Joseph Daly earned 750 total points
ID: 22836851
Ok so how about this just for a test. Remove the proxy settings from the GPO and create their own new GPO with only proxy settings and see if those apply. This is a tricky one here.
0
 

Author Comment

by:Hayzeus
ID: 22897945
Okay, so I ran out of time and I used RDP to connect with an administrative login to every workstation in our organization.  What a pain.

So, none of the suggestions offered up actually addressed what I saw as a problem, BUT some of you did suggest some work arounds that I think would work in a pinch.  I'll assign split points in what I hope is a fair manner.

Here's why I think it doesn't work:

1)  In GP, we have the "make settings per machine" enabled.
2)  When a regular user connects, they don't get the updated settings because they do not have enough security clearance to update a "per machine" setting (which should theoretically require admin privileges).
3)  Connecting to the machine as an admin will update the central proxy settings... thus allowing all users to receive the newly updated settings.

The more I think about it, the more I think it's probably working as intended, but I can't help this feeling that there must be a better way to push these settings out.  I know that XXDCmast's suggestion of creating a new GPO (downstream) with the updated settings would work, but it still feels like a jury rig.

thanks everyone for their help.
0
 
LVL 1

Expert Comment

by:TBright163
ID: 24871402
This bulletin may clarify the behaviour going on with this issue.  http://technet.microsoft.com/en-us/library/cc728150(WS.10).aspx
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
In the absence of a fully-fledged GPO Management product like AGPM, the script in this article will provide you with a simple way to watch the domain (or a select OU) for GPOs changes and automatically take backups when policies are added, removed o…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question