Solved

Unable to access ASDM on Cisco ASA 5520

Posted on 2008-10-29
23
17,088 Views
Last Modified: 2012-05-05
I have taken over a network which has an ASA5520.  I can access the ASA via ASDM on the maintenance interface but cannot on the inside interface.  I can download and install asdm but when I try to connect I get :

"ASDM is unable to read the configuration form the ASA.  Please check the configuration and your connection and then try again by clicking the Refresh icon."

I can continue from the error and enter CLI commands to the ASA such as show running-config, etc.  Just cannot get the gui up.

ASDM Version 5.0(5)
ASA Version 7.0(5)

Here is my rc:

Result of the command: "show running-config"
: Saved
:
ASA Version 7.0(5)
!
hostname ******
domain-name ******
enable password ****** encrypted
names
dns-guard
!
interface GigabitEthernet0/0
 description This is the inside interface
 nameif Inside
 security-level 100
 ip address 192.168.201.30 255.255.255.0
!
interface GigabitEthernet0/1
 description This is the outside interface
 nameif Outside
 security-level 0
 ip address ****** 255.255.255.0
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd ****** encrypted
banner exec ******
banner login ******
ftp mode passive
clock timezone EST -5
access-list Inside_nat0_inbound extended permit ip 192.168.201.0 255.255.255.0 192.168.200.32 255.255.255.224
access-list outside_access_in remark Web Mail Rule
access-list outside_access_in extended permit tcp any host ****** eq https
access-list outside_access_in remark VPN Rule for connecting to exchange
access-list outside_access_in extended permit tcp any host ****** eq smtp
access-list outside_access_in extended deny tcp any any
access-list Inside_nat0_outbound extended permit ip 192.168.201.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list split standard permit 192.168.201.0 255.255.255.0
pager lines 24
logging asdm informational
mtu Inside 1500
mtu Outside 1500
mtu management 1500
ip local pool ****** 192.168.201.230-192.168.201.242 mask 255.255.255.0
ip local pool testpool 10.10.10.1-10.10.10.100 mask 255.255.255.0
ip verify reverse-path interface Inside
ip verify reverse-path interface Outside
no failover
monitor-interface Inside
monitor-interface Outside
monitor-interface management
icmp deny any Outside
asdm image disk0:/asdm505.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
global (Outside) 2 ******
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 0.0.0.0 0.0.0.0
nat (management) 0 0.0.0.0 0.0.0.0
static (Inside,Outside) ****** 192.168.201.5 netmask 255.255.255.255
access-group outside_access_in in interface Outside
route Outside 0.0.0.0 0.0.0.0 ****** 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
group-policy DfltGrpPolicy attributes
 banner none
 wins-server value 192.168.201.1
 dns-server value 192.168.201.1
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec webvpn
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock value DefaultRAGroup
 pfs disable
 ipsec-udp enable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain value ******
 split-dns none
 secure-unit-authentication enable
 user-authentication enable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  port-forward-name value Application Access
group-policy ****** internal
group-policy ****** attributes
 banner value You are now connect to ****** Corp. VPN
 banner value
 wins-server value 192.168.201.1
 dns-server value 192.168.201.1
 vpn-tunnel-protocol IPSec
 ip-comp enable
 group-lock value ******
 ipsec-udp enable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split
 default-domain value ******
 webvpn
username ****** password ****** encrypted privilege 15
username ****** attributes
 vpn-group-policy ******
 webvpn
username ****** password ****** encrypted privilege 15
username ****** password ****** encrypted privilege 15
username ****** attributes
aaa authentication enable console LOCAL
aaa authorization command LOCAL
aaa local authentication attempts max-fail 3
http server enable
http 192.168.201.0 255.255.255.0 Inside
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map Outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map Outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map Outside_map 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map interface Outside
isakmp enable Outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
tunnel-group DefaultRAGroup general-attributes
 address-pool ******
 default-group-policy ******
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
tunnel-group ****** type ipsec-ra
tunnel-group ****** general-attributes
 address-pool testpool
 default-group-policy ******
tunnel-group ****** ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group ******
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
vpn-sessiondb max-session-limit 8
vpn-sessiondb max-webvpn-session-limit 2
telnet timeout 10
ssh 0.0.0.0 0.0.0.0 Inside
ssh timeout 60
console timeout 0
management-access Inside
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
webvpn
 title ****** Corp WebVPN Service
 logo file disk0:/******Logo.jpg
 text-color black
 authorization-server-group LOCAL
 authorization-required
smtps
 server 192.168.201.5
 default-group-policy ******
smtp-server 192.168.201.5
privilege cmd level 3 mode exec command perfmon
privilege cmd level 3 mode exec command ping
privilege cmd level 3 mode exec command who
privilege cmd level 3 mode exec command logging
privilege cmd level 3 mode exec command failover
privilege cmd level 3 mode exec command vpn-sessiondb
privilege show level 5 mode exec command running-config
privilege show level 3 mode exec command reload
privilege show level 3 mode exec command mode
privilege show level 3 mode exec command firewall
privilege show level 3 mode exec command interface
privilege show level 3 mode exec command clock
privilege show level 3 mode exec command dns-hosts
privilege show level 3 mode exec command access-list
privilege show level 3 mode exec command logging
privilege show level 3 mode exec command ip
privilege show level 3 mode exec command failover
privilege show level 3 mode exec command asdm
privilege show level 3 mode exec command arp
privilege show level 3 mode exec command route
privilege show level 3 mode exec command ospf
privilege show level 3 mode exec command aaa-server
privilege show level 3 mode exec command aaa
privilege show level 3 mode exec command crypto
privilege show level 3 mode exec command vpn-sessiondb
privilege show level 3 mode exec command ssh
privilege show level 3 mode exec command dhcpd
privilege show level 3 mode exec command vpn
privilege show level 3 mode exec command blocks
privilege show level 3 mode exec command uauth
privilege show level 3 mode configure command interface
privilege show level 3 mode configure command clock
privilege show level 3 mode configure command access-list
privilege show level 3 mode configure command logging
privilege show level 3 mode configure command ip
privilege show level 3 mode configure command failover
privilege show level 5 mode configure command asdm
privilege show level 3 mode configure command arp
privilege show level 3 mode configure command route
privilege show level 3 mode configure command aaa-server
privilege show level 3 mode configure command aaa
privilege show level 3 mode configure command crypto
privilege show level 3 mode configure command vpn-sessiondb
privilege show level 3 mode configure command ssh
privilege show level 3 mode configure command dhcpd
privilege show level 5 mode configure command privilege
privilege clear level 3 mode exec command dns-hosts
privilege clear level 3 mode exec command logging
privilege clear level 3 mode exec command arp
privilege clear level 3 mode exec command aaa-server
privilege clear level 3 mode exec command crypto
privilege cmd level 3 mode configure command failover
privilege clear level 3 mode configure command logging
privilege clear level 3 mode configure command arp
privilege clear level 3 mode configure command crypto
privilege clear level 3 mode configure command aaa-server
: end

Thanx in advance!!

0
Comment
Question by:TGhelpdesk
  • 7
  • 6
  • 2
  • +6
23 Comments
 
LVL 8

Expert Comment

by:CoyotesIT
ID: 22835969
I have seen some problems launching ASDM, I'm never sure of the actual cause, however, and this is an error I have not come across. However, I have been able to resolve the issue by performing a reload and rebooting the ASA. Obviously not the best option without fail over but if you haven't tried that I would recommend it if possible. This has cleared up mysterious issues with ASDM for me each time.
0
 
LVL 5

Expert Comment

by:rexxus
ID: 22838418
Are you able to run the ASDM java applet from the http://x.x.x.x/admin/index.htm URL?
0
 
LVL 5

Expert Comment

by:rexxus
ID: 22838879
Check your proxy settings, as ASDM uses the global internet connection settings listed in the control panel

Might be an exception for the management interface IP address but not the inside interface.  You may need to add the exception for the inside interface.
0
 

Author Comment

by:TGhelpdesk
ID: 22842991
Rexxxus:  The Java Applet will run with the same error.
0
 

Author Comment

by:TGhelpdesk
ID: 22853268
CoyotesIT:  Power cycling does not resolve...
0
 

Author Comment

by:TGhelpdesk
ID: 22853271
rexxus:  Proxy settings are not the problem....
0
 
LVL 5

Expert Comment

by:rexxus
ID: 22854951
I'm wondering if the privilege levels are stopping the connection, I'll have a play in the test lab and check it out
0
 
LVL 5

Expert Comment

by:rexxus
ID: 22859621
Not 100% as been unable to get access to a device to test, but I'm leaning towards webvpn causing issues with asdm access.

If you can get to the cli, try the following commands:

http server enable 65500

then point your browser the https://x.x.x.x:65500 and try the java applet
0
 

Author Comment

by:TGhelpdesk
ID: 22866194
rexxus: http server enable 65500
is not a valid configuration option

USFW01(config)# http server enable 65500
ERROR:    % Invalid input detected at '^' marker.
0
 
LVL 5

Expert Comment

by:rexxus
ID: 22866282
Apologies, had a later OS version bookmarked.

Are you able to provide the contents of the log (sh log), captured from the CLI, when ASDM access fails?
0
 

Author Comment

by:TGhelpdesk
ID: 22891134
rexxus: can you tell me how to enable and capture the log?

thanx!
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 5

Expert Comment

by:rexxus
ID: 22891216
Depending on how much traffic you might be ok using the internal log buffer

conf t
logging enable
logging buffered errors

If the ASA is busy, you may need to have one session open to capture the ASDM failure whilst you try in another session

0
 
LVL 5

Expert Comment

by:rexxus
ID: 22891217
Forgot, use "sh log" to view the log file
0
 
LVL 1

Expert Comment

by:JNRCS
ID: 22901797
im having the same issue accessing adsm on a brand new ASA 5510
0
 
LVL 1

Accepted Solution

by:
JNRCS earned 500 total points
ID: 22901998
I found out the problem, I was having same issue. Uninstall all copies of java from your machine, google search java 1.4.2 and install that and give it a try. worked for me
0
 

Author Closing Comment

by:TGhelpdesk
ID: 31511425
Obviously, ASDM is VERY 'Java Version dependant'!
0
 

Expert Comment

by:fedonm
ID: 22943278
I'm sorry, neither of these worked for me...
For that matter, even 1.6 release 7 is used by my network admin and it works fine.
0
 

Expert Comment

by:bigbrim
ID: 23097616
I was having a similar issue with ASA5510. It seems newer versions of Java is not fully compatible. I had upgraded to Java 6.10, then started having the problem of connecting ADSM unable to continue loading, Unconnected sockets not implemented. Downgraded to Java 6.7 and connection is working fine.
0
 

Expert Comment

by:fedonm
ID: 23134129
Actually, yes.... I compared a working version on my network administrator's system and realized that theonly difference between his machine and mine was the Version of Java. I downgraded from 1.6 release 10 and to 1.6 release 7 and I've been fine since. so if executing any upgrades of JRE or the JVM, I'd suggest testing it first or ensuring that you have a roll-back option.
0
 
LVL 3

Expert Comment

by:omic_admin
ID: 23310861
can't use Java 6 update 10 or higher, has to be update 7 or probably less to work. Could not get 1.4.2 to work correct on a vista client. Got it working by downloading and running Java 6u7
0
 

Expert Comment

by:krpartlow
ID: 24937707
This has worked for me in the past:

After receiving the error, close the error message, stay in the ASDM and then do the following:

In Cisco ASDM go to:
File -> Clear ASDM Cache
File -> Clear Internal Log Buffer
File -> Refresh ASDM with the Running Configuration of the Device
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 35915675
0
 
LVL 3

Expert Comment

by:omic_admin
ID: 35916853
I was finally able to access it after having the ASA updated tot he latest version; after that I was able to use the latest Java update to access the ASDM
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now