Help with DNS error

I have been experiencing connectivity issues with a DC on my student network, in effort to resolve it, I read about NetDiag a tool from Sever 2003 install disk.  I read that it will work on Server 2008 system, so I ran it.  Attached is the report given, in it you will see that DNS test failed.  I tried searching the web for an answer but could not find any thing related to 2008 server.  On this server I also have an extra nic connected to a Dell Powervault storage array.  Not sure if this is related, but when I go into the network configuration on the nic connected to the network, when I close it I get the following message.
"Warning - Multiple default gateways are intended to provide redundancy to a singe network (such as an intranet or the Internet).  They will not function properly when the gateways are on two separate, disjoint networks (such as one on your intranet and one on the Internet).  Do you want to save this configuration?"
Have had this message before in 2003 server, also did not have a Powervault.
Not sure where to look, at this point, over all the system seems to run okay, except (another issue related to DNS) when trying to validate trusts between Staff and Student network, system reports that cannot  find logon server.  There is a lot going on, I think and hope it is wrapped into the DNS issue.  Suggestions are greatly appreciated.
NetDiag.log
ISSitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Patrick49erCommented:
The issue lies in the NIC attached to your PowerVault.  Take the default gateway out and let your server reach it via the NIC on your network.  That will take care of the warning message on your 2008 server.  

On your DNS issue, I'm not sure what you are doing with those 0.0.0.0 as the default gateways.  Take those out and see if this resolves it.
0
Patrick49erCommented:
Host Name. . . . . . . . . : Midgard
        IP Address . . . . . . . . : 192.168.1.3
        Subnet Mask. . . . . . . . : 255.255.255.0
        Default Gateway. . . . . . : 192.168.1.1
        Dns Servers. . . . . . . . : 192.168.1.3
                                              212.33.131.67

I think this is what your server should be using.  Just to clarify, the 0.0.0.0 is not in the same subnet as your 255.255.255.0 mask indicates for NIC1 and NIC2.  That is why it tells you that message.  Those two with the addition of the 192.168.1.1 address on Connection 2 confuses your server.  Just let Connection with the two DNS servers handle the default gateway for your server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Darius GhassemCommented:
It looks like you have an external DNS server listed which is one problem. You are using multiple NICs so you need to uncheck Register this IP address off all NICs except one. Also, you need to configure DNS on this server to listen on one NIC. I don't know why you have your NICs configured the way you do.

http://technet.microsoft.com/en-us/library/cc758119.aspx

http://technet.microsoft.com/en-us/library/cc759481.aspx
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

ISSitAuthor Commented:
Thank you for your responses, to update:
I went in and found the unused Nic (the server came with 2 built in) had to go via the network settings in control panel-a bit different from 2003, anyway found it and deleted the default gateway setting (disabled the card), there goes the error message about gateway settings.  
The additional Nic installed was needed (according to Dell) to access the PowerVault.  When I go to look at the configuration, the default gateway is empty on both cards.  I had previously gone into the DNS settings on the DC and set it only listen to 192.168.1.3 (unchecked the boxes for the other two network cards.  I am considering taking the extra Nic out and installing it in a member server?  Thoughts please.  Thank you again for your time.
0
Darius GhassemCommented:
Have you remove the external DNS server out of your TCP\IP properties?
0
Patrick49erCommented:
Is this your DNS server?  If so, then it does need to have that external DNS server listed.  If it isn't, then Dariusq's recommendation to remove it is right on.
0
ISSitAuthor Commented:
Yes the DNS server is internal, the external DNS was for requests for resources outside of our school.
0
Darius GhassemCommented:
Do an ipconfig /all again and post. You should never have external DNS servers listed in your local network under the TCP\IP settings they should always point to your internal DNS servers then allow the local DNS servers Forward all DNS requests to your ISP DNS servers

http://www.windowsnetworking.com/articles_tutorials/DNS_Conditional_Forwarding_in_Windows_Server_2003.html
0
Patrick49erCommented:
Thanks Darius!  I got that mixed up and so went and looked to see how I had my DNS server configured.  My DNS server does point to itself in the TCP/IP properties, but in the DNS manager I do have the Forwarders going to my ISP's DNS servers.
0
ISSitAuthor Commented:
I have gone in set only the servers IP address as DNS.  I also went in and removed the Dell Powervault (the added nic) and placed on a member server.  DNS still fails but with the attached error, so it is getting better.  I have tried searching the internet for this error with no joy, any ideas?
NetDiag.log
0
Darius GhassemCommented:
Restart the netlogon service.
0
ISSitAuthor Commented:
The last two errors had to do with permissions on the netlogon.dns file.  Checking permissions I found that system and administrator had full rights to the file, when I logged in as administrator and ran the test dns passed.  I logged back in with my usual logon and added that with full permissions.  Ran the netdiag test again and it passed.  Any thoughts on what has happened here?  If DNS passes, am I looking good now?
Thanks all, any other comments will be greatly appreciated.
0
Darius GhassemCommented:
You are looking good the reason you failed was because the username didn't have access to what it needed to test.
0
Patrick49erCommented:
As Dariusq said, it has to do with your permissions.  Remember, you can set up various roles for "administrators."  These roles can be backup operators who while having the ability to backup do not have restore nor view abilities.  This is because in larger organizations you will have folks who are given the "lower" level admin tasks while those like Dariusq are given the "higher" level roles, such as administering the schema of the domain.  Then to add to that, you have domain level roles and forest level roles.  Pretty cool field we are in. :)
0
ISSitAuthor Commented:
Thank you for your input and help, there was no clear-cut solution but each of your inputs led to where I needed to be!  What a great site and group of people!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.