?
Solved

Can't get to internet from DMZ

Posted on 2008-10-29
1
Medium Priority
?
1,030 Views
Last Modified: 2012-05-05
From a computer in DMZ I can't get to internet.  I can get to internal network fine, but not the internet.

Can you help?

Here's my setting below.

 x.x.x. = public IP.

: Saved
: Written by enable_15 at 18:52:10.578 UTC Wed Oct 29 2008
!
ASA Version 8.0(4)3
!
hostname ciscoasa
enable password
passwd
names
name x.x.x52 webserver_public
name 10.19.41.199 webserver_client
name 10.19.42.10 webserver_private
name 10.19.4.0 HQ
!
interface GigabitEthernet0/0
 description WAN
 nameif outside
 security-level 0
 ip address x.x.x51 255.255.255.240
!
interface GigabitEthernet0/1
 nameif inside
 security-level 100
 ip address 10.19.41.250 255.255.255.0
!
interface GigabitEthernet0/2
 description DMZ
 nameif DMZ
 security-level 50
 ip address 10.19.42.250 255.255.255.0
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service DM_INLINE_TCP_1 tcp
 port-object eq ftp
 port-object eq www
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp HQ 255.255.255.0 any time-exceeded
access-list outside_access_in extended permit tcp any host webserver_public object-group DM_INLINE_TCP_1
access-list outside_access_in extended permit ip any any inactive
access-list inside_access_in extended permit tcp 10.19.0.0 255.255.0.0 host x.x.x50 eq ftp inactive
access-list inside_access_in extended permit tcp HQ 255.255.255.0 any eq www inactive
access-list inside_access_in extended permit icmp HQ 255.255.255.0 any echo inactive
access-list inside_access_in extended permit ip any any
access-list inside_nat0_outbound extended permit ip 10.19.0.0 255.255.0.0 10.19.42.0 255.255.255.0
pager lines 24
logging asdm informational
mtu management 1500
mtu outside 1500
mtu inside 1500
mtu DMZ 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
icmp permit any inside
icmp permit any DMZ
asdm image disk0:/asdm-61351.bin
asdm location x.x.x50 255.255.255.255 inside
no asdm history enable
arp timeout 14400
nat-control
global (outside) 101 interface
global (DMZ) 101 10.19.42.1-10.19.42.20 netmask 255.255.255.0
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 101 10.19.0.0 255.255.0.0
static (DMZ,outside) webserver_public webserver_private netmask 255.255.255.255
static (DMZ,inside) webserver_public webserver_private netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 x.x.x49 1
route inside HQ 255.255.255.0 10.19.41.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:63b42c1802d4c23c6a1fc6ff5b3bcdf5
: end
 
0
Comment
Question by:dannyyo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 22840497
Try adding:
nat (DMZ) 101 10.19.42.0 255.255.255.0

0

Featured Post

WatchGuard's M Series Appliances - Miecom Approved

WatchGuard's newest M series appliances were put to the test by Miercom.  We had great results and outperformed all of our competitors in both stateless and stateful traffic throghput scenarios! Ready to see how your UTM appliance stacked up? Download the Miercom Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Optimal Xbox 360 connectivity requires "OPEN NAT". If you use Juniper Netscreen or SSG firewall products in a home setting, the following steps will allow you get rid of the dreaded warning screen below and achieve the best online gaming environment…
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses
Course of the Month14 days, 11 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question