Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 355
  • Last Modified:

SBS 2003 RPC Over HTTP

Greetings all. I have a SBS 2003 server running exchange. I setup RPC over Http using a microsoft document, here is the link -

http://web.archive.org/web/20050114062934/http://support.microsoft.com/kb/833401

I setup the directories in IIS, purchased and installed a go-daddy security certificate, opened the ports in the firewall.

The problem is when I configure outlook to reach the server it just keeps asking for a username and password. I don't get any errors, I just keep getting the username and password prompt. I went directly with a web browser to the rpc directory on the server and the same thing, it keeps prompting me for a username and password no matter what combination I put in.

Can anyone help me out here? I'll be happy to paste more info if needed, I don't know where else to check to get this working.
0
steved309
Asked:
steved309
  • 4
1 Solution
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
SBS has Outlook Anywhere or Outlook RPC/HTTPS setup by default.

Your username format:
domain\FirstLast (or however your domain user names are formatted).
P@ssW0rd!?!

That should do it.

The Remote Web Workplace Help has the appropriate Outlook Anywhere client setup info.

Philip
0
 
tchamtiehCommented:
You have to enable the backend RPC Proxy Settings. Once you do that, reboot and edit the registry for the proxy and then it will work.

Check the Server settings.....

RPC Proxy Registry Keys:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy]
"Enabled"=dword:00000001
"ValidPorts"="<netbios name of server>:593;<netbios name of
server>6001-6002;<netbios name of server>:6004;f<Internal FQDN of
server>:593;<internal FQDN of server>:6001-6002;<internal FQDN of
server>:6004"

If the following value is present in this key delete it:

"AllowAnonymous"=hex(7):31,00,00,00,00,00

More Information:

By default, on a clean install of SBS 2003 the AllowAnonymous value is not
present in the registry key. If it is present, it will cause the error
messages listed in the Problem Description. This is due to the fact that
this value allows us to connect anonymously, and does not pass the
credentials even though we are prompted for them causing Exchange to reject
the connection.

The following KB articles for your reference:

Exchange Server 2003 Client Access Guide
http://technet.microsoft.com/en-us/library/bb123645.aspx

833401 How to configure RPC over HTTP on a single server in Exchange Server 2003 http://support.microsoft.com/?id=833401

841652 How to configure an RPC over HTTP topology on computers that are running
http://support.microsoft.com/?id=841652 

Hope this helps.
-Thomas
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
This is Small Business Server ...

Again, RPC/HTTPS functionality is built-in out of the box. Messing around with the IIS backend will break things in other areas of SBS.

Philip
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
steved309Author Commented:
Mpec -

I know you are saying that it should work out of the box, but it doesn't, or at least I didn't know that, did following that document that I posted break anything?

And it doesn't work, I am testing by going to the server.com/rpc directory and it's asking for a username / password, it just keeps asking for one no matter what I put in.
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
How about using the properly formatted Internet URL that you use for your Remote Web Workplace?

That is the correct URL to use in Outlook: rww.mysbsdomain.com and msstd: rww.mysbsdomain.com along with Basic Authentication.

Again, the proper setup relative to your SBS configuration is to be found in the Remote Web Workplace Help.

Philip
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Thanks for that. :)
Philip
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now