Solved

Setting up static IP  - fedora 9

Posted on 2008-10-29
8
2,128 Views
Last Modified: 2011-10-19
Hi all,

How do i set up static IP on fedora 9 and it stays on when it reboots?

I tried ifconfig --- Works, but does not stay on when it reboots

I tried to edit /etc/sysconfig/network-scipts/ifcfg-eth0, but when it reboots, it's not the right IP.

Even during installation, i set up as static ip (192.168.0.253), when it finished instalaltion and reboot, the ip address is 192.168.0.95 instead of 192.168.0.253
i checked the ifcfg-eth0 file, it stated 192.168.0.253

Please help
0
Comment
Question by:c00kie88
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 40

Accepted Solution

by:
omarfarid earned 125 total points
ID: 22837787
try to set it up using command line tool

setup
        -> Network Configuration
               
0
 

Author Comment

by:c00kie88
ID: 22838031
Hi omarfarid,

I have no gui interface..
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 22838410
you need to run it from command line not gui (e.g. if you ssh or telnet to the system remotely or from the console login from text based terminal)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 6

Expert Comment

by:My name is Mud
ID: 22838681
type... if you installed on setup...

system-config-network
0
 
LVL 6

Expert Comment

by:My name is Mud
ID: 22838694
if not just installed...

yum install system-config-network
0
 
LVL 6

Expert Comment

by:My name is Mud
ID: 22838711
If this is a home configuration, I think the router-modem sets a range like from 64-255 or something like that...
range-DHCP
0
 
LVL 6

Expert Comment

by:My name is Mud
ID: 22838720
Oppsss...
DHCP-range.jpeg
0
 

Author Comment

by:c00kie88
ID: 22846809
Hi there,
se
i found out the problem..

Network manager service is the problem..

I have to disabled NetworkManager service and restart "network service" and my static Ip config picks in :) and it stays when it reboots.

0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question