Solved

i received a bad pool caller error.  how is this fixed?  i have a windows xp os with dell

Posted on 2008-10-29
14
1,212 Views
Last Modified: 2012-05-05
i received the error "bad pool caller"
how do i fix this.  I was trying to open a file through my myscribe.  when i ran it i recieved the blue screen stating it was dumping the memory.  
how do i fix the bad pool caller error?
0
Comment
Question by:brantek
  • 5
  • 2
  • 2
  • +3
14 Comments
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22838612
What did the blue screen say?  It should say something like
BAD_POOL_CALLER. stop: 0×000000c2 (0×000000043, 0xc2528000, 0×00000000, 0×00000000)
But it would be useful to have the complete error.

As is you can try a couple of things.

Run Microsoft's ram checker
http://oca.microsoft.com/en/windiag.asp

Click on Start then run and run chkdsk /r.  Then reboot and it'll run a check on your hard drive.

Click on Start then run and run sfc /scannow (you'll need to have your CD in the drive tray).  This repairs any system files.

If none of those work then you'll probably need to run a repair from your cd.
http://www.geekstogo.com/forum/How-to-repair-Windows-XP-t138.html
0
 
LVL 8

Expert Comment

by:Milan_Ojh
ID: 22838756
0
 
LVL 91

Expert Comment

by:nobus
ID: 22838810
i prefer memtest, since it runs from DOS, not from within windows  :  www.memtest.org
you can also post your minidump to analyse, before running more commands
0
 

Author Comment

by:brantek
ID: 22857826
Run Microsoft's ram checker
http://oca.microsoft.com/en/windiag.asp
I did this and it would not work.  got this onto a disk and shutdown and restarted and it did nothing


Click on Start then run and run chkdsk /r.  Then reboot and it'll run a check on your hard drive.
I did this and my disk is fine.

Click on Start then run and run sfc /scannow (you'll need to have your CD in the drive tray).  This repairs any system files.
This would not work.

If none of those work then you'll probably need to run a repair from your cd.
http://www.geekstogo.com/forum/How-to-repair-Windows-XP-t138.html

Ths cd is a reinstallation cd.  It did not offer the option to repair, just reinstall as updated or new.
0
 
LVL 35

Expert Comment

by:torimar
ID: 22857848
You say a memory dump was written after the crash?

Look for it in c:\windows\minidump, zip it, and post it here as an attachment.
(If there are more than one minidump files, try to match the timestamp in their names with the day when this pool-caller crash happened).
0
 

Author Comment

by:brantek
ID: 22862619
here are the dump files
0
 

Author Comment

by:brantek
ID: 22862648
sorry the did not go through the last time.  had to change the extensions on  the files to zip and then compressed them.  
Dump-Files.zip
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 2

Expert Comment

by:m3tech
ID: 22862717
Bad pool caller often points to memory problems of some form. Microsoft's memtest (http://oca.microsoft.com/en/windiag.asp) is my preffered tool to identify physical ram issues. To run this successfully use the "save cd file to disk" option. Note this will create an iso image file that must be burned to cd using capable software (nero for example, windows will not burn this file successfully).

Please give further details regarding sfc /scannow not working. Open a command prompt (start -> run -> cmd, enter) and type sfc /purgecache (recommeded prior to running sfc /scannow) and press enter. This should return you to a command prompt after a few seconds. Next type sfc /scannow and press enter. This process may take a few minutes. Please report any error messages as this is an internal windows tool and it not working points to other issues with your operating system.
0
 
LVL 35

Expert Comment

by:torimar
ID: 22862915
The dump files indicate that the STOP error is produced by myscribe.exe when invoking Ndis.sys, the network card driver wrapper.

There are three things you could do now to tackle this BSOD:

- try to update your network drivers
- contact the Myscribe community and see whether the issue is known among them
- run Myscribe in offline mode.
0: kd> !analyze -v

*******************************************************************************

*                                                                             *

*                        Bugcheck Analysis                                    *

*                                                                             *

*******************************************************************************
 

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)

An attempt was made to access a pageable (or completely invalid) address at an

interrupt request level (IRQL) that is too high.  This is usually

caused by drivers using improper addresses.

If kernel debugger is available get stack backtrace.

Arguments:

Arg1: 00000008, memory referenced

Arg2: 00000002, IRQL

Arg3: 00000000, value 0 = read operation, 1 = write operation

Arg4: f747e848, address which referenced memory
 

Debugging Details:

------------------
 
 

READ_ADDRESS:  00000008 
 

CURRENT_IRQL:  2
 

FAULTING_IP: 

NDIS!NdisReturnPackets+48

f747e848 8b7308          mov     esi,dword ptr [ebx+8]
 

CUSTOMER_CRASH_COUNT:  2
 

DEFAULT_BUCKET_ID:  DRIVER_FAULT
 

BUGCHECK_STR:  0xD1
 

PROCESS_NAME:  MyScribe.exe
 

LAST_CONTROL_TRANSFER:  from aa26a84c to f747e848
 

STACK_TEXT:  

a917fa80 aa26a84c 849adf20 00000001 a917fc9c NDIS!NdisReturnPackets+0x48

a917fa98 aa26ae36 a917fb1c aa26ae36 849adf08 afd!AfdReturnBuffer+0xe1

a917fd34 805413fc 000004b0 000004ac 00000000 afd!AfdFastConnectionReceive+0x369

a917fd34 00000000 000004b0 000004ac 00000000 nt!KiFastCallEntry+0xfc
 
 

STACK_COMMAND:  kb
 

FOLLOWUP_IP: 

NDIS!NdisReturnPackets+48

f747e848 8b7308          mov     esi,dword ptr [ebx+8]
 

SYMBOL_STACK_INDEX:  0
 

SYMBOL_NAME:  NDIS!NdisReturnPackets+48
 

FOLLOWUP_NAME:  MachineOwner
 

MODULE_NAME: NDIS
 

IMAGE_NAME:  NDIS.SYS
 

DEBUG_FLR_IMAGE_TIMESTAMP:  41107ec3
 

FAILURE_BUCKET_ID:  0xD1_NDIS!NdisReturnPackets+48
 

BUCKET_ID:  0xD1_NDIS!NdisReturnPackets+48
 

Followup: MachineOwner

---------
 

0: kd> lmvm NDIS

start    end        module name

f7469000 f7495a80   NDIS       (pdb symbols)          f:\tmpsymbols\ndis.pdb\42ED3DC0817A4246B157736BBAF668742\ndis.pdb

    Loaded symbol image file: NDIS.SYS

    Mapped memory image file: f:\tmpsymbols\NDIS.SYS\41107EC32ca80\NDIS.SYS

    Image path: NDIS.SYS

    Image name: NDIS.SYS

    Timestamp:        Wed Aug 04 08:14:27 2004 (41107EC3)

    CheckSum:         0003996E

    ImageSize:        0002CA80

    File version:     5.1.2600.2180

    Product version:  5.1.2600.2180

    File flags:       0 (Mask 3F)

    File OS:          40004 NT Win32

    File type:        3.6 Driver

    File date:        00000000.00000000

    Translations:     0409.04b0

    CompanyName:      Microsoft Corporation

    ProductName:      Microsoft® Windows® Operating System

    InternalName:     NDIS.SYS

    OriginalFilename: NDIS.SYS

    ProductVersion:   5.1.2600.2180

    FileVersion:      5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

    FileDescription:  NDIS 5.1 wrapper driver

    LegalCopyright:   © Microsoft Corporation. All rights reserved.

Open in new window

0
 
LVL 2

Expert Comment

by:m3tech
ID: 22863236
More information about Myscribe (vendor, version, etc) is needed, as well as details regarding sfc not running properly. sfc should run, period. If it won't there is likely a more significant issue with your operating system.

Can you verify that this BSOD only happens when trying to use Myscribe, and that you can cause this BSOD at will by using Myscribe in a certain way?

Also check windows system and application logs for errors. (start -> run -> Eventvwr.msc, enter).
0
 

Accepted Solution

by:
brantek earned 0 total points
ID: 22891903
The problem is now resolved.   i ran a complete system and memory check and it showed 100% fine.  this only crashed when i tried to run this program.  So after reinstalling several times and cleaning all residual again and rebooting i was going to try reinstalling the video driver.  But since the error such as driver IRQL and bad pool caller stated memory or video could be the culprit i decided try just reseating the memory.  so i not only did that but i switched slots as well.  after that it showed ast 512 instead of a gig.  so i  just reseated again and the program opened and processed perfectly.  I believe there may be a loose sodder on the mother board, which after pushing on it twice to reseat created a better connection.  
0
 
LVL 91

Expert Comment

by:nobus
ID: 22893162
we all pointed you to the ram
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22896913
I agree with nobus, if we could have ran memtest or gotten the MS ram checker to work then this problem probably would have been resolved earlier.  However, we never did suggest that you switch RAM slots.  Poinks, or no poinks, your call.  I'm glad it's fixed
0
 

Author Comment

by:brantek
ID: 22910122
not only did you  point me towards the ram but the description of the errors in google did as well.  Along with the error on my screen telling me it could be the ram, the video card or the hardware of software that may have just been installled. I ran the tests and found nothing.  Reinstalled the software and nothing.  Cleared the system and ran complete diagnostics and nothing.  Why? because there was nothing wrong with the ram.  the problem seems to be on the motherboard.  The ram is working fine., but im sure somewhere down the line this is going to happen again.   So I think its time to get another one.  But in good faith since you offered assistance i will award some points.  thank you
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

cPanel is a Unix based web hosting control panel that provides a graphical interface and automation tools designed to simplify the process of hosting a web site. cPanel utilizes a 3 tier structure that provides functionality for administrators, rese…
We have adopted the strategy to use Computers in Student Labs as the bulletin boards. The same target can be achieved by using a Login Notice feature in Group policy but it’s not as attractive as graphical wallpapers with message which grabs the att…
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now