PHP exec() not executing php file

I am trying to call a PHP file to run as a background process from another PHP file using the exec() command and it does not appear to be working.  

I have a file called test1.php that just calls a second file test2.php to run in the background.  

Very simple...


exec ("/usr/bin/php -f /path/to/test2.php > /dev/null &");

test2.php just sends out an email to me using the mail function.  (just a basic function to debug and figure out what's wrong).

If I run test2.php from the command line, it works fine.  

php -f /path/to/test2.php - this works fine and I receive the email if I run this in putty.  

If I put test2.php in the public_html directory and go to it directly, that also works fine.  But when I try to call it from another PHP file using exec(), nothing happens.

Also, if I call a basic linux command or another program such as ffmpeg using exec() that all works fine.  It just appears to be calling a php file.  Some google searching has suggested it could be an issue with the php or apache user being set to NOONE and not having permissions.  But I'm not sure about that, or what the best solution is if that's the case.

This is on a dedicated linux server.  Centos 4.7  PHP 5.2.6  safe_mode = Off

Let me know what other info would be helpful.  


Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Are you sure that's the right path to php?
What are its permissions?
Why don't you include the mail module or do it somehow else? You don't need to execute it, do you?
> But when I try to call it from another PHP file using exec(), nothing happens.

Try to analyze the output (if there's any). PHP is compiled with --enable-force-cgi-redirect sometimes which means that calls from shell won't work.
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

NerdsOfTechTechnology ScientistCommented:
Put both files in same directory and try this...
exec ("/usr/bin/php -f test2.php > /dev/null &");

Open in new window

NerdsOfTechTechnology ScientistCommented:
Better yet just include the file (it will run)
include 'test2.php'; // run test2.php

Open in new window

stangill13Author Commented:
Hey guys, the scripts here are just some basic test scripts to get this working.

The ultimate goal is that the first file will be a file uploader (video files).  And once the file is uploaded it will then exec() the second file, which will encode the video to .flv format using ffmpeg.  The mail function was just a test to try to figure out whether or not it's working.  So that's the reason I'm not just including it.  Eventually the second file I'm trying to call will be doing video encoding and I will want that to run in the background.  

sh0e: how can I double check if that is the correct path and it's permissions?

NerdsOfTech: putting the two php files in the same directory has the same result.

caterham_www: what do you mean by analyze the output?


stangill13Author Commented:

I don't believe that is the case --enable-force-cgi-redirect.  From the php info file -

'./configure' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-sqlite-utf8' '--enable-wddx' '--enable-zip' '--prefix=/usr' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mhash=/opt/mhash/' '--with-mime-magic' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-png-dir=/usr' '--with-pspell' '--with-sqlite=shared' '--with-tidy=/opt/tidy/' '--with-ttf' '--with-xmlrpc' '--with-xpm-dir=/usr/X11R6' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr'

I also added the optional output and return_var arguments to the exec call.  The result was output was simply an empty Array() and the return_var was 0.
stangill13Author Commented:
Also, _ENV["PATH"] is /bin:/usr/bin

I assume that's the path to PHP?  And if so, do I have it correct here:

exec ("/usr/bin/php -f /path/to/test2.php > /dev/null &");
Can you try a couple things for me?
At the shell, type: which php

Also, can you try exec("ls -l /path/to/test2.php", $output) and/or exec("cat /path/to/test2.php", $output) in your code and give me the value of $output?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stangill13Author Commented:
Yes that's it, THANK YOU!

which php -> /usr/local/bin/php

Path to php was wrong.  (figures something basic)  I changed that and everything works as it should.  
stangill13Author Commented:

which php -a

does list both paths


It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.