Solved

SBS 2003 - Exchange info store hangs on startup of service

Posted on 2008-10-30
11
323 Views
Last Modified: 2012-05-05
Hi

Prob in brief, SBS 2003 all patched to latest updates, had to restart server after a crash then noticed the server wouldnt start untill i booted into safe mode and turned the exchange info store service to manual then the sbs box will boot normally now when i go to start the exchange info store service the whole os locks up and i have to reboot again, there is nothing in the event logs to suggest any problems?

help needed quickly :)
0
Comment
Question by:nostrasystems
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
11 Comments
 
LVL 11

Expert Comment

by:TWBit
ID: 22839664
Have you tried running ISINTEG or ESEUTIL?

This link explains it in detail.  Make sure you have a valid backup! http://www.msexchange.org/tutorials/Exchange-ISINTEG-ESEUTIL.html
0
 

Author Comment

by:nostrasystems
ID: 22839764
just to update, i have removed the exchange log files to a backup directory and now the exchange info store service will start without crashing the server but the info store will not mount whats my next step?
0
 

Author Comment

by:nostrasystems
ID: 22839802
i get "the database files in the store are inconsistent" when i try mount
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 11

Accepted Solution

by:
TWBit earned 500 total points
ID: 22839834
I wouldn't have touched those files for the exact reason you see.  I would move the files back and run the ISINTEG util as previously noted.
0
 

Author Comment

by:nostrasystems
ID: 22839839
Is below my next step? just backing up what i got database/logs now taking a while

Repair the information store: 1. At a command prompt, change to the drive:\Program Files\Exchsrvr\Bin folder, where drive is the letter of the drive on which Exchange is installed. Use one of the following commands: " If you are trying to restore the mailbox store, type eseutil /p "drive:\Program Files\Exchsrvr\MDBDATA\priv1.edb", and then press ENTER.
" If you are trying to restore the public folder store, type eseutil /p "drive:\Program Files\Exchsrvr\MDBDATA\pub1.edb", and then press ENTER.
 
2. At the command prompt, type eseutil /mh "drive:\Program Files\Exchsrvr\MDBDATA\priv1.edb" (or pub1.edb), and then press ENTER to verify the consistency information that is returned.
3. At the command prompt, type eseutil /d "drive:\Program Files\Exchsrvr\MDBDATA\priv1.edb" (or pub1.edb), and then press ENTER to defragment and to compact the database.
4. At the command prompt, type ISINTEG -S Server_Name -FIX -TEST ALLTESTS, and then press ENTER. Repeat this several times until it reports zero fixes and zero errors.
5. Mount the store.
6. Back up the store.
0
 

Author Comment

by:nostrasystems
ID: 22839852
one question should i put back the old log files even though they crash the system? or are they recreated by the esutil?
0
 
LVL 11

Expert Comment

by:TWBit
ID: 22840211
eseutil /mh is okay, but it won't fix the database, just tell you what is inconsistent.  I would use eseutil /r to recover the database and replay the logs. Hence why the logs shouldn't have been moved.  More text here: http://technet.microsoft.com/en-us/library/aa998075(EXCHG.65).aspx
0
 

Author Comment

by:nostrasystems
ID: 22841089
this is where im confused im right back to the start i put back the databases and log files but the only way i can start the info store service is if i remove the log files once i remove them the service starts and i can run eseutil and insteg otherwise i cant use them so i have put back in the log files after i have sucessfully started the service and im now running is

ISINTEG -S sbs -FIX -TEST ALLTESTS

whats my next step?
0
 

Author Comment

by:nostrasystems
ID: 22841289
can anyone tell me if the information store service should be started or stopped when running eseutil as isinteg will not see the database if its not running some places on the net say stop info store service when using eseutil?
0
 
LVL 11

Expert Comment

by:TWBit
ID: 22841450
Yes, the store does need to be stopped when running eseutil
0
 

Author Comment

by:nostrasystems
ID: 22841908
all fixed i went back to the start and put back the copy of the database and log files and ran

ISINTEG -S sbs -FIX -TEST ALLTESTS

i had to copy out the log files then start info store service then copy them back in and then run the above after it fixed errors i mounted the two databases priv and pub and all is good after a sanity check rebbot :)

thank you
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question