?
Solved

Message "unavailable database" when running gfix or gbak

Posted on 2008-10-30
22
Medium Priority
?
7,098 Views
Last Modified: 2013-12-09
Whenever I try to run the interbase commands gfix or gbak in a command window against a database on a w2k3 server, I get the message "unavailable database".

The database exists, Interbase is running and my user profile has full control permissions at root share, folder and file levels.

The command used is:

"C:\Program Files\Borland\InterBase\bin\gfix.exe" -v -full -user SYSDBA -pass <pword> dbfilename.gdb

Could enyone explain this and suggest a solution, please?
0
Comment
Question by:DerrickT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 7
  • 3
  • +1
22 Comments
 
LVL 4

Expert Comment

by:dprochownik
ID: 22839902
At first try use full path for database file name, not a relative one as in yours example.
As I remembered, I had similar problems on w2k3 and relative paths were responsible for that

"C:\Program Files\Borland\InterBase\bin\gfix.exe" -v -full -user SYSDBA -pass <pword> <full path>\dbfilename.gdb
0
 

Author Comment

by:DerrickT
ID: 22839962
Hi dprochownik,

No luck with that one.  I have tried that with the same result.
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22840173
is everybody else logged out ?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:DerrickT
ID: 22840288
There are no users attached to the database.
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22840307
are your running this from the server ?

only works locally
0
 

Author Comment

by:DerrickT
ID: 22840407
Yes.  I am logged onto the server using RDC.  I have local administrator rights and, as I said, full control permissions from the top down.

I have been using the command line interface for more years than I care to admit on Linux servers, it just doesn't seem to want to work on the Windows platform.

0
 
LVL 4

Expert Comment

by:dprochownik
ID: 22840445
You wrote -pass parameter. I'm not sure, but I think that in windows it has to be full -password
0
 

Author Comment

by:DerrickT
ID: 22840468
Nice try, dprochownik but no cigar.  Same result.
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22840476
it doesn't say file name, but db_name ...
have you tried using the name of the database ?

without the extension ?


0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22840490
it's actually
-pa MASTERPASSWORD
0
 
LVL 38

Accepted Solution

by:
Geert Gruwez earned 1000 total points
ID: 22840496
when using RDC you use the option /console ?
0
 
LVL 4

Expert Comment

by:dprochownik
ID: 22840542
which version of interbase are you using ?
0
 

Author Comment

by:DerrickT
ID: 22840673
This is interbase 2007 (v8).

I'm not logged in via RDC using /console.  I'll try that although I don't expect it will be an issue.

I have tried all permutations of -p to -password and have used the full database name including the extension in the command line.  The same result is produced when dropping the extension.  I have tried in on a range of viable databases, all with the same result.

I am beginning to wonder if this is another one of those wonderful and extremely useful undocumented features provided by the Windows development team.
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22840838
nothing to do with Windows

have you run it from the directory where the database file resides ?

in the cmd

cd \
cd yourdatabasedirectory

"C:\Program Files\Borland\InterBase\bin\gfix.exe" -v -full -user SYSDBA -pass MASTERKEY dbfilename.gdb
0
 
LVL 19

Assisted Solution

by:NickUpson
NickUpson earned 1000 total points
ID: 22841431
remember that you cannot access the database file via share,

I remeber there was an issue with doing this via any form of remote desktop, please try running on the actual machine console
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22841778
NickUpson is right
sometimes we have issues too with Remote Desktop
so we use alternatives

there are other forms of remote desktop
which probably won't have these issues
these tend to emulate keyboard/mouse on the remote machine
they usually need a service to be installed on the server
some can push the service to the server

vnc
www.realvnc.com/

remote admin (radmin)
www.radmin.com/

Dameware
www.dameware.com


0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22841937
i ran it from the command line and i had to use the full parameter name options to make it work
from the database directory on the server

C:\Company\DataInterbase>"c:\Program Files\InterBase Corp\InterBase\bin\gfix
.exe" -validate -full -user SYSDBA -password masterkey Company.gdb
0
 

Author Closing Comment

by:DerrickT
ID: 31511610
This will only run if you are logged in either at the console or using mstsc/console.

Thanks to everybody for their input.
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22841978
did something not work completely as you gave a B grade ?
0
 

Author Comment

by:DerrickT
ID: 22841999
Sorry about that, I'm an EE newbie.  Should have been A.

Any idea how I can change it?
0
 
LVL 38

Expert Comment

by:Geert Gruwez
ID: 22842081
hit the button Request attention at the top,
but first read this:
http://www.experts-exchange.com/help.jsp#hs29

EE is a great site for getting solutions.
Solutions are provided by volunteers who do this in their spare time.
There is only A, B and C.
A the solution works
B I had to look some things up and modify for this to work
--> give comments that something doesn't work, = feedback
      and maybe you'll get a better solution
      it at least gives the expert the change to provide a better one
C well if you must, but make sure to give comments why



0

Featured Post

Get MySQL database support online, now!

At Percona’s web store you can order your MySQL database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A Stored Procedure in Microsoft SQL Server is a powerful feature that it can be used to execute the Data Manipulation Language (DML) or Data Definition Language (DDL). Depending on business requirements, a single Stored Procedure can return differe…
In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller singl…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question