Solved

Having difficulties creating Power Options .adm file for GP.

Posted on 2008-10-30
2
913 Views
Last Modified: 2012-06-27
CLASS USER
CATEGORY !!ControlPanel
    CATEGORY !!PowerOptionsCat
 
            POLICY !!PowerConfigurationCfg
      KEYNAME "Control Panel\PowerCfg"
      PART !!PowerScheme DROPDOWNLIST REQUIRED
                     VALUENAME "CurrentPowerPolicy"
                               ITEMLIST
                                   NAME !!PowerSchemeHomeOfficeDesk   VALUE NUMERIC 0
                                   NAME !!PowerSchemePortableLaptop      VALUE NUMERIC 1
                    NAME !!PowerSchemePresentation          VALUE NUMERIC 2 DEFAULT
                                   NAME !!PowerSchemeAlwaysOn             VALUE NUMERIC 3
                    NAME !!PowerSchemeMinimalPowerManagement VALUE NUMERIC 4
                                   NAME !!PowerSchemeMaxBattery            VALUE NUMERIC 5
                              END ITEMLIST
      END PART            
            END POLICY

     END CATEGORY
END CATEGORY

[strings]
ControlPanel="Control Panel"
PowerOptionsCat="Power Options"

PowerConfigurationCfg="Power Configuration"

PowerScheme="Configure Power Settings:"
PowerSchemeHomeOfficeDesk="Home/Office Desk"
PowerSchemePortableLaptop="Portable/Laptop"
PowerSchemePresentation="Presentation"
PowerSchemeAlwaysOn="Always On"
PowerSchemeMinimalPowerManagement="Minimal Power Management"
PowerSchemeMaxBattery="Max Battery"

I have created a power.adm file from the text above. However, when I add the template to Local Policy on an XP Pro machine the only thing that shows up is a Power Options container under Control Panel with nothing else inside. In other words it creates a container for the policy I wish to configure but it is empty. I think it may have to do with the fact that it is trying to reference a registry string [CurrentPowerPolicy] instead of a DWORD or BINARY type. I'm not sure what to substitute in place of the VALUE type of NUMERIC to change a string's data value.
0
Comment
Question by:Ace2817
2 Comments
 
LVL 31

Accepted Solution

by:
Toni Uranjek earned 500 total points
ID: 22932083
Hi!

Go to Administrative templates, the clikc View menu, select Filtering and clear check box in front of "Only show policy settings that can be fully managed".

HTH

Toni
0
 

Author Closing Comment

by:Ace2817
ID: 31511707
Thanks,
It can be the simplest settings that are the most frustrating.

Shawn
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

Suggested Solutions

On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now