Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Connect VMworkstation virtual machine to internet throgh the host PC

Posted on 2008-10-30
14
Medium Priority
?
2,574 Views
Last Modified: 2012-05-05
Hi all, I have a small problem in what I thought would be a straight forward task.
My goal is to have a functioning copy of Win2k3 server running on VM workstation (I need the USB support for this task) which can both contact the internet and also access the host PC (Vista Business).
The virtual machine is running well. I originally created it on Virtual PC 2007 but it's lack of USB support pushed me onto VMware. So my question is how can I get the network connection on the VM to work.

Noob on virtualisation so if you could use small words and avoid sudden jerky movements I'd appreciate it.
0
Comment
Question by:Wafu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
  • +1
14 Comments
 
LVL 11

Expert Comment

by:lbertacco
ID: 22842863
It can depend on how your host pc is connected to the internet, but assuming that you have a lan with a dhcp server that correctly pass ip, dns and gateway address, you just need to set the VM network adapter to BRIDGED mode.
0
 
LVL 11

Expert Comment

by:lbertacco
ID: 22842885
In Bridged mode, the VM will behave as if it is just another machine on the LAN. Alternatively you can use NAT mode, in which case your host pc behaves like a NATting router and the VM will access the internet with your host pc's IP address.
0
 
LVL 10

Expert Comment

by:Andrew Doades
ID: 22842894
if you network setting is bridged,  this will use your hosts network connection to connect to the internet and you can have your own ip address.
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:Wafu
ID: 22842911
Sorry, left that part out. The host connects through a DHCP enabled router.

How do I place it into Bridged mode?

0
 
LVL 11

Expert Comment

by:lbertacco
ID: 22843065
Stop the VM (if it is running), click on "Edit the Virtual Machine settings" and then click on the Ethernet device. You can choose between Brdiged, NAT or Host-only. Pick Bridged.
0
 

Author Comment

by:Wafu
ID: 22843187
Bridged is already selected there.
0
 
LVL 11

Expert Comment

by:lbertacco
ID: 22843276
Well, then check the network status of the vm. Does it get an IP? What dns and gateway is it pointing to?
0
 

Author Comment

by:Wafu
ID: 22843792
VM is simply reporting media disconnected

However within the VM settings page the 'replicate physical network connection state' is unchecked.
0
 
LVL 9

Expert Comment

by:sda100
ID: 22843967
You may need to check that VMware is bridging with the correct physical network adapter (if you have more than one).

Steve :)
0
 

Author Comment

by:Wafu
ID: 22843981
Ok, if I tick this box I get a question mark over the connection state box in the sys tray and a message saying that it can't renew the IP address when I try to repair it.
0
 
LVL 9

Accepted Solution

by:
sda100 earned 1000 total points
ID: 22844068
Ok - but that might be a problem with your DHCP server.

At this stage, I'd say reboot the guest machine and see if it picks up an address.  If it doesn't, manually give the guest an IP address and other relevant settings, of a free IP address on your network.  Does this work?

Steve
--
0
 
LVL 11

Assisted Solution

by:lbertacco
lbertacco earned 1000 total points
ID: 22844816
While the VM is running, if you click on the ethernet adapter in the lower right border, make sure that the "connected" checkbox is marked. When you mark it, windows should detect "cable connected". Also make sure the the host pc can access the internet BEFORE starting the vm.
0
 

Author Comment

by:Wafu
ID: 22848813
Ok , having played around with this in to the small hours, I can connect to the internet only if I select NAT, connect to the host only if I use host only, but I can't connect to anything while selecting bridge. Just to clarify earlier the ? over the network connection symbol was in the systray of the 2k3 machine(virtual).

Anything else to check to get the bridge working? Do I need to configure the host in anyway?
0
 

Author Closing Comment

by:Wafu
ID: 31511747
Unfortunately I ran out of time on this one and had to change tack. Thanks for the help regardless guys. Hopefully it will aid someone else.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question