Solved

Active Sync is prompting users for username and password

Posted on 2008-10-30
13
501 Views
Last Modified: 2012-06-21
I just fixed an OWA problem by resetting the exchange iis virtual directories as described in this article:  http://www.msexchange.org/tutorials/Resetting-OWA-Folder-IIS-security-permissions-Exchange-2003.html it seemed to work wonderfully but now my mobile users are having trouble accessing Active Sync. They have been using Active Sync on their windows mobile phones for awhile and now they are seeing the login prompt and are unable to log in. I think perhaps I need to change the security settings on the active sync virtual directory but I'm not sure what to choose.  At this point there are no items checked in the Directory Security Authentication Methods dialog box for the Active Sync Virtual Directory.
0
Comment
Question by:DawnMcCreary
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 3
13 Comments
 
LVL 14

Expert Comment

by:dfxdeimos
ID: 22843876
Do they connect via SSL? If so try checking the basic authentication option.
0
 

Author Comment

by:DawnMcCreary
ID: 22844499
I checked basic authenticaiton and it is still not allowing active sync.
0
 
LVL 14

Expert Comment

by:dfxdeimos
ID: 22844548
Do you use SSL?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 14

Expert Comment

by:dfxdeimos
ID: 22844558
Also, does it report an error code?

Do you see any relevant event log entries on the Exchange server?
0
 
LVL 33

Accepted Solution

by:
Exchange_Geek earned 500 total points
ID: 22844562
0
 

Author Comment

by:DawnMcCreary
ID: 22844743
We do not use ssl. The only error code appeared after I tried to access OMA. I see OMA error 1503. I'm working on the links in the answer above now.
0
 

Author Comment

by:DawnMcCreary
ID: 22844982
I checked basic on the Exchagne-OMA virtual directory and was able to get to OMA. However my test user is still unable to sync with active sync.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22845107
Glad to see atleast OMA started to work. How about Auth on Active Sync ??
0
 

Author Comment

by:DawnMcCreary
ID: 22849072
Active Sync Auth is set to basic only
0
 

Author Comment

by:DawnMcCreary
ID: 22850460
Here are my auth settings in Exchange IIS:
OMA = Basic - Default Domain \
MobileAdmin = Basic Default Domain \
ActiveSync=Basic - Default Domain \
GroupShield = Non Selected
ExchWEb = Enable Anonymous
Exchage-OMA = Basic - Default Domain and Realm crcindustries.local
Exchange = Basic - Default Domain and Realm crcindustries.local
EXAdmin=Integrated
OWA is working as expected, windows mobile devices not able to connect. Device prompts for username and PW and does not successfully connect. I can connect to OMA with a browser.
0
 

Author Comment

by:DawnMcCreary
ID: 22867885
I found the answer to my active sync problem. This site lists the active sync errors. My error was 85010014.
http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php
I tried the very first suggestion for 85010014 "Verify that the HTTP server is available and try again. May require user to de-select sync items (Inbox, Contacts, Calendar, Tasks) and re-select them to reset the sync key." and it worked. Deselect all items on the PDA or Phone then reselect them. Wonderful.
Thanks everyone for taking the time to troubleshoot this for me. I'll award the points to Exchange Geek because his suggestions made sure my settings were correct before going forward.
0
 

Author Closing Comment

by:DawnMcCreary
ID: 31511792
The settings suggested were perfect for the exchange server. However, the next step is to reset Active Sync on the PDAs and phones. Thanks for all of your help.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22867958
Wow, glad to see your issue solved - good solution offered for EE Forums.

Take care.
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question