• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3010
  • Last Modified:

Remote Desktop:" Terminal Server has exceeded maximum number of allowed connections.."

I recieving this message when attempting to log on to a network server via Remote Desktop "Terminal Server has exceeded maximum number of allowed connections" i suspect my off sight programmers are logged on.  How would i use terminal services to make another connection past the 2 concurrent max Remote Desktop offers?? Also how do I view active connections on a network server??
0
thirsty4knowledge
Asked:
thirsty4knowledge
  • 6
  • 4
  • 4
  • +4
1 Solution
 
CrashDummy_MSCommented:
If the server is configured for remote administration, as in terminal server licenses are not being used, then you get 2 remote connections plus 1 console connection. You can use the console connection remotely too, just go to start, run and use "mstsc /admin" (may be "mstsc /console" on some remote desktop clients).

From there you can kick the old sessions off. Go to control panel, administrative tools, terminal services manager.
0
 
CrashDummy_MSCommented:
Also, you may want to go into Terminal Services Configuration, go to properties for RDP-Tcp, to the sessions tab and set limits so that ended or idle sessions are automatically killed after a time.
0
 
jdietrichCommented:
You can log in to the cosole (Admin).  To make more connections you need to purchase licenses.  If the off site programmers are not logging out, but X'ing out of the session it will keep the connections alive while they are really not in use.  Tell them to log off when done.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
nappy_dCommented:
You will need to:

  • Setup a Terminal Licensing server
  • Purchase and Install Terminal Licenses
  • Put your Terminal server into Application mode
NOTE: MS is pretty strict with the licensing.  You typicall need to purchase a for each and every user that you may have in the office.  This means, even if you have 5 users that use the terminal serverbut you have a office of 20 users, MS makes you pay for 20 user licenses.

This is how it was listed in their EULA the last time I cheked about 6 months ago.
0
 
thirsty4knowledgeAuthor Commented:

I dont want to kick the old session off because my offsite programmers are likely earnestly using those connections.  Plus i dont know contact info for them to confirm.  So I want to verify connections and create a new one.  Does this make sense?
0
 
CrashDummy_MSCommented:
Using the /admin switch will let you get a 3rd connection, but for any additional you'll need to set the server up as a full fledged terminal server, purchase licenses, etc.
0
 
thirsty4knowledgeAuthor Commented:
How do i get to terminal services via my system??
0
 
nappy_dCommented:
With Termianl server in Administrative mode, you only get two concurrent connections.

Unless you already have something such as VNC installed this is the only way you can get a third connection to the server via its console.

Are you in the same area as the server? If so, you can user the terminal services manager to see if they are connected and send them a message.
0
 
CrashDummy_MSCommented:
Nappy, if you run the terminal services client with the /admin switch you can log into the console, which basically gives you a 3rd remote session. "mstsc /admin"
0
 
nappy_dCommented:
open your run command line and then enter "mstc /admin" without the quotes
0
 
nappy_dCommented:
:) you beat me to it :)
0
 
thirsty4knowledgeAuthor Commented:

ok, i tried this: mstsc/admin/ v: server5
Dosn't seem to be working any ideas??
0
 
CrashDummy_MSCommented:
"mstsc /admin /v:server5"
0
 
CrashDummy_MSCommented:
You may also try "mstsc /console"
I believe that was the command on some old versions of remote desktop.
0
 
thirsty4knowledgeAuthor Commented:

Yes, i tried removing the space before and that didn't work.  The console command works but that's the same console i get when i use remote desktop and once i type the destination server and try to connect this is where i recieve the error: "Terminal Server has exceeded maximum number of allowed connections".  
How can i get to a point where im viewing current connections with desire desitination server, logon to destination server without logging off current connections.  If no options are available to do the previously mentioned.  How can i force log off other connections??
0
 
mSproutCommented:
0
 
t0dd_swCommented:
uhh, what version of server are you running? /Console switch only works on 2003 and higher as i recall. You can view active sessions by running tsadmin from another server on the same domain, then select the server in question. Needs to be same version or higher OS than your target. From the tsadmin program, you can send a message to the session (rt click, send message)
0
 
Glen KnightCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 6
  • 4
  • 4
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now