linux user change password

Dear Sir:

I have redhat enterprise linux version 5 with many user accounts , many of them login from internet , like ftp i want them login to the server through ssh and they are able to do so but when they try to change their password it is not happening , please tell me how to set this option for them so that they can change their password , as of now when they try following is the error message:
Changing password for user mt.
Changing password for mt
(current) UNIX password:
passwd: Authentication token manipulation error

please help me to set this.

D_wathiAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
dainokConnect With a Mentor Commented:
I suppose you have an entry for the mt user in /etc/passwd file. Check also /etc/shadow; you should have a entry for mt user in it. If /etc/shadow entry miss, mt user can't login (and also can't change password).

To fix it, I suggest you to duplicate another shadow entry, and change the first field according to mt username. Finally change mt password using passwd.

cat /etc/passwd | grep mt
mt:x:100:100:Mt User:/home/mt:/bin/bash

cat /etc/shadow | grep mt
mt:!!:6445::::::

"!!" in shadow file means password not set
0
 
frandshansenCommented:
How do you add users to your system?
0
 
michofreihaCommented:
check if the users  are created under passwd....if yes check the permissions for that file and let us know
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
fosiul01Commented:
what is the permission of

 /usr/bin/passwd ??

ls -l | grep passwd
0
 
michofreihaCommented:
go to the location of your passwd file (most probably in /etc), make ls -l and check the permissions of that file..You should have something like the below:

-rw-r--r--  1 root   root    1804 Oct 13 09:28 passwd
0
 
D_wathiAuthor Commented:
Thanks for the reply.
yes,  it is -rw-r--r--    1 rot root passwd.

how to make changes so that users can change their passwords.



0
 
fosiul01Commented:
what permission you got here

 /usr/bin/passwd ??  
0
 
D_wathiAuthor Commented:
Sir, i think SE LINUX is preventing to do so also thinh if disabled then they are able to change the passwd but by keeping the SE Linux in enforcing mode still they should be also to change the password , how to do this please help.
0
 
nabeelmoiduCommented:
in /var/log/messages you normally get a message with an instruction to run a sealert with some no....
when you run that , you get the instruction on which selinux variable to modify .

check your /var/log/messages and /var/log/security
0
 
D_wathiAuthor Commented:
Thanks for the reply,
I am looking for the user himself should be able to change the password as a root iam able to do so but i require the user himself to do this for his login , by logging in through ssh
user test login through ssh to the server when try to change his password folloing is the error message:
[test@parrot ~]$ passwd
Changing password for user test.
Changing password for test
(current) UNIX password:
passwd: Authentication token manipulation error

please suggest me how to enable this for the user
Thanks in advance.
0
 
dainokCommented:
As root type: pwck
And check the integrity of passwd, shadow and group file. Post (or fix) the result and retry the passwd command.
Tell us what happen.
0
 
D_wathiAuthor Commented:
Thanks for the reply, done as suggested :
[root@parrot ~]# pwck
user adm: directory /var/adm does not exist
user news: directory /etc/news does not exist
user uucp: directory /var/spool/uucp does not exist
user gopher: directory /var/gopher does not exist
user pcap: directory /var/arpwatch does not exist
user sabayon: directory /home/sabayon does not exist
user callstreet: directory /home/callstreet does not exist
user mt1: directory /home/mt1 does not exist
user ind: directory /home/Home_Directory does not exist
user indar_k: directory /home/Home_Directory/indar does not exist
user truecare: directory /home/truecare does not exist
pwck: no changes
[root@parrot ~]#

Please note:
As a root iam able to change everbody's password but my requirement is userhimself should be able to change their password by doing ssh to the server , please help
0
 
dainokCommented:
Maybe passwd loose suid bit; try:

# which passwd
/usr/bin/passwd

# ll /usr/bin/passwd
-rwsr-xr-x 1 root root 22960 Jul 17  2006 /usr/bin/passwd

The 's' mean that if a user run passwd, passwd run as root. If you don't have the 's', as root type:
# chmod 4755 /usr/bin/passwd

If you still have the problem, you should try to change a password and read (and post) /var/log/messages.
0
All Courses

From novice to tech pro — start learning today.