Solved

Problem with accent and other symbols in Windows XP

Posted on 2008-10-30
12
401 Views
Last Modified: 2008-11-23
When I open a web page the content show me characters in cyrillic (for example the accents, 9 for é, J por ú, = por í ...etc). That's happends in other program (not only in IE v6) in general ....

I think I could be an encoding problem ...

I'm using Windows XP (i recently update to SP 3 after that problem) ...  

I just scan my computer for virus (with Kaspersky) and for spyware (AdAware, HijackThis, Spy Bot) and everything is correct ...

Any ideas ?
0
Comment
Question by:sminfo
  • 5
  • 5
  • 2
12 Comments
 
LVL 50

Expert Comment

by:jcimarron
ID: 22846708
sminfo--Click IE View|Encoding|More.  Is the checkmark next to Cyrillic?  If not what Encoding is checked?  I get the feeling you are not located in the USA so do not know what Encoding should be default.   You could try AutoSelect and let the page decide.
0
 
LVL 14

Expert Comment

by:igor-1965
ID: 22847979
In Control Panel start Regional and Language settings (you have to run it as administrator) and check out Advanced language settings for non-Unicode programs - it should match your language. If you need to change this setting - tick the box Make changes to current user and to Default User.  In case if you normally working under the account that is not having administrative rights on the computer then temporarily add this account to the administrators group, make change, reboot computer then remove the account from Administrators.
 
0
 

Author Comment

by:sminfo
ID: 22850710
The problem is not only in IE. For example if I receive an email with Microsoft Oulook 2003 and the sender name have accent characters or something like that I receive it with 'special' character ...

I try changing the Regional Option settings for for non-Unicode programs, but the problem continues ...

I try too changing  the  View|Encoding option in IE checking and unchecking Auto-Select, selecting Western European (Windows), Unicode (UTF-8) and nothing happends ...

0
 
LVL 14

Expert Comment

by:igor-1965
ID: 22851106
Could you be a bit more specific? I mean, by saying what your settings are.

What you have set in Regional and Language Options in Control Panel? Please note that the changes in this settings require reboot.

Also, have you checked in Internet Explorer | Internet Options | Languages | Language Preferences? What are your settings?
0
 

Author Comment

by:sminfo
ID: 22851317
IE language:  English (United States) [en-us]

Regional and Language Option:  English (United States) (In every Tab and every option of this configuration)
0
 
LVL 14

Expert Comment

by:igor-1965
ID: 22851380
What is the setting in in Internet Explorer | Internet Options | Fonts?
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 

Author Comment

by:sminfo
ID: 22851485
Web page font Times New Roman
Plain text font Courier New
And in Language Script is selected Cyrillic ...but anytime I change to Latin based when I enter a new IE seesion it's not keeped (continues with Cyrillic)...
0
 
LVL 14

Expert Comment

by:igor-1965
ID: 22852590
I found some hits here: http://www3.ntu.edu.sg/home5/PG03053527/Tips/TipsForIE/Tip_for_IE.htm (the solution the article mention seems not be working in XP / IE7 - the registry settings must been change since that).

I think you are actually having a problem with Regional Settings (Advanced)  - the code page conversion tables are not set properly or somehow corrupted.

What I would advised to try is to change Non-Unicode program language to English (United Kingdom) and when prompted to use the installed fonts, answer No so the codes would been (re)loaded from Windows Installation CD. Reboot computer then change it back to your previous settings (English - US) and again answer No when prompted to use the installed fonts.


0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22853174
sminfo--From IE Help
"To override website font and color settings
If you want to have the fonts and colors you specify in Internet Explorer to be used for all websites, regardless of the fonts that have been set by the website designer, follow these steps.
In Internet Explorer, click the Tools button, and then click Internet Options.
On the General tab, click Accessibility.
Select the Ignore colors specified on webpages, Ignore font styles specified on webpages, and Ignore font sizes specified on webpages check boxes, and then click OK twice.


Changing webpage fonts and background colors
When web authors and designers create webpages, they often specify particular typefaces, fonts, colors, sizes, and background colors. These settings are specified for each item or they are set in a style sheet, which is a type of template for specifying how different styles should appear throughout a webpage or site.
You can override any or all of these settings."
If this problem started only recently you could try a System Restore.

P.S.  In one of your posts above you said "I try too changing  the  View|Encoding option in IE checking and unchecking Auto-Select"  I had suggested you check AutoSelect if it was not checked.  Does that mean AutoSelect was checked while you had the problem originally?


0
 

Author Comment

by:sminfo
ID: 22853712
I try a System Restore at first time but it doesn't repair anything ...

At this moment I have checked AutoSelect ...
0
 

Accepted Solution

by:
sminfo earned 0 total points
ID: 22877553
I finally found the solution .... In the registry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage the entry 1252 had c_1251.nls as value ...

I change that (1252 = c_1252.nls, 1251=c_1251.nls and so on).

For that I export HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls from another machine that was working OK y after that restart the computer ...

Now, everything is working OK again ...
0
 
LVL 14

Expert Comment

by:igor-1965
ID: 22879135
Congratulations!
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the time we are in fix when all of sudden our systems behave weirdly.  Such problems cost time and effort... so it's best to take some preventive actions so that we can avoid such issues or overcome such problems more easily. Preventive M…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now