Solved

Why can I ping my Pix 506e external interface?

Posted on 2008-10-30
4
547 Views
Last Modified: 2012-05-05
I've just finished re-tasking a Pix 506e.
I can connect to it with the client, and get access to the resources behind it that I want.  However, for some reason,  I can still ping the external interface from outside.  What am I missing?







PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxx encrypted
passwd xxxxx encrypted
hostname remote
domain-name xxxxxx.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list inpackets deny ip host 0.0.0.0 any
access-list inpackets deny ip 10.0.0.0 255.0.0.0 any
access-list inpackets deny ip 172.16.0.0 255.240.0.0 any
access-list inpackets deny ip 192.168.0.0 255.255.0.0 any
access-list 90 permit icmp 10.10.4.0 255.255.255.0 192.168.224.0 255.255.255.0
access-list 90 permit ip 10.10.4.0 255.255.255.0 192.168.224.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 205.x.x.x 255.255.255.224
ip address inside 10.10.4.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnaddresses 192.168.224.1-192.168.224.20
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 90
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inpackets in interface outside
route outside 0.0.0.0 0.0.0.0 205.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community xxxxx
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt ipsec pl-compatible
crypto ipsec transform-set CSClient esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 86400
crypto dynamic-map CSecure 10 set transform-set CSClient
crypto dynamic-map CSecure 10 set security-association lifetime seconds 28800 kilobytes 4608000
crypto map vpnmap 10 ipsec-isakmp dynamic CSecure
crypto map vpnmap client configuration address initiate
crypto map vpnmap client authentication LOCAL
crypto map vpnmap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local vpnaddresses outside
isakmp nat-traversal 20
isakmp policy 2 authentication rsa-sig
isakmp policy 2 encryption des
isakmp policy 2 hash sha
isakmp policy 2 group 1
isakmp policy 2 lifetime 86400
isakmp policy 3 authentication pre-share
isakmp policy 3 encryption 3des
isakmp policy 3 hash md5
isakmp policy 3 group 2
isakmp policy 3 lifetime 86400
vpngroup xxxxxx address-pool vpnaddresses
vpngroup xxxxxx default-domain xxxxxx.com
vpngroup xxxxxx split-tunnel 90
vpngroup xxxxxx idle-time 1800
vpngroup xxxxxx password ********
telnet timeout 5
ssh x.x.x.x 255.255.255.192 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 10
console timeout 0
 
terminal width 80
Cryptochecksum:
: end

Open in new window

0
Comment
Question by:ANSJay
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 8

Accepted Solution

by:
Jay_Gridley earned 125 total points
ID: 22848872
The ICMP command should let you disable this:

icmp deny any echo outside
0
 
LVL 1

Assisted Solution

by:tigerbam
tigerbam earned 125 total points
ID: 22850022
You haven't enabled icmp in the outside interface thats
why you are able to ping the outside interface.

icmp deny any outside

This will block the whole ICMP traffic.
0
 

Author Comment

by:ANSJay
ID: 22853197
I'm just curious as to why it isn't disabled by default, because most of the other pixes I have configured don't allow it by default.
0
 

Author Closing Comment

by:ANSJay
ID: 31511916
Thanks....this did the trick
0

Featured Post

How to Defend Against the WCry Ransomware Attack

On May 12, 2017, an extremely virulent ransomware variant named WCry 2.0 began to infect organizations. Within several hours, over 75,000 victims were reported in 90+ countries. Learn more from our research team about this threat & how to protect your organization!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ACL not working 11 64
Cisco SRST questions 5 55
SSL VPN and open two factor authentication 3 77
port-forwarding asa 9.5 9 26
From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question