Solved

Multicasting across VLANS on Cisco 3560

Posted on 2008-10-30
4
6,298 Views
Last Modified: 2012-06-21
I have a Cisco 3560 with 3 VLANS and ip routing enabled. VLAN1 contains devices multicasting data on UDP port 3100, and I can't seem to receive the multicasts when connected to VLAN2. How do I set the switch up to allow multicasts from VLAN1 to be seen on VLAN2. Running config is posted below. Thank you very much for helping me with this question!



=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2008.10.30 18:59:10 =~=~=~=~=~=~=~=~=~=~=~=
sho run
Building configuration...

Current configuration : 2854 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password <SNIP>
!
no aaa new-model
ip subnet-zero
ip routing
ip dhcp excluded-address 192.168.2.1 192.168.2.99
ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool vlan2
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.2
   lease 7
!
ip dhcp pool vlan1
   network 192.168.1.0 255.255.255.0
   dns-server 4.2.2.2
   default-router 192.168.1.2
   lease 7
!
ip multicast-routing distributed
ip igmp snooping querier
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
 switchport mode access
!
interface FastEthernet0/2
 switchport mode access
!
interface FastEthernet0/3
 switchport mode access
!
interface FastEthernet0/4
 switchport mode access
!
interface FastEthernet0/5
 switchport mode access
!
interface FastEthernet0/6
 switchport mode access
!
interface FastEthernet0/7
 switchport mode access
!
interface FastEthernet0/8
 switchport mode access
!
interface FastEthernet0/9
 switchport mode access
!
interface FastEthernet0/10
 switchport mode access
!
interface FastEthernet0/11
 switchport mode access
!
interface FastEthernet0/12
 switchport mode access
!
interface FastEthernet0/13
 switchport mode access
!
interface FastEthernet0/14
 switchport mode access
!
interface FastEthernet0/15
 switchport mode access
!
interface FastEthernet0/16
 switchport mode access
!
interface FastEthernet0/17
 switchport mode access
!
interface FastEthernet0/18
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/24
 description To Linksys
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet0/1
 switchport mode access
!
interface GigabitEthernet0/2
 switchport mode access
!
interface Vlan1
 description IPTV_STREAMS
 ip address 192.168.1.2 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp proxy-service
!
interface Vlan2
 description MULTICAST_RECEIVER
 ip address 192.168.2.2 255.255.255.0
 ip pim sparse-dense-mode
!
interface Vlan3
 description Internet
 ip address 192.168.3.2 255.255.255.0
!
ip default-gateway 192.168.1.1
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
 password <SNIP>
 no login
line vty 5 15
 no login
!
end


0
Comment
Question by:CNTUCKER
  • 2
4 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 22849388
It looks like the switch configured properly... However, I thought that distributed multicast routing was only available on platforms with VIP's.

You might try changing the "ip multicast-routing distributed" to "ip multicast-routing".

Other than that, I would verify that multicast is working correctly at the server and client. Maybe connect a client to the same network as the server and make sure it works.
0
 
LVL 15

Expert Comment

by:bkepford
ID: 22850197
You may want to change from ip pim sparse-dense-mode to ip pim dense mode
You are only running over two vlans and both of them need the multicast so it is not like you would be flooding out unneeded interfaces.
0
 

Author Comment

by:CNTUCKER
ID: 22851320
I'm running the following image:

Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(25)SEE4, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 16-Jul-07 03:11 by myl
Image text-base: 0x00003000, data-base: 0x01300000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(25r)SEC, RELEASE SOFTWARE (fc4)

Switch uptime is 1 day, 17 hours, 17 minutes
System returned to ROM by power-on
System image file is "flash:c3560-ipservicesk9-mz.122-25.SEE4.bin"

I've tried to change to ip multicast-routing instead of distributed, but it won't let me - just says incomplete command. What is the difference?
0
 
LVL 15

Expert Comment

by:bkepford
ID: 22851383
One is the router command the other is a layer 3 switch command. That is the correct command.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco Router DMZ 5 79
VIRL IP adress 3 72
policy routing to fw2 18 68
How can I measure the quality of my Internet access? 2 50
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question