• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 348
  • Last Modified:

Microsoft Outlook 2007 not workingover a VPN, even though you can connect

Hi,

We have a client that we set up a VPN into his offices so he could work from home, he can connect to the VPN fine and browse the web no problems.
Its just when he tries to run Outlook 2007 it errors on the send and recieve function:-

"Task 'Microsoft Exchange' reported error (0x8004011D) : 'The server is not available. Contact your administrator if this condition persists.'

they have a host file set up on the laptop in system32

server IP       Domain name taken from the exchnage resoved exchange server

i.e.
10.75.75.5                    random1.local.random

Anyone got any ideas?
0
YellowbusTeam
Asked:
YellowbusTeam
  • 10
  • 9
1 Solution
 
JoWickermanCommented:
Hi YellowbusTeam,

The exchange server name needs to be fully qualified in the mail profile.  (Control Panel>mail>Email Accounts>Exchange Settings)

For example:  If you listed the Exchange Server by the server name "Server01" initially, then you should change it to the fully qualifed domain name of "server01.smallbusiness.local"

Hope this helps.

Cheers.
0
 
YellowbusTeamAuthor Commented:
Is that how you get it to work over a VPN?

As we already have it working in Outlook in the office no probs, i presume you are talking about checking the server name in the mail setting on the exchange account. This is what we already know and that works.

It's when he is at home and using a VPN connection into the office, then launching outlook and that is when he gets the error, now if im not mistaken it requires a host file to resolve the IP to the Servers domain name? Am I correct on that?

Thanks
0
 
JoWickermanCommented:
Hi,

No, you do not need a host file. If you're connected to a VPN, your RRAS server already gave your PC a correct IP address, thus all netbios names will work through DNS.

If the user is at home, they need to change their outlook setup with the changes I mentioned in my first post. Even though the name does show the FQDN, RETYPE the server's FQDN. It has shown to work.

Cheers.
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
YellowbusTeamAuthor Commented:
Well our sever doesn't have thr RRAS option enabled and to be honest we don't really know that much about it as we have always used host files.

How would we go about setting up RRAS on the server?

If we set that up then Outlook in the vpn will work?
0
 
JoWickermanCommented:
Ooohhhh... Yeah, that might be the reason that the VPN won't work properly...

Well... What is the layout of your network?

What server are you running? Do you have firewall and seperate router? I'll gladly help you to do the config.

Cheers.

0
 
YellowbusTeamAuthor Commented:
The client has a dell tower server, with there own router and wireless access point.

They use Windows Small Businiess Server 2003, with exchnage enabled and Blackberry Professional.

Our network line comes into there office then into the router on the WAN side then the LAN side goes to the switch, whic is then sent out to the server and a patch panel so the clients staff can connect with cables if they desire. They use wireless mainly though through a netgear WAP.

does that you at all with how we would go about setting up RRAS
0
 
JoWickermanCommented:
Here is a very good article, it'll probably explain better than me.

http://support.microsoft.com/kb/323441

Have a look through it and let me know if there's something you do not understand.
0
 
YellowbusTeamAuthor Commented:
Our router does the PPTP VPN's. have you any other ideas?

but the article was a good find and had lots of useful information on it
0
 
JoWickermanCommented:
Oh ok!

Easy then! On the server in Control Panel -> Administrative Tools -> Routing and Remote access.

Activate RRAS, follow all the prompts.

On your router, configure the pptp to forward traffic on port 1723 to the ip address of your server.

Make sure the server's firewall allows connections on TCP port 1723.
0
 
YellowbusTeamAuthor Commented:
Is there a way of still using the router as PPTP.

correct me if im wrong but as that last comment stands the router just forwards the PPTP on to the server?
0
 
JoWickermanCommented:
The router and Server work together in this config.

That's correct. The router forwards the request, the server authenticates the user and informs the router to allow the traffic.
0
 
YellowbusTeamAuthor Commented:
is there any chance you could dupply us with a description of RRAS
0
 
JoWickermanCommented:
Hi,

What exactly do you want to know? Do you want to know how RRAS works? I will send you some documentation if you can explain to me what you're looking for.

Cheers.
0
 
YellowbusTeamAuthor Commented:
I would like to know how it works and what benefits it has over running the VPN through the router?

0
 
JoWickermanCommented:
0
 
YellowbusTeamAuthor Commented:
Hi
Thanks mate a great help
0
 
JoWickermanCommented:
Cool! :)

Glad I could assist!
0
 
JoWickermanCommented:
Hi,

Are you satisfied with the solution? Can we close this post?

Cheers.
0
 
YellowbusTeamAuthor Commented:
Yes i am, i will close it now
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 10
  • 9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now