• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 838
  • Last Modified:

cannot nfs mount with exec

I mount a remote directory via NFS through a home network (both the server and client are Fedora Linux 6), and have now realised I cannot run scripts on the mount. This seems to be due to the fact that it is mounted with the `noexec' option (the 'mount' command says so), though I didn't mean this to happen.

I put 'exec' option explicitly in the fstab file and re-mounted the directory, but it still remains non-executable. Would anybody advise what is preventing the executable mount???

Incidentally I put -rw option in the /etc/exports file on the NFS host.
0
yosato_uk
Asked:
yosato_uk
  • 2
1 Solution
 
woolmilkporcCommented:
Did you check the 'nosuid' mount option (just in case your scripts were flagged 'setuid' or 'setgid')?
0
 
frashiiCommented:
Can you paste sanitized versions of /etc/fstab (client) and /etc/exports (host) ?

Can you unmount and remount it with the -vvv flag so that we can get some verbosity on the mount ?

umount /mnt/nfsmountpoint
mount -avvv

And paste that output as well ?

I'm trying to remember if something like SElinux can be configured to disallow remote executions on network shares as well. Are you running SELinux or Novell Apparmor or the like ?
0
 
frashiiCommented:
*ping*
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now