Solved

3750 Catalyst Switch config issue - VoIP phones hopping vlans

Posted on 2008-10-31
3
1,007 Views
Last Modified: 2008-10-31
Our network has 2 vlans one for voice which points to a router connected to a T1 for voice and the other for data connected to a router with a T1 for data. This has worked fine with a couple 24 port 2950's.

We just installed a new switch. Now some phones work perfectly while others are getting their IP address from our DHCP server on the data vlan rather than our voip providers dhcp server.

The phones are Cisco 7940's. The only thing that changed on the network was everything was unplugged from the old switch and connected to the new switch.

The switch is 48 ports. In the attached config I removed ports 2-48 as they are all configured identically.

Is there anything obvious here that could be causing this? Any help would be immensely appreciated!


Building configuration...
 

Current configuration : 9739 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname IT1Source3750

!

enable password 7 ####

!

no aaa new-model

clock timezone MST -7

switch 1 provision ws-c3750g-48ps

system mtu routing 1500

ip subnet-zero

no ip source-route

no ip domain-lookup

!

!

!

!

no file verify auto

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

no spanning-tree vlan 1-4

!

vlan internal allocation policy ascending

!

interface GigabitEthernet1/0/1

 switchport trunk encapsulation dot1q

 switchport mode trunk

 switchport voice vlan 2

 switchport priority extend cos 3

 spanning-tree portfast
 

!

interface Vlan1

 description LAN Data VLAN (Inside/Private/Default VLAN)

 ip address 10.0.1.252 255.255.255.0

 no ip route-cache

!

interface Vlan2

 description Voice Vlan

 no ip address

 no ip route-cache

 no shutdown

!

interface Vlan3

 description Mgt Vlan

 no ip address

 no ip route-cache

 shutdown

!

ip default-gateway 10.0.1.254

ip classless

no ip http server

!

!

control-plane

!

!

line con 0

 password 7 ####

 login

 stopbits 1

line vty 0 4

 password 7 ####

 login

line vty 5 15

 login

!

end

Open in new window

0
Comment
Question by:xy8088
  • 2
3 Comments
 
LVL 15

Expert Comment

by:bkepford
ID: 22850644
If you are using all Cisco phones confiure your ports like this
interface GigabitEthernet1/0/1
switchport mode access
switchport access vlan 1
switchport voice vlan 2
switchport priority extend cos 3
spanning-tree portfast

Cisco phone will use CDP to detect the voice VLAN and even though your not running dot1q per say it should work just fine.
 
 
0
 
LVL 3

Author Comment

by:xy8088
ID: 22850859
So I just go in to configure that interface and issue the command:
switchport mode access

Will that also remove the:
 switchport trunk encapsulation dot1q

Or is that a separate command? Sorry for my ignorance, all our Cisco guys are gone and I'm on my own for this.
0
 
LVL 15

Accepted Solution

by:
bkepford earned 495 total points
ID: 22850905
interface range GigabitEthernet1/0/1-48
no switchport mode trunk
no switchport Trunk encap dot1q
switchport mode access
switchport access vlan 1



 
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco 2960 PACL 9 94
Configuring switch:  PortFast Edge vs PortFast 4 185
Cisco switch SVI 17 62
Managed vs unmanaged switches 8 49
The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now