• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1020
  • Last Modified:

3750 Catalyst Switch config issue - VoIP phones hopping vlans

Our network has 2 vlans one for voice which points to a router connected to a T1 for voice and the other for data connected to a router with a T1 for data. This has worked fine with a couple 24 port 2950's.

We just installed a new switch. Now some phones work perfectly while others are getting their IP address from our DHCP server on the data vlan rather than our voip providers dhcp server.

The phones are Cisco 7940's. The only thing that changed on the network was everything was unplugged from the old switch and connected to the new switch.

The switch is 48 ports. In the attached config I removed ports 2-48 as they are all configured identically.

Is there anything obvious here that could be causing this? Any help would be immensely appreciated!


Building configuration...
 
Current configuration : 9739 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname IT1Source3750
!
enable password 7 ####
!
no aaa new-model
clock timezone MST -7
switch 1 provision ws-c3750g-48ps
system mtu routing 1500
ip subnet-zero
no ip source-route
no ip domain-lookup
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 2
 switchport priority extend cos 3
 spanning-tree portfast
 
!
interface Vlan1
 description LAN Data VLAN (Inside/Private/Default VLAN)
 ip address 10.0.1.252 255.255.255.0
 no ip route-cache
!
interface Vlan2
 description Voice Vlan
 no ip address
 no ip route-cache
 no shutdown
!
interface Vlan3
 description Mgt Vlan
 no ip address
 no ip route-cache
 shutdown
!
ip default-gateway 10.0.1.254
ip classless
no ip http server
!
!
control-plane
!
!
line con 0
 password 7 ####
 login
 stopbits 1
line vty 0 4
 password 7 ####
 login
line vty 5 15
 login
!
end

Open in new window

0
xy8088
Asked:
xy8088
  • 2
1 Solution
 
bkepfordCommented:
If you are using all Cisco phones confiure your ports like this
interface GigabitEthernet1/0/1
switchport mode access
switchport access vlan 1
switchport voice vlan 2
switchport priority extend cos 3
spanning-tree portfast

Cisco phone will use CDP to detect the voice VLAN and even though your not running dot1q per say it should work just fine.
 
 
0
 
xy8088Author Commented:
So I just go in to configure that interface and issue the command:
switchport mode access

Will that also remove the:
 switchport trunk encapsulation dot1q

Or is that a separate command? Sorry for my ignorance, all our Cisco guys are gone and I'm on my own for this.
0
 
bkepfordCommented:
interface range GigabitEthernet1/0/1-48
no switchport mode trunk
no switchport Trunk encap dot1q
switchport mode access
switchport access vlan 1



 
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now