Solved

Cisco VPN Client - Secure VPN connection terminated locally by the client, Reason 412 Peer is no longer responding.

Posted on 2008-10-31
8
3,633 Views
Last Modified: 2010-04-21
I had initally setup the PIX 501 for several users to gain access to the office network their home desktops. It worked fine when I tested each user by connecting and logging in to the PIX.  That being completed I proceeded to setup the Small Business Server remote VPN connection for mobile users with laptops.  I am now getting the above error so I can only assume that it is one of the changes I made to the PIX for the SBS VPN that is now causing my Cisco VPN Client to fail but I have been unable to determine what it causing the problem.   I have attached the PIX configuration for all to review.  Thanks for the assistance.  

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password Q3Dtr5H78W34DD encrypted
passwd D4dskdkkrRFDE55QdE encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 192.168.70.96 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any 192.168.70.96 255.255.255.240
access-list BWPVPN_splitTunnelAcl permit ip 192.168.13.0 255.255.255.0 any
access-list outside_access_in permit tcp any host XX.XXX.XX.238 eq pptp
access-list outside_access_in permit gre any host XX.XXX.XX.238
access-list outside_access_in permit tcp any host XX.XXX.XX.238 eq https
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.13.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool BWPPool 192.168.70.100-192.168.70.110
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.13.0 255.255.255.0 inside
pdm location 192.168.2.0 255.255.255.0 inside
pdm location 192.168.13.100 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
http 192.168.13.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup BWPVPN address-pool BWPPool
vpngroup BWPVPN split-tunnel BWPVPN_splitTunnelAcl
vpngroup BWPVPN idle-time 1800
vpngroup BWPVPN password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet 192.168.2.0 255.255.255.0 inside
telnet 192.168.13.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname Potclienttest@sbcglobal.net
vpdn group pppoe_group ppp authentication pap
vpdn username Potclienttest@sbcglobal.net password **********
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username Bclown password 26ei5AkptVHXuWMq encrypted privilege 5
username gbush password 61SjTmqqKxmFUYqz encrypted privilege 15
username jsmith password E2mfE7ppBGu46vJL encrypted privilege 5
username jplumber password PYsWCZrguB0XZfQU encrypted privilege 5
terminal width 80
0
Comment
Question by:drcolema
  • 4
  • 3
8 Comments
 
LVL 3

Expert Comment

by:Slawomir Malinowski
ID: 22851471
It could be an unstable client internet connection or MTU issue.
Please check your MTU size (try with 1300 or the smallest possible) - application is located in the same plasce where you have you Cisco client.

good luck
0
 
LVL 1

Expert Comment

by:IanTM
ID: 22851802
just to clarify... does the pix always have the same external ip address?

this line...

    ip address outside pppoe setroute

could indicate that it might not.
0
 

Author Comment

by:drcolema
ID: 22854764
Yes.  It is a static IP.  I get the same IP every time.  
0
 

Author Comment

by:drcolema
ID: 23071907
Amdil, where do I change the MTU size?  I have a suspiscion that the DSL broadband connection on the server side is too slow.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 1

Accepted Solution

by:
IanTM earned 500 total points
ID: 23074135
ok some things to try (after modifying the pix config always do a "write mem" then "reload" i always reload as the pix can be funny sometimes when you modify on the fly)

1.a. remove these lines from the pix config.

fixup protocol pptp 1723
access-list outside_cryptomap_dyn_20 permit ip any 192.168.70.96 255.255.255.240
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
access-list outside_access_in permit tcp any host XX.XXX.XX.238 eq pptp
access-list outside_access_in permit gre any host XX.XXX.XX.238

1.b. modify these lines in the pix config

old line --- ip local pool BWPPool 192.168.70.100-192.168.70.110
new line --- ip local pool BWPPool 192.168.70.97-192.168.70.110


now try your cisco vpn client. i'm hoping this should succeed and you can move on to step 2.


2.a. add these lines into the config (note xx.xx.xx.xx in the ip address of your sbs server!!)

fixup protocol pptp 1723
access-list outside_access_in permit tcp any interface outside eq pptp
static (inside,outside) tcp interface pptp xx.xx.xx.xx pptp netmask 255.255.255.255 0 0
vpngroup BWPVPN dns-server xx.xx.xx.xx
vpngroup BWPVPN wins-server xx.xx.xx.xx

2.b. change these lines in the config

old line --- access-list BWPVPN_splitTunnelAcl permit ip 192.168.13.0 255.255.255.0 any
new line --- access-list BWPVPN_splitTunnelAcl permit ip 192.168.13.0 255.255.255.0 192.168.70.96 255.255.255.240


ok so this should get both the cisco and m$ sbs vpn working side by side. if not repost the new config as it looks after the changes and we'll see where we are... we'll be damn close.

also just as a house keeping exercise pop this in too --- no fixup protocol dns maximum-length 512

0
 

Author Closing Comment

by:drcolema
ID: 31512066
Not all of your suggestions solved the problem.  The primary being that I was point ALL traffic to the server and I should have been pointing only the PPTP.  Thanks.
0
 
LVL 1

Expert Comment

by:IanTM
ID: 23122672
I'm glad you're up and running.

However, I've no idea what you're referring to...

"Not all of your suggestions solved the problem. The primary being that I was point ALL traffic to the server and I should have been pointing only the PPTP. Thanks."
...as in your original config you had no inbound static routes therefore no traffic would have ever got to your sbs server.

My config only points PPTP as you required.

static (inside,outside) tcp interface pptp xx.xx.xx.xx pptp netmask 255.255.255.255 0 0


0
 

Author Comment

by:drcolema
ID: 23122961
My error.  I had added a static route incorrectly but did not list it in the configuration.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

We sought a budget ($5,000) firewall solution that would provide all the performance we needed with no single point of failure.  Hosting a SAAS web application in our datacenter, it was critical that we find a way to keep connectivity up and inbound…
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now