Solved

Configuring Windows Home Server on Verizon around blocked ports

Posted on 2008-10-31
20
1,286 Views
Last Modified: 2013-12-14
Hello I recently took the windows home server and installed in on an older emachine and it runs fine but I have verizon and they block port 80(HTTP)  and 443(HTTPS) so I used this info to try and change the ports (http://www.myhomeserver.com/?page_id=23) I changed them to 1024(HTTP) and 4443(HTTPS) but I still cant access them from outside. If anyone can help that would be awsome please and thank you.
0
Comment
Question by:dtlg90vt
  • 10
  • 9
20 Comments
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22852208
Do you have the ports forwarded to your device on your router?
0
 

Author Comment

by:dtlg90vt
ID: 22852429
Yes i even used DMZ to my servers address its and incoming isp port block i believe
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22852460
How are you trying to access it? What address? Are you putting the port number after?
ex. (random made-up ip) http://12.15.5.2:1024 or https://12.15.5.2:4443
 
0
 

Author Comment

by:dtlg90vt
ID: 22852597
the way i have been reading to do it is
Https://12.15.5.2:4443/home
or
Http://12.15.5.2:1024/home
0
 

Author Comment

by:dtlg90vt
ID: 22852608
1024 corresponds with my http port and 4443 corresponds with my https port but i can do it using a local ip like 192.168.2.148
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22852645
That is correct. You can try using a different port again. 8080 is a common alternative port for 80. Also double check your router settings to make sure that traffic like this is not being blocked somehow. Also do you have some internet security software installed on WHS that may block outside traffic, but allow internet traffic?
Good luck.
0
 

Author Comment

by:dtlg90vt
ID: 22852694
only firewall is windows firewall but i port it everytime i try a different port but could it be that verizon blocks all incoming ports ?
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22852735
They cannot block every incoming port or you would not have any 2-way communications - how could you receive a instant message or information from a website?
What router do you have? Did you try port 8080?
0
 

Author Comment

by:dtlg90vt
ID: 22852889
im trying port 8080 right now also something weird it seems as if my wan ip has changed???? yeah i thought blocking all incoming sounded weird to but i saw in online some where
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22852916
If your router support dynamic DNS you should try that instead of using an ip. Try with your new ip first. You can also install a DDNS service on your WHS if your router does not support it. Check this out:
http://www.dyndns.com/
 
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Author Comment

by:dtlg90vt
ID: 22852984
yeah i saw something about that but i dont understand how this works
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22853066
You sign up for the service - there are free and paid versions. I have always used the free versions and it has worked fine. You then configure your router (if supported) or desktop client to send your external ip to that service at x minute intervals. You will then have an address like http://dtlg90vt.dyndns.org that will be pointing to your current ip address.
0
 

Author Comment

by:dtlg90vt
ID: 22853241
which one of the my services do i use on that website?
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22853516
You need the dynamic DNS service - which is free.
http://www.dyndns.com/services/dns/dyndns/
 
0
 

Author Comment

by:dtlg90vt
ID: 22853775
ok i set that up and then what should it just work or do i just set my ports back to normal 80 and 443 or do i keep them the way they were after the tutorial i used at the top? i used the port checker dyndns.com provides and it says that port 8080 is open but port 4443 is blocked
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22854032
Just use 8080 and set a different port for https. Now you should be able to access your information through your ddns name and port numbers you setup. Now no matter what your ip changes you should be able to access your information.
Good luck.
0
 

Author Comment

by:dtlg90vt
ID: 22855070
i'v done all this and its still not working 8080 and 4443 were both open ports after i checked them with dyndns.com but it wasnt actually working
0
 
LVL 24

Accepted Solution

by:
andrew_aj1 earned 250 total points
ID: 22855160
Don't use DDNS right now for testing, i would use your ip address. I just mentioned it because you stated your ip changed. since you say its not working still i would suspect more of a router or firewall issue. Make sure all your firewalls are disabled and make sure your ports are forwarded correctly.
Good luck.
0
 

Author Comment

by:dtlg90vt
ID: 22855514
ok im going to try and bypass the router, by the way im have dd-wrt on my router if you are farmiliar with that its  alternate firmware with much more options. so im going to undo what i did with dyndns.com and i changed the ports back to normal because in the windows home server console when you change the ports from the default ones it fails the router and domain name tests
0
 
LVL 17

Assisted Solution

by:Andres Perales
Andres Perales earned 250 total points
ID: 23018216
you have to leave the ports alone on your home server, the port forward happens at your router.
So Home server you do not change anything and it has a static ip address of 192.168.XXX.10 (that as an example).
On the router you have your outside address as you described about with the 24.xx.xx.xx address and the inside of course is 192.168.xxx.1 that is your gateway, routers do NAT or Network address translation so anyone inputting your outside address 24.xx.xx.xx would then be forwarded to you home server ip address. 192.168.xx.10 but you want to do a port forward so when someone enters your outside address of 24.xx.xx.xx:8080 you tell your router to pass that to 192.168.xx.10 on port 80.
hope that makes sense!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

On a regular basis I get questions about slow RDP performance, RDP connection problems, strange errors and even BSOD, remote computers freezing or restarting after initiation of a remote session. In a lot of this cases the quick solutions made b…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now