Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

How to set correct permissions on existing redirected folders

Posted on 2008-10-31
5
Medium Priority
?
639 Views
Last Modified: 2008-11-03
We've recently taken over the IT support for a company that has an SBS 2003 server and a dozen XP/Vista PCs and laptops.

The company that originally supplied them with the PCs and laptops gave them Home editions of both XP and Vista - so of course, no one was actually joined to the local domain.

We've now upgraded all the workstations and joined them to the domain properly.

The server was already setup for My Documents redirection, which of course wasn't working before because no one was joined to the domain.

However, now it is working and users files have been copied to the server, I've realised that the server has been setup to redirect to a non-standard user documents location - and all the permissions are wrong.

What's the best way to resolve this and get all the permissions back as they should be?

There appear to be a number of options to me, namely:

1. Simply change the Client Document Redirection settings to save files to the default shared user directory, which has the correct permissions setup
2. Change the default shared user directory to the directory that is currently being used for redirection (sure there is a standard method for doing this).  Would I need to stop redirection first, change the default shared folder, then restart redirection?
3. Change permissions on the current folder that's being used for redirection?  Presumably that would have to be done manually.

Ideally, I'd like to leave the files where they are as they're on a different disk to the system drive.

Any advice?
0
Comment
Question by:devon-lad
  • 2
  • 2
5 Comments
 
LVL 14

Expert Comment

by:dfxdeimos
ID: 22852843
How many users do you have?
0
 
LVL 9

Expert Comment

by:Adam Graham
ID: 22856188
I don't see any reason you should have to move the files/folders. If they have been re-directed, all be it to a non 'standard' location, it means the folder redirection is working. Has this been accomplished via a manually created GPO or via the SBS option in Server Management --> Backup --> Configure My Documents Redirection?

In either case all you need to do is set the NTFS permissions correctly on the root folder and then replicate them down through the folder structure.

Adam
0
 
LVL 1

Author Comment

by:devon-lad
ID: 22860584
dfxdeimos - 12 users

18526 - Using the SBS option.  Can you clarify what permissions I need to set on the root folder so that each subfolder can only be accessed by the relevant user?  Because the permissions are different for each subfolder, I assumed I'd have to do this manually.
0
 
LVL 9

Accepted Solution

by:
Adam Graham earned 2000 total points
ID: 22861779
Here is an extract from the SBS help file, I think this is what you are looking for.

_____________________________________________________

When you enable folder redirection, the My Documents folder is redirected to the folder called Users Shared Folders by default. If you redirect the My Documents folder to another location, you need to first set the correct permissions on the folder.

To set permissions on the shared network folder where each user's My Documents folder is redirected

Click Start, and then click Windows Explorer.
Right-click the folder to which you want to redirect the user's My Documents folder, and then click Sharing and Security. On the Sharing tab, choose Share this folder, click Permissions. Add the following users and groups if they are not present, and then assign them Full Control permissions:

Domain Users
Domain Admins
SBS Folder Operators

Note;

It is recommended that you remove any previous users or groups from the list of group or user names.
On the Security tab, click Advanced, and then clear the check box for Allow inheritable permissions from the parent to propagate to this object and all child objects. When prompted for how to assign the permissions, click Remove. Click Add, add the following users and groups if they are not present, and then assign them Full Control permissions:

Creator Owner
Domain Admins
SBS Folder Operators
SYSTEM

Click Add, and then type Domain Users. In the Permissions Entry for All Users dialog box, click the Apply onto drop down box, click This folder only, and then select the following:

List Folder/Read Data
Read Attributes
Create Folders/Append Data
_____________________________________________________

Hope that helps

Adam
0
 
LVL 1

Author Comment

by:devon-lad
ID: 22865784
That appears to have done it - thanks.  
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the event you manage a Small Business Server 2003, and you are audited for PCI compliance, there are several changes you must make in order to pass the audit. I can take no credit for discovering any of these fixes or workarounds, but there is no…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…
Suggested Courses

877 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question