Solved

Why wont this config work??

Posted on 2008-10-31
3
494 Views
Last Modified: 2012-05-05
I have a 5505 running the config below.  I have a customer that has an SBS server at 192.168.1.100, and nees http, https, smtp, 4125 and 993 forwarded to that IP.  They have a static IP (although at the moment I have the router configured to get the IP via DHCP from the IVAD).  This config is NOT allowing me to access the internet.  Could somebody school the Cisco noob?  I am going to give this another go this weekend...

Danno


: Saved
:
ASA Version 7.2(3)
!
hostname ESIcisco
domain-name default.domain.invalid
enable password aiKWaWNCThgEVo/4 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 10
 ip address xx.xxx.75.138 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any interface outside eq 4125
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq 993
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list inside_access_out extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1499
mtu outside 1499
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 101 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 993 192.168.1.100 993 netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.1.100 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 4125 192.168.1.100 4125 netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.1.100 https netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.100 www netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.1.100 smtp netmask 255.255.255.255
access-group inside_access_out out interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xx.xxx.75.137 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.129 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:221ddde703003851fa54c68cc3f6b93e
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

0
Comment
Question by:danlikey2
  • 2
3 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 22853509
Almost there.
Try this

global (outside) 1 interface  <== this should be "101" to match the nat
nat (inside) 101 0.0.0.0 0.0.0.0

Example:

global (outside) 101 interface
nat (inside) 101 0.0.0.0 0.0.0.0
0
 
LVL 7

Author Comment

by:danlikey2
ID: 22853615
excellent.  I will try that.  Anything else look out of place?  Do the port forwarding rules look right?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 22853670
Yes, the forwarding rules look fine.

>access-list inside_access_out extended permit ip any any
>access-group outside_access_in in interface outside

You do not need the above two lines. Permit ip any any is the default behavior with no acl applied, so it is redundant to do that.

To help troubleshooting you might want to add icmp to the inspect rules

policy-map global_policy
 class inspection_default
  inspect icmp


0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to configure Site to Site VPN on a Cisco ASA.     (version: 1.1 - updated August 6, 2009) Index          [Preface]   1.    [Introduction]   2.    [The situation]   3.    [Getting started]   4.    [Interesting traffic]   5.    [NAT0]   6.…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question