Solved

Frame Relay config not pinging - Why?

Posted on 2008-10-31
9
1,049 Views
Last Modified: 2013-12-12
We set up a new frame relay extranet link to one of our suppliers.  Our frame relay circuit is conneted to the suppliers frame relay cloud through AT&T services.  To confirm the link is working we are trying to perform a simple ping between the two routers.  The ping fails.

AT&T says both legs of the circuit are set and working as expected.
Our supplier says they do not have any rules blocking ICMP traffic.

We have tried a different router and got the same results, ping fails.

Ran the following commands
sho int s0/0/0
sho frame-relay map
sho frame-relay pvc
sho frame-relay lmi
sho ip route

All commands appear to show valid results.

Below is the config settings and log command outputs.

Are there any issues with the config settings?  This is our first frame relay but our supplier has 45 users on their cloud.

Frame Relay link to Supplier

  US                          ATT            SUPPLIER
192.168.151.86/30 <-------------> 192.168.151.85/30



***************************************************************************
frcnty1841#ping 192.168.151.85

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.151.85, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

***************************************************************************
sho ver
Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 12.4(3i), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 28-Nov-07 18:17 by stshen

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

frcnty1841 uptime is 2 minutes
System returned to ROM by power-on
System image file is "flash:c1841-ipbase-mz.124-3i.bin"

Cisco 1841 (revision 7.0) with 114688K/16384K bytes of memory.
Processor board ID FTX1230Y1LH
2 FastEthernet interfaces
1 Serial interface
WIC T1-DSU
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
31360K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

frcnty1841#

************************************************************
frcnty1841#sho start
Using 2149 out of 196600 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname frcnty1841
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 xxxxxxxx
!
no aaa new-model
!
resource policy
!
clock timezone PSTime -8
clock summer-time PDT recurring
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
ip tcp synwait-time 10
!
!
no ip bootp server
no ip domain lookup
ip domain name shra.org
ip name-server 10.10.120.60
!
username xxxxxxxxxxxxxxx
!
!
!
interface FastEthernet0/0
 description inside link facing asa$ES_LAN$
 ip address 172.16.150.2 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
 no mop enabled
!
interface Serial0/0/0
 ip address 192.168.151.86 255.255.255.252
 encapsulation frame-relay
 frame-relay map ip 192.168.151.85 16 broadcast CISCO
 frame-relay interface-dlci 16
 frame-relay lmi-type cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.151.85
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 password 7 xxxxxxxxxxxxx
 login
 transport output telnet
line aux 0
 password 7 xxxxxxxxxxxxx
 login
 transport output telnet
line vty 0 4
 password 7 xxxxxxxxxxxxx
 private
 login
 transport input telnet
line vty 5 15
 privilege level 15
 no login
 transport input telnet
!
scheduler allocate 4000 1000
end

************************************************************
frcnty1841#sho int s0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K with integrated T1 CSU/DSU
  Internet address is 192.168.151.86/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  16, LMI stat recvd 16, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 1023  LMI type is CISCO  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:09, output 00:00:09, output hang never
  Last clearing of "show interface" counters 00:02:57
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     16 packets input, 232 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     21 packets output, 637 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

************************************************************************
frcnty1841#sho frame-relay map
Serial0/0/0 (up): ip 192.168.151.85 dlci 16(0x10,0x400), static,
              broadcast,
              CISCO, status defined, active

************************************************************************
frcnty1841#sho frame-relay pvc

PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0

  input pkts 0             output pkts 4            in bytes 0        
  out bytes 416            dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:03:16, last time pvc status changed 00:01:57

**************************************************************************
frcnty1841#sho frame-relay lmi

LMI Statistics for interface Serial0/0/0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0            Invalid Prot Disc 0
  Invalid dummy Call Ref 0            Invalid Msg Type 0
  Invalid Status Message 0            Invalid Lock Shift 0
  Invalid Information ID 0            Invalid Report IE Len 0
  Invalid Report Request 0            Invalid Keep IE Len 0
  Num Status Enq. Sent 19            Num Status msgs Rcvd 19
  Num Update Status Rcvd 0            Num Status Timeouts 0
  Last Full Status Req 00:00:06            Last Full Status Rcvd 00:00:06


**************************************************************************
frcnty1841#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.151.85 to network 0.0.0.0

     192.168.151.0/30 is subnetted, 1 subnets
C       192.168.151.84 is directly connected, Serial0/0/0
S*   0.0.0.0/0 [1/0] via 192.168.151.85
frcnty1841#
0
Comment
Question by:dalva
9 Comments
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Try this configuration:

interface Serial0/0/0
 no  ip address 192.168.151.86 255.255.255.252
 encapsulation frame-relay
 no  frame-relay map ip 192.168.151.85 16 broadcast CISCO
 no frame-relay interface-dlci 16
 frame-relay lmi-type cisco

interface serial 0/0/0.16 point-to-point
  ip address 192.168.151.86 255.255.255.252
  frame-relay interface-dlci 16


0
 
LVL 4

Expert Comment

by:socalsuperhero
Comment Utility
DLCI's are correct? Have you verified the status lights on the NIU?
0
 
LVL 1

Author Comment

by:dalva
Comment Utility
lrmoore,
We did try the sub interface method before we posted to here.
Instead of  interface serial 0/0/0.16 point-to-point we used interface serial 0/0/0.1 point-to-point.
We found the sho frame-relay map command showed the serial 0/0/0 as being down.  We tried to enter the frame-relay map command but it does not work on a sub-interface so we ended up with the current config.
Does it make a difference to use .1 versus .16?
0
 
LVL 1

Author Comment

by:dalva
Comment Utility
socialsuperhero,
We have confirmed the DLCI's mulitple times with the supplier and AT&T.  As for status lights, the only lights on the internal WIC are LP (loopback), AL (alarm) and CD(carrier detect).  The CD is green under normal conditions.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 79

Accepted Solution

by:
lrmoore earned 200 total points
Comment Utility
There is no difference between .1 or .16 that is just an arbitrary interface number. I like to keep them consistent with the dlci number just to make it easy for my p brain to keep it straight.
Since you have a /30 IP address, this must be a point-to-point link so the only config that makes sense is a P-2-P subinterface.
Have you tried using IETF encap, or do you know if the other end is a Cisco router too?
0
 
LVL 1

Author Comment

by:dalva
Comment Utility
lrmoore,
We have not tried IETF encap.  That is an option to try next Monday.
I am a little confused about having to use a subinterface since it is /30 ip address.  We could not get the mapping to work with subinterface settings.
We will continue this on Monday.
0
 
LVL 23

Expert Comment

by:Mysidia
Comment Utility
I suggest you revisit your " encapsulation frame-relay"   interface command.
It may be that you need  "encapsulation frame-relay ietf"  instead.

The 3 things that are most important to ensure are:
o  Your lmi type is correct  (givin the output of your show commands, it is)
o  You have mappings setup for the correct dlcis.
o  Your link encapsulation is correct and matches what the supplier is using.
i.e.  if the remote end is using anything unusual, you need to know about it.

Since you are specifying a  'frame map';  it seems advisable to disable inverse arp, unless the supplier is using inverse arp.
no frame-relay inverse-arp
no arp frame-relay


In fact, there are multiple ways to setup frame relay.
For a point to point link it really doesn't matter all that much whether you use a subinterface or a single interface and a 'map' statement for your P-t-P link, provided you do it correctly for your setup.

In most cases you should be able to avoid using subinterfaces if you absolutely don't want to use them.  For  point-to-multipoint setups,  subinterfaces may be preferred, where using a single interface with multiple IPs mapped may create problems for your routing protocol setup in the point-to-multipoint situation.


  input pkts 0             output pkts 4            in bytes 0        
 ^^^^^^^^^^
This in your 'sho frame-relay pvc'
is indicative of the link not working.

LMI and frame may be up,  but you aren't accepting data from the other side, or it isn't sending data in an encoding you can read...


Ideally:  get your supplier to   pipe you their frame config for the main interface, your subinterface, and  run those same show commands on their router.

Revealing to you  the stats for your PVC.

Perhaps they also see  '0 packets input'...  which isn't very interesting.

It would be very revealing though if it showed they had packets both in and out to and from you.

0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Using a subinterface negates the requirement to map anything.
0
 
LVL 1

Author Closing Comment

by:dalva
Comment Utility
lrmoore, get the points for being the first to suggest the IETF encap which fixed the problem.

I have opened a new related question at
http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_23872369.html
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Hello All, I have been training on Multicast for a while now and whenever I start the topic , I find out that my friends /  Colleagues mention that they do not know how to test Multicast Joins. As most of the multicast would be video traffic and …
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now