Solved

Windows Server 2008 multiple network cards don't work

Posted on 2008-10-31
14
9,639 Views
Last Modified: 2012-07-25
I have installed Windows Server 2008 x64 Enterprise edition and I setup 2 NICs on it.  They're setup in different VLANs on a Cisco 6513 switch.  Here's the config:

1st NIC
172.16.0.63
255.255.252.0
172.16.0.1         gateway

2nd NIC

172.30.7.15
255.255.255.0
(no gateway setup)

I cannot ping the IP address on the 2nd NIC 172.30.7.15 from any computer on the domain.  

I can ping the 1st NIC just fine.  I can also ping the 2nd NIC from the switch itself but not from any other computer in the network.  

----------------------------

I have the exact same setup on a Windows 2003 server and it works just fine.  Here's my troubleshooting steps:

1.  Turned off Windows firewall
2.  Turned Network discovery On and Off, it didn't make any difference.
3.  checked the binding order in Advanced properties and made it match the 2003 server
4.  Turned off IPV6 on all the NICs.  

It seems to be the server not responding to any clients, except for the switch itself.
0
Comment
Question by:Florescu
  • 7
  • 7
14 Comments
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22860513
Your second NIC isn't in the same subnet as your workstations.  Or are your workstations on the 172.30.7.X nework?  I would connect your laptop to the same switch and VLAN then set it with and IP address of 172.30.7.16/24.  And try pinging again.

If that's not the issue, try uninstalling the second NIC, and rebooting the server (which will reinstall the NIC) then reconfigure it.


0
 

Author Comment

by:Florescu
ID: 22867365
It shouldn't matter if the workstations are in the same VLAN because I have the exact same setup on Windows 2003 servers and it works just fine.  
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22868705
Then assuming the configuration is correct, we are looking at either a hardware problem with the  server or with the Cisco 6513 switch.  

Have you tried a different port on the switch?  I know it should be fine since you can ping it from the switch but it would be an easy test to run.

To eliminate the possibility of a potential problem with the switch put a different switch in place that's also connected to a laptop with a static IP on the same subnet. Then retest.

Did you try reinstalling the NIC on the server per my first post?

Have you reviewed the event logs for possible leads?
0
 

Author Comment

by:Florescu
ID: 22869223
This is happening with more than just 1 server.  I have another server that I just installed Windows 2008 on and it's behaving the same way.

There must be some changes in 2008 that are making it behave this way.
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22869588
Uninstalling IPv6 (as opposed to just unchecking the box)
http://www.infotechguyz.com/server2008/uninstallipv6.html
0
 

Author Comment

by:Florescu
ID: 22986784
I tried that, it does the same thing.  I did a packet capture on the server and the server does see the traffic but it just never responds to it.
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 23024074
Sorry for the delay in response.  Any progress since your last post?  Microsoft must have modified how things work on server 2008, or there's a setting that you're unaware of the the 2003 server.  I think this goes back to my first post.  The computers are on the wrong subnet.  Perhaps I'm wrong, but try putting a computer on the same subnet, say 172.30.7.14/24, and try the ping test.  Perhaps 2003 had some type of pass through but 2008 doesn't.

Let me know what your testing finds,

Tenaj-207
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:Florescu
ID: 23034307
They work fine if they're on the same subnet but I need it to work the other way.  The ultimate goal is to get network load balancing going but that doesn't matter if I can't even get to the ip address.  

I think you are right, there's a difference between 2003 and 2008, that's why I posted something here.  I thought somebody may know how to fix it.
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 23038254
You need a route statement on the DNS server to redirect people to the right location.  It'll read something like;

route -p add 172.30.7.0 mask 255.255.255.0 172.16.0.63 metric 1
0
 

Author Comment

by:Florescu
ID: 23051457
That's not the problem here.  The clients can get to the 172.30.7.x network just fine, the route back is what the problem is.

On the server, there's a default route that points to 172.16.0.63.
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 23072077
Try this command again but use the IP address of the switch instead.  Also try putting the route statement on the PC itself.

route -p add 172.30.7.0 mask 255.255.255.0 {switch IP address} metric 1
0
 

Author Comment

by:Florescu
ID: 23077965
That didn't help.
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 23079160
Florescu,

I'm sorry the route statements didn't work.  The issue is still the same; your server is on a different subnet then the rest of the computers.  I don't know how you had this working with the 2003 server but it's clearly not working with 2008.  

Now that you know that answer to this question, "Windows Server 2008 multiple network cards don't work." The answer being that the networks cards do work it's an issue with routing.  You can ask a new question, "How to bridge two subnets with Server 2008."

I wish I had more information for you but I think closing this question and asking a new one will get you the best solution with the quickest response.
0
 

Accepted Solution

by:
Florescu earned 0 total points
ID: 23205974
I figured out with a call to Microsoft Tech support.

Windows 2008 introduces a "strong host model" that doesn't allow the different NICs to talk to each other.  For example, if a request comes in on the 2nd NIC and there's no default gateway setup, then the NIC will not use the 1st NIC to reply to the requests.  (even though there's a default gateway setup on that 1st NIC).  

In order to change that behaviour and go back to a 2003 model, you go to the command prompt and then you type:

netsh interface ipv4 set interface NLB weakhostreceive=enable
netsh interface ipv4 set interface NLB weakhostsend=enable

(where NLB is the name of the network interface... default is Local Area Connection)

As an alternative, you can set a default gateway on the 2nd NIC but that can introduce more problems where the system doesn't know which way to send traffic.  MS said that I could set the metric to 2 on the 2nd NIC and that way it will only be used if the 1st NIC is unavailable.

http://technet.microsoft.com/en-us/magazine/2007.09.cableguy.aspx
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

Suggested Solutions

To effectively work with Diskpart on a Server Core, it is necessary to write some small batch script's, because you can't execute diskpart in a remote powershell session. To get startet, place the Diskpart batch script's into a share on your loca…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now