Missing ability to format existing text as vertical text

I have been using Visio since it's release and I have always had the function to change text so it appears vertical. You can do this in all MS office products. I have a new installation of Visio 2007 Pro and I didnt see the button on the tool bar. So I opened up help and got this:

Select the shape.
Click the Change Text Direction button .
The shape's text rotates 90° clockwise and appears in a vertical font.
 Note    To display the Change Text Direction tool, on the Tools menu, click Options, click the Regional tab, and, in the Asian text list, click Show.

I looked at the note and thought OK, I will change this setting. But when I open tools and options, there is no Regional tab to select the Asian text list. and click show. No tab exists.

I installed the same software on another machine and it has the same issue. I can go to the tool bar and customize it and drag the Change Text Direction button to the tool bar, but as soon as I click OK, it disappears.

I have searched the web and people are having the same issue, but then they are told to go to tools --> options --> regional setting and in the Asian text list, click Show. This fixes their issue, but for me, I dont have that tab.
RobguadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RobguadAuthor Commented:
I think I answered my own question...

I think I figured it out, at least on my Windows XP box. I had to go into control panel and regional and language options. From there the languages tab. Then I selected the checkbox to install files for east Asian Languages. I never recall having to do that with other versions of Vision before to use that function, or to use that function in Word or Excel...

Now I have to figure out how to do the same thing on Server 2008, which is what I have installed on my laptop...
0
RobguadAuthor Commented:
Actually, after adding the east Asian language and rebooting, it still does not display a regional tab in the options for Visio. So this is still an open issue. I thought for sure that would have corrected it.
0
Scott HelmersVisio Consultant, Trainer, Author, and DeveloperCommented:
I don't think I've used the rotate text function before so I haven't missed it in Visio 2007.

However, I just added Japanese as a language and the rotate text button appeared on the Format Text toolbar.

They key seems to be to add Japanese in the MS Office settings, not in the Windows settings:
Click Start, click All Programs, click Microsoft Office, click Microsoft Office Tools, and  then click Microsoft Office 2007 Language Settings and add Japanese there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RobguadAuthor Commented:
Thanks that did it. I also found out I can right-click the shape, then choose Shape and select Rotate Text.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Visio

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.