Solved

Port Issues and FTP

Posted on 2008-11-01
5
494 Views
Last Modified: 2013-12-02
I just set up FTP on my Windows Server 2003 box with a port number of 4465 for FTP commands.  (It's not 21.)  I can access the FTP home directory using the server itself (127.0.0.1) or any workstation in my LAN.  I'm having trouble, however, accessing the server from the WAN.  I've opened up my DSL router firewall for TCP ports 20 (FTP data) and 4465.  Here's the message I get when I try to access my new FTP server from a remote machine using Filezilla:

Status:      Connected
Status:      Retrieving directory listing...
Command:      PWD
Response:      257 "/" is current directory.
Command:      TYPE I
Response:      200 Type set to I.
Command:      PASV
Response:      227 Entering Passive Mode (192,168,1,2,6,212).
Status:      Server sent passive reply with unroutable address. Using server address instead.
Command:      LIST
Response:      425 Can't open data connection.
Error:      Failed to retrieve directory listing

I'm clearly "getting in the door."  The 192,168,1,2 value is the static IP of my server on the LAN.  Note the subsequent response, however: "Server sent passive reply with unroutable address. Using server address instead."  

My ISP does have a firewall in place for port values under 500.  Am I running into this firewall for port 20?  
Is it something else?
What diagnostics can I try?
0
Comment
Question by:jdana
  • 2
  • 2
5 Comments
 
LVL 35

Accepted Solution

by:
torimar earned 400 total points
ID: 22857338
Two things you might want to try:

1. Disable Passive Mode in FileZilla;
2. Configure the server to reply with its external address.
0
 
LVL 26

Assisted Solution

by:akahan
akahan earned 100 total points
ID: 22857345
On your router, you need to not just open up the firewall, but also forward ports 4465 and 20 to the server's LAN IP address.  Have you done that?
0
 

Author Comment

by:jdana
ID: 22860754
torimar
1. I disabled passive mode.
2. Not sure how to configure server to respond with its external address.
akahan
I had configured port forwarding for 20 and 4465 to the server's LAN address.  I wasn't clear on this in the original posting.
0
 
LVL 35

Assisted Solution

by:torimar
torimar earned 400 total points
ID: 22860945
1. Does this mean you disabled PASV now and tested, or generally disabled it? Because the logs you posted certainly don't speak of an active connection attempt.

2. Unfortunately, I don't know how to do this for the Windows FTP server. It's easy in FileZilla's server: just select Passive Mode Settings.
0
 

Author Closing Comment

by:jdana
ID: 31512499
For "Active IP Mode" I made the changes shown in the screen shot.  These are changes made to the client.  The error message, however,  sure makes it look like the issue resides with the server.  I found a K-Base article that explains how to make the change.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Opening Ports 18 93
Sonicwall routing between VPNs 5 54
network error 8 48
Block YouTube via Application Control in Fortigate 1000C 3 31
Article by: rfc1180
The Maximum Segment size (MSS) is an important consideration when troubleshooting connectivity via the Internet/Intranet. As the packets are routed via the Internet/Intranet, the packets must traverse through multiple routers in the path between two…
Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question