Solved

trying to get nfslock to stop

Posted on 2008-11-01
5
686 Views
Last Modified: 2013-12-16
i'm trying to get nfslock to stop and then disable on startup.  But all I get is this with all different variations and sequences:

service nfslock stop  [FAILED]
service nfslock start  [FAILED]
service nfslock stop  [FAILED]
service nfslock stop  [FAILED]
service nfslock start  [FAILED]
service nfslock start  [FAILED]
0
Comment
Question by:allwebnow
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 14

Accepted Solution

by:
Deepak Kosaraju earned 250 total points
ID: 22858934
just use the following command to stop service to start during startup of system.
chkconfig nfslock --level 345 stop

check with pgrep nfslock | xargs killall
if nfslock is not running it solves you question.

0
 

Author Comment

by:allwebnow
ID: 22860185
Thanks for your response!  

ok I tried that command and then started the system back up.  However, My firewall is still giving me this message in the security checker area;

On most servers nfslock is not needed and should be stopped and disabled from starting, as it could pose a security threat. This service is currently enabled in init and can be disabled using:
service nfslock stop
chkconfig nfslock off

Is there a way to disable it in init?  Because even after startup, i still can't run these commands to get it to stop and disable.   Even if it is disabled, something is still telling the system or firewall that it is still enabled.
0
 
LVL 14

Expert Comment

by:Deepak Kosaraju
ID: 22860224
chkconfig does the same, disable service  during System startup. can you copy the paste the log from which your observing  ->  something is still telling the system or firewall that it is still enabled.

0
 

Author Closing Comment

by:allwebnow
ID: 31512358
i got it working.  Contacted Firewall devs and they got the message to go away.
0
 

Author Comment

by:allwebnow
ID: 22882830
finally just used chkconfig nfslock off only and that worked
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question