Solved

One RDP Client can no longer connect to TS 2003 server.  Everyone else can...

Posted on 2008-11-01
4
268 Views
Last Modified: 2013-11-21
One cleint out of the 25 using the same TS server can no longer connect to the TS server.  It is a 2003 server which has been running for about 2 years.  This is the error he gets:
 "The remote computer disconnected the session because of an error in the licensing protocol.  Please try connecting to the remote computer again or contact your server administrator."

This seems to have happened since we had a boot sector error on two drives and had to reactivate them through disk manager.

Also there have been lots os other permission related issues, such as one volume loosing all NTFS rights and registery settings.

The lisening server is online and the CALS have not been exceeded.

Troubleshooting steps taken:
Solution:  Perform the following steps:

Verify that the license server is correctly installed.

Verify that the Terminal Server Licensing service is running on the license server.

Verify that the client, the terminal server, and the license server can communicate by ensuring that Domain Name System (DNS) is configured correctly on each computer. To do this, run the ping command from each computer to each computer using the IP address, FQDN, and the NetBIOS name. If any of the ping commands fail, verify the DNS configuration on the network.

On the terminal server, set a preferred licensing server to connect to. You can do this by using the registry, a Windows Management Instrumentation (WMI) script, or, in Windows Server 2003 with Service Pack 1, you can use Group Policy settings or Terminal Server Configuration.

See also:   Install Terminal Server Licensing; Set preferred Terminal Server license servers; Terminal Server license server roles

Solution:  If the previous solution does not resolve this problem, create a backup of the MSLicensing registry key and its subkeys on the client, and then remove the original key and subkeys by doing the following:

On the client, navigate to the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing.

Click MSLicensing.

On the Registry menu, click Export Registry File.

In the File name box, type mslicensingbackup, and then click Save.

If you need to restore this registry key in the future, double-click mslicensingbackup.reg.

On the Edit menu, click Delete, and then click Yes to confirm the deletion of the MSLicensing registry subkey.

Close Registry Editor, and then restart the computer.

When the client is restarted, the missing registry key is rebuilt.

Thx,
matt

0
Comment
Question by:TX_SCUBA
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22860579
Have you tried to have that user connect from a different computer?

Have you tried removing that user from the remote desktop group then re-adding them?
0
 

Author Comment

by:TX_SCUBA
ID: 22861967
User can connect on a different computer.
0
 
LVL 15

Assisted Solution

by:tenaj-207
tenaj-207 earned 250 total points
ID: 22869066
If the user can connect from a different computer then we know the issue is with the PC not the server or user account.  

One great trouble shooting technique is to open msconfig (click on start then run and type in msconfig in the text box) go to the startup tab and uncheck everything (there's a disable all button to make this easy).  Then go the the services tab check the box to  "Hide all Microsoft services"and uncheck the rest of the non-Microsoft services.  Then reboot and check to see if remote desktop works from this computer.

If it does work then you know that there is a conflict with another program.  Start rechecking just the things you need in the msconfig utility until the problem comes back.  Then you'll know where your conflicting program is.

If this doesn't work then you may need to remove and readd this PC from the domain.

-tenaj
0
 

Accepted Solution

by:
TX_SCUBA earned 0 total points
ID: 23965558
For whatever reason when the boot sector was reinstalled the TS liceing swithed back to Per Seat.  Microsoft had me switch back to Per User and now everything is fine.

~
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question