Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco 2611 DSL PPPoe connection configuration

Posted on 2008-11-02
4
Medium Priority
?
1,569 Views
Last Modified: 2013-12-14
We currently have a cable connection connected to one of our cisco 2611 routers. We are getting a new provider, and we need to configure the wan interface for dsl.

It's a PPPoe dialer with a dynamic ip. I have attached a snippet of our running config. If someone can provide me with the steps or configuration in order to switch over to the dsl while retaining the current config.


Current configuration : 2596 bytes
!
! Last configuration change at 10:33:42 EST Sun Nov 2 2008
! NVRAM config last updated at 22:51:33 EST Mon Oct 27 2008
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SPARTAN
!
boot-start-marker
boot-end-marker
!
enable secret 5 <removed>
enable password 7 <removed>
!
clock timezone EST -4
no aaa new-model
ip subnet-zero
no ip source-route
ip flow-cache timeout active 1
!
!
no ip domain lookup
!
ip dhcp pool mypool
   network 192.168.1.0 255.255.255.0
   domain-name spartan.local
   dns-server 208.67.222.222 208.67.220.220
   default-router 192.168.1.1
   lease 7
!
no ip bootp server
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 description LOCAL AREA NETWORK
 ip address 192.168.1.1 255.255.255.0
 no ip proxy-arp
 ip nat inside
 ip route-cache flow
 half-duplex
!
interface Ethernet0/1
 description WAN PORT
 ip address dhcp
 ip nat outside
 ip route-cache flow
 half-duplex
!
interface Dialer1
 no ip address
 no cdp enable
!
ip nat inside source list 102 interface Ethernet0/1 overload
ip nat inside source static tcp 192.168.1.11 2121 interface Ethernet0/1 2121
ip nat inside source static tcp 192.168.1.10 9675 interface Ethernet0/1 9675
ip nat inside source static tcp 192.168.1.10 80 interface Ethernet0/1 80
ip nat inside source static tcp 192.168.1.10 1723 interface Ethernet0/1 1723
ip nat inside source static tcp 192.168.1.10 3389 interface Ethernet0/1 3389
ip nat inside source static tcp 192.168.1.10 79 interface Ethernet0/1 79
ip nat inside source static tcp 192.168.1.11 78 interface Ethernet0/1 78
ip nat inside source static udp 192.168.1.11 50543 interface Ethernet0/1 50543
ip nat inside source static tcp 192.168.1.11 50543 interface Ethernet0/1 50543
ip nat inside source static tcp 192.168.1.10 21 interface Ethernet0/1 21
ip nat inside source static tcp 192.168.1.11 8081 interface Ethernet0/1 8081
ip nat inside source static tcp 192.168.1.12 77 interface Ethernet0/1 77
no ip http server
ip classless
ip flow-export source Ethernet0/1
ip flow-export version 5
ip flow-export destination 192.168.1.10 9996
!
!
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit icmp any any
no cdp run
!
!
snmp-server ifindex persist
!
!
!
banner motd ^C This is a secure system. All actions are logged, Authorized Perso
nnel Only! ^C
!
line con 0
 password 7 011157154F190C5978
 logging synchronous
 login
line aux 0
line vty 0 4
 password 7 011157154F190C5978
 login
!
ntp clock-period 17208887
ntp server 192.5.41.40
!
end
 
SPARTAN#

Open in new window

0
Comment
Question by:fluk3d
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 13

Expert Comment

by:Quori
ID: 22864581
Your device does not appear to have a DSL capable interface - you will need a WIC-1ADSL if it is ADSL, and a different card again if it is SHDSL, etc.
0
 
LVL 5

Accepted Solution

by:
arshana earned 300 total points
ID: 22866046
Router#configure terminal
Router(config)#vpdn enable
Router(config)#no vpdn logging
Router(config)#vpdn-group pppoe
Router(config-vpdn)#request-dialin
Router(config-vpdn-req-in)#protocol pppoe
Router(config-vpdn-req-in)#end
0
 
LVL 6

Author Comment

by:fluk3d
ID: 22866577
arshana can you elaborate please? I am not a complete newb when it comes to CLI but, i'm not exactly sure where to configure the username & password.

Also regarding the 1st comment, my router will not support dsl connection without a dsl wict?
0
 
LVL 9

Expert Comment

by:Press2Esc
ID: 22884866
per Arshana's config, the DSL router would be set in a "bridged" mode & the Cisco will provide the DSL req'd PPPoE connection.  
Per your 2nd question, a WIC is not req'd as the bridged DSL router essentially functions as a modem converting the phone to an ethernet connection....
P2E.
0

Featured Post

The Ideal Solution for Multi-Display Applications

Check out ATEN’s VS1912 12-Port DP Video Wall Media Player at InfoComm 2017. Kerri describes how easy it is to design creative video walls in asymmetric layouts and schedule detailed playlists ahead of time with its advanced scheduling feature.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question