Solved

WDS using VMWare Workstation

Posted on 2008-11-02
8
4,379 Views
Last Modified: 2012-05-05
I have setup a PC running Windows 2003 Server and am running VMWare Workstation 6. I have created a guest OS using Windows 2003 Server Standard Edition and have configured AD, DNS & DHCP on this guest server.

I then created two further guest machines, on one I installed a copy of Windows XP Pro for use as a reference machine to create an XP WIM. I created the second VM guest but didnt install an OS on it as I wanted to use this as the target workstation on which I would blat my XP image.

I then installed and configured MS AIK 1.1 and WDS as per the step by step on TechNet. I created boot images using the vista DVD as per the instructions in the help files which were pretty poor to say the least. I managed to eventually capture a WIM of my XP reference machine using the default WINPE.wim file and typing wdscapture rather than using the capture boot image created per the WDS help files as it didnt load networking correctly despite me following the same process and adding my VMWare nic drivers.

Anyway I can now see my Windows XP image on the WDS and have been trying all day to get my target VM to PXE boot properly using the Discover Image that I created. Interestingly if I PXE boot my IBM T43 laptop it loads up properly and I get as far as the language selection screen in the boot image! (I didnt want to go any further for fear of blatting my laptop by accident :-))

So I have two different issues:

Firstly if I  run both the 2003 AD DC with WDS and the Target VM for the XP image on the same laptop  I can PXE boot ok but wdsclient gives me an error saying that it cant connect to the WDS check firewall and ports etc.. (if i press SHIFT&F10 at this point and run ipconfig it shows that i have an IP and that i can ping the WDS) (Read somewhere that it might be an issue with the network loading after WDS has initialised but have no idea how to deal with this)

Secondly, after discovering that my IBM laptop could PXE boot to the WDS and get past the loading of the network I decided to move the target XP machine to another installation of VMWare Workstation 6 on a separate physical PC leaving the WDS /AD DC running in VMWare Workstation 6 on the main PC. This made things even worse, I now cant even PXE boot to the WDS, it times out and just hangs on TFTP...

I have tried disabling all my firewalls, messing around with the VMWare virtual network settings and after 9 hours im at a loss. I just cant seem to pull a WIM from a WDS running in one VM to another VM with a blank HDD.

(Please note I also tried editing my VMX file to force the target VM to use the Intel E1000 nic instead of the default AMD nic and this only made things worse. When I do this the VM wont PXE boot at all weather the WDS is on the same tin box or not.)

I am hoping that after scouring the web all day reading forum after forum and finding snippets of information that someone else can advise me on how to get WDS to work properly in a VMWare environment.
Your help is greatly welcomed and appreciated

J
0
Comment
Question by:jimsus
  • 4
  • 3
8 Comments
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Did you set up the guests to use NAT (not Bridged) Networking on the T43? .... T
0
 

Author Comment

by:jimsus
Comment Utility
I tried using both NAT and bridged networking on the VM target, currently the WDS is on the main PC in VMW6 and the VM target is on my laptop. The WDS VM is bridged, when i try using NAT for the Vm target it just times out completeley and says that no DHCP server is availible, when i change the config to bridged on the VM target it says PXE-E32 : TFTP open timeout TFTP...
0
 
LVL 90

Expert Comment

by:John Hurst
Comment Utility
Now, I have not used your setup at all,  so please forgive me if I ply ground you already know well.

When you use NAT networking, the Host machine together with VMware Networking (the Network Editor) makes a DHCP machine. So while you do need to allow the NAT range in the Host firewall, you do have a DHCP server available.

One traditional "fix" for VMware DHCP networking issues was to uninstall and reinstall VMware, but that pretty much disappeared by about VMware V4.

If you use Bridged Networking (which may make more sense, given the two machines are on different physical boxes), then your router (I assume) is the DHCP server, and the only requirement here is to ensure the local firewalls on host machines permit the local DHCP range. ... T
0
 

Author Comment

by:jimsus
Comment Utility
Thanks T,

I was concerned that the DHCP function in VMWare Workstation might be causing issues with my setup even when using a bridged network configuration so I disabled it. Also I completely disabled the FW on both VM Hosts and on the guest WDS server. The WDS guest is also running AD, DNS and DHCP with the correct options set for port listening and DHCP options for PXE / TFTP as per the help files and it seems to work ok if I use a physical laptop and almost works with bridged VM guest, it gets past PXE boot loads the boot WIM starts network support but then fails with the error that i have attached. My router which has a built in 5 port switch also has a built in SPI FW which for the sake of this test I have totally disabled. It also serves DHCP if configured but I have disabled this and set it to relay requests to my WDS guest server instead.

J
errorvm.jpg
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 90

Accepted Solution

by:
John Hurst earned 500 total points
Comment Utility
From my perspective (not the same experience factor as yours), you are trying to get DHCP services from a guest machine, and I don't think you can do that. I am fairly sure (experience with serveral versions of VMware over time) that VMware wants DHCP externally to the host (Bridged Networking) from (say) a router, or internally via its own NAT server that provides similar functionality. I don't see how VMware can set up its networking when DHCP itself has not even started (Guest not yet started). Again, my comments reflect my experience and not yours. ... T
0
 

Author Comment

by:jimsus
Comment Utility
Hi T,

I am far from being an expert with VMWare but I believe I can say with confidence that running a 2K3 DHCP server within a VMWare environment works fine. I have setup a few AD domains within VMWare previously with both client and server virtualised and not had any issues. Even in this scenario I can see that DHCP appears to be working normally. I am getting an IP lease from the DHCP server, when I press Shift & F10 at the screen shown in my attachment above and run ipconfig it shows that I have an IP lease and I can even ping my WDS server. Bizarrely however even though the network is started and I can communicate with the WDS server using ping I still get the above message. (Only from the VM guest, as previously mentioned a physical workstation can talk to the WDS server fine.) Im wondering if perhaps it is a driver issue. Although if this were the case surely I wouldnt get an IP address and I wouldnt be able to ping from the VM guest to the WDS? different network layer though is suppose... im getting confused with this it doesnt seem to make sense :-)

J
0
 

Author Comment

by:jimsus
Comment Utility
Ok I fixed it! LOL J I cant believe it. It wasnt a VMware issue, nor a driver issue, nor a firewall issue or anything else I thought about! I mentioned earlier in the thread in my opening question in fact that I had (Read somewhere that it might be an issue with the network loading after WDS has initialised but have no idea how to deal with this) well this got me thinking, why would WDS initialise before the network had finished loading, what are the main differences between my VM guest and my T43 laptop that could affect loading speed. The answer is& RAM! I have done so much reading on this over the past few days that I forgot one key thing, a Vista PE boot WIM needs at least 512MB of RAM to run properly. My T43 laptop has 2GB (which is why is loaded quickly and worked, my VM guest had only 256 as I accepted the defaults when creating the VM as I planned to use it for XP I upped the RAM to 1GB an presto!

Well I feel silly and satisfied at the same time as its currently downloading my XP WIM to the guest VM as I type.

Thanks for your help T :-)

J
0
 

Expert Comment

by:redfoxsupport
Comment Utility
Jimusus:

can you tell me how you got past the "pxe-32 tftp open timeout" errors as I am having the exact same issues??

cheers,
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

HOW TO: Install and Configure VMware vSphere Hypervisor 6.5 (ESXi 6.5), Step by Step Tutorial with screenshots. From Download, Checking Media, to Completed Installation.
Veeam Backup & Replication has added a new integration – Veeam Backup for Microsoft Office 365.  In this blog, we will discuss how you can benefit from Office 365 email backup with the Veeam’s new product and try to shed some light on the needs and …
Teach the user how to install vSphere Update Manager  Console to Windows system:  Install vSphere Update Manager: Configure vSphere Update Manager plug-in in vSphere Client: Verify vSphere Update Manager settings in vSphere Client:
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now