Solved

421 4.4.2 Connection dropped - Large emails only

Posted on 2008-11-02
6
1,712 Views
Last Modified: 2012-09-10
Hello, I have just installed an additional Exchange Server 2007 to my existing 4 E2k7 environment.  The new server is connected by VPN WAN.  Emails flow between the servers OK for small sized emails.  Larger sized emails of around 10-30MB in size continuously receive Connection Dropped Error  421 4.4.2.  The WAN is about 256K speed and can be unreliable at times. Are there fine tuning settings for the time outs in the receive connector? or anything else that may cause this problem? Thanks.
0
Comment
Question by:Superfundi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 6

Expert Comment

by:Pret0rian
ID: 22865423
The Default message size for receiving and sending in Exchange 2007 is 10 Mb i think. Maybe you should look at changing the default message size restrictions?

Remi
0
 

Author Comment

by:Superfundi
ID: 22865962
The receive connector maximum message size has already been changed to 64000 KB.  Also the user's maximum message size has been raised to 64000 KB for transmit and receive.  Under the default conditions, you would normally get a message rejection notice that the maximum message size has been exceeded, but I dont get this due to the increased limits.

get-transportconfig says;
MaxReceiveSize                 : 64000KB
MaxSendSize                     : 64000KB

I used to get the same email message everynight using POP3 over the same VPN link, but on installation of the additional E2k7 server, replacing POP3, it now fails.  It is as if the E2k7 transport is not as tolerant as POP3 to latency and transient delays.
0
 
LVL 12

Expert Comment

by:florin_s
ID: 22874050
Hi,

As you said the wan is unreliable so I recommend first checking your MTU size, here is how to check:

http://www.pctools.com/guides/registry/detail/280/
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:Superfundi
ID: 22874233
Thanks Florins, good suggestion.  I also suspected the MTU but on the VPN configuration.  The VPN management is an appliance and outsourced.  Some adjustments have been done but have not fixed the problem. The VPN hardware is best suited to satellite and long latancy traffic and has been in a long time so not much to suspect there.  BTW, DFS "seems" to work fine for the same size files.

Some more information;  The last mile connection to the remote server is ISP provided wireless running at 256k.  This server is in Port Moresby.   Since this problem came up, I've noticed the same problem on another remote server located in Mt Hagen, same country.  This one however has a 512k VSAT WAN.  It was originally E2k3 and head office the same.  HO was upgrade to E2k7 and Mt Hagen run perfectly for many months on E2k3 over the appropriate send connector.  

It was only when Hagen was upgraded from E2k3 to E2k7, and Morseby from POP3 to E2k7 that these problems started.  The connection is not dropped immediately, but a long time into transferring the email, e.g. 50mins.  Microsoft has changed something in the send/receive connectors going from E2k3 to E2k7 to create this problem.  In all fairness they expect world wide communications get better so they change the defaults to suit, but in some countries, it is still "agricultural".

Anyone know how to tune the following in the receive connector, and if it is worthwhile?  I've included the value of my settings.  Does 00:00:00 mean HH:MM:SS ??  I

MaxProtocolErrors: 5
PipeLiningEnabled: True
ConnectionTimeout:  00:10:00
ConnectionTimeoutActivity: 00:05:00
TarPitInterval:  00:0:05
0
 
LVL 12

Expert Comment

by:florin_s
ID: 22874778
Here are some articles related to the problem:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23086381.html
http://exchangepedia.com/blog/2007/01/enabled-by-default-smtp-tarpit-in.html
http://support.microsoft.com/kb/900926

you can also check the rate limiting for smtp traffic on the public ethernet port of the router if is the case.
0
 

Accepted Solution

by:
Superfundi earned 0 total points
ID: 22937383
problem not solved and nothing I have researched gives me a fix.  The large emails is being generated by our ERP system and was 1 email with a 30MB attachment.  I have now changed it to send 30 emails with 1MB attachments which seems to have been a good workaround.

Still interested if someone has a resolution, but otherwise, closing this issue.    Thanks
0

Featured Post

PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

689 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question