• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 342
  • Last Modified:

portforwarding problems

Hi.

I am new to Cisco ASA 5510 and I have a problem getting the NAT port forwarding to work. I can access remote desktop, https or http traffic.

Here is my config


Result of the command: "show run"

: Saved
:
ASA Version 7.0(8)
!
hostname bfvciscoasa
domain-name domainname.dk
enable password [password] encrypted
passwd [password] encrypted
names
name 192.168.2.2 bfvdc01
name 192.168.2.3 bfvegbolig
name 192.168.2.4 bfvexchance
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address xxx.xxx.xxx.xxx 255.255.255.252
!
interface Ethernet0/1
 nameif Inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
access-list outside_access_in extended permit tcp any eq 3389 interface outside eq 3389
access-list outside_access_in extended permit tcp any eq https host bfvexchance eq https
access-list outside_access_in extended permit tcp any eq www host bfvegbolig eq www
pager lines 24
logging asdm informational
mtu management 1500
mtu Inside 1500
mtu outside 1500
no failover
monitor-interface management
monitor-interface Inside
monitor-interface outside
asdm image disk0:/asdm-508.bin
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (management) 10 0.0.0.0 0.0.0.0
nat (Inside) 10 0.0.0.0 0.0.0.0
static (Inside,outside) tcp interface 3389 bfvdc01 3389 netmask 255.255.255.255
static (Inside,outside) tcp interface https bfvdc01 https netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.2.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:387fce96d10f02b108eda6e89b743036
: end

0
logicmedia
Asked:
logicmedia
  • 3
  • 2
  • 2
1 Solution
 
rexxusCommented:
You need to setup the outside to inside static NAT's for the 3 ports you want forwarded and then allow external resources to hit the external interface ACL and then be NAT'd to the right internal device:

static (Inside,outside) tcp interface 3389 bfvdc01 3389 netmask 255.255.255.255
static (Inside,outside) tcp interface https bfvexchance https netmask 255.255.255.255
static (Inside,outside) tcp interface www bfvegbolig http netmask 255.255.255.255

access-list outside_access_in extended permit tcp any eq 3389 interface outside eq 3389
access-list outside_access_in extended permit tcp any eq https interface outside eq https
access-list outside_access_in extended permit tcp any eq www interface outside eq www

0
 
Pete LongTechnical ConsultantCommented:
0
 
logicmediaAuthor Commented:
Hi.

I have opgraded to ASA version 8 and followed the giude from PeteLong. I think both the NAT translation rule and the security rule is correct?

Here is the new configuration.


Result of the command: "show run"

: Saved
:
ASA Version 8.0(2)
!
hostname bfvciscoasa
domain-name bfvadm.dk
enable password 8Ry2YjIyt7RRXU24 encrypted
names
name 192.168.2.2 bfvdc01
name 192.168.2.4 bfvegbolig
name 192.168.2.3 bfvexchance
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address xxx.xxx.xxx 255.255.255.252
!
interface Ethernet0/1
 nameif Inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa802-k8.bin
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns server-group DefaultDNS
 domain-name bfvadm.dk
object-group service RemoteDesktop tcp
 port-object eq 3389
access-list outside_access_in_1 extended permit tcp any host bfvdc01 object-group RemoteDesktop
access-list outside_access_in_1 extended permit tcp any host bfvexchance eq https
access-list outside_access_in_1 extended permit tcp any host bfvegbolig eq www
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu Inside 1500
mtu management 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (Inside) 10 0.0.0.0 0.0.0.0
nat (management) 10 0.0.0.0 0.0.0.0
static (Inside,outside) tcp interface 3389 bfvdc01 3389 netmask 255.255.255.255
static (Inside,outside) tcp interface https bfvexchance https netmask 255.255.255.255
static (Inside,outside) tcp interface www bfvegbolig www netmask 255.255.255.255
access-group outside_access_in_1 in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
http 192.168.2.0 255.255.255.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
!
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f32c4e1046b7186a0982fb3ad8e38e69
: end
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Pete LongTechnical ConsultantCommented:
looks fine to me - is it still not working?
0
 
logicmediaAuthor Commented:
No, i cant get a connection from the outside though the asa.
0
 
rexxusCommented:
You need to change the "outside_access_in_1" access list.

Currently you have:

access-list outside_access_in_1 extended permit tcp any host bfvdc01 object-group RemoteDesktop
access-list outside_access_in_1 extended permit tcp any host bfvexchance eq https
access-list outside_access_in_1 extended permit tcp any host bfvegbolig eq www

This allows any external addresses to talk to you internal addresses (192.168.2.x).  This won't work as the traffic that your ASA will recieve will be:

Any external IP address destined to the external address assigned to your outside interface

You need:

access-list outside_access_in_1 extended permit tcp any host interface outside object-group RemoteDesktop
access-list outside_access_in_1 extended permit tcp any host interface outside eq https
access-list outside_access_in_1 extended permit tcp any host interface outside eq www

See my original post, you need to permit inbound anything external talking to the IP address assigned to the external interface (as this is what the router will see), sorry I might not have made that clear initially.
0
 
logicmediaAuthor Commented:
Thank you - that was the solution.
I just figured it out half an hour ago, when i was going through my new cisco books :-)
I still do not understand why the other configuration works in my ASA 5505 it should be the same?
Again, that you wary much for taking the time to help me.
Best regards
Tonni
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now