Solved

How do I upload files via FTP when I get error messages of "Access Denied"?

Posted on 2008-11-03
20
277 Views
Last Modified: 2013-12-09
I am trying to upload a html file to my website but all I get is an error message of "Access Denied".
I have tried using CuteFTP, FileZIlla, CoreFTP, and the one that comes with the ISP.
All provide the same error message that access is denied.
I could download content from the site to my harddrive but not upload.
ISince I used four different FTP programs, I believe it is not a software issue.
It has something to do with XP or my SBS 2003 R2 server.
I have tried changing the FTP mode from passive to active and that did not resolve it.
Please advise.
0
Comment
Question by:j_rameses
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 5
  • 4
  • +1
20 Comments
 

Expert Comment

by:_MAGIK_
ID: 22867811
Reset the password or create another FTP account.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 22867823
Hello j_rameses,

do you have ISA on your server?

Regards,

suppsaws
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22867830
In general I always use passive FTP to w2k3 boxes. It seems to be NAT/firewall OR permissions. Do you have the options to test without NAT/FW between client and server ?

Permissions:
Check IIS permissions, under FTP server check the tab Home Directory, check if Write access is enabled. If enabled, check NTFS permissions, should be at least R/W/C on the folder yyou are uploading to.
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 

Author Comment

by:j_rameses
ID: 22867850
suppsaws,
yes i have ISA 2004.
0
 

Author Comment

by:j_rameses
ID: 22867887
buddhole,
where in IIS manager do I find the FTP section?
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 22868007
then read this:

http://sbs.editme.com/interesting  >> Cannot upload/download ftp files with sbs premium ISA
0
 

Author Comment

by:j_rameses
ID: 22868116
suppsaws,
how do i do this?
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22868231
Right click My computer ans choose manage. At the bottom you can see IIS. Open it and open FTP sites. If permissions are ok in IIS and NTFS, follow suppsaws comment: (http://isainsbs.blogspot.com/2005/07/ftp-up-and-down.html)
0
 

Author Comment

by:j_rameses
ID: 22868417
buddhole,
I am under IIS and there are three folders none for FTP.
I looked through the folders content and I do n ot find a FTP.
Where exactly is it?
The three folders I have are:
1) Application Pools
2) Web Sites
3) Web Service Extension
0
 

Author Comment

by:j_rameses
ID: 22868508
magic,
I can connect.
I can download.
I just can't upload.
0
 

Author Comment

by:j_rameses
ID: 22868616
suppsaws,
according to the article, are they referring to these two options in ISA section Firewall Policy :
1) SBS FTP Server Access Rule, action=allow;its enabled
2) SBS FTP Outbound Access Rule, action = allow;its enabled
0
 

Author Comment

by:j_rameses
ID: 22869000
hello, anyone there?
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22870139
I was assuming that the FTP server was on your win2k3 sbs server. Apparently it's running at an ISP. About the rules. check the outbound access rule and follow the below text regarding users:

"By default the FTP outbound rule is present but disabled. Enabling this rule will give all of your users the ability to send files out using FTP. If you don't want everyone to have FTP out permissions, then open the properties for that rule, go to the users tab, remove the all users group and add your individual or group that you want. However, this rule only applies for web proxy clients, not for firewall clients.

If you would like to offer Firewall Clients the same features then you'll need to edit the SBS Internet Users rule and uncheck the Read Only box under FTP Filtering. "
0
 

Author Comment

by:j_rameses
ID: 22870189
buddhole,
the FTP software are on a client PC.
there is also one that my ISP provides.
I prefer to use one of my software versions rather than one from the ISP.
Read my above note to suppsaws response.
They are enabled.
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22870658
Where is the FTP server ? On sbs or at your ISP ? If it is at the ISP, can you upload files from home ?
Also check this rule: If you would like to offer Firewall Clients the same features then you'll need to edit the SBS Internet Users rule and uncheck the Read Only box under FTP Filtering. "

0
 

Author Comment

by:j_rameses
ID: 22870708
We do not have an ftp server.
We are using the ISP as our web host provider for our website.
I am trying to replace their index page with our own but all I get is access denied.

Regarding: "Also check this rule: If you would like to offer Firewall Clients the same features then you'll need to edit the SBS Internet Users rule and uncheck the Read Only box under FTP Filtering."
Where do I do this from?
0
 
LVL 21

Accepted Solution

by:
suppsaws earned 500 total points
ID: 22874071
It's Europe here, I was asleep :)

Did you rerun the CEICW (connect to the internet wizard) after installing the ISA part?
If you rerun the CEICW SBS will configure all the default SBS ISA firewall rules for you.

Right click 'SBS internet access rule' > configure FTP, uncheck 'read only'.
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22874443

On your SBS server, open up ISA Server Mgmt, click on Firewall Policy, and scroll down and locate the policy labeled 'SBS Internet Access Rule'. Right click on this rule, and then click on the option 'Configure FTP'.  In the popup window that opens, click to UNCHECK the 'read only' option, then click Apply, then OK.
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 22874612
euh okay .... that is what I said ....
0
 

Author Comment

by:j_rameses
ID: 22876575
suppsaws,
that took care of the problem.
thank you.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction At 19:33 (UST) on Tuesday 21st September the long awaited email arrived with the subject title of “ANNOUNCING THE AVAILABILITY OF WINDOWS SBS 7 PREVIEW”.  It was time to drop whatever I was doing and dedicate as much bandwidth as possi…
This guide is intended to provide step by step instructions on how to migrate from Small Business Server 2003 to Small Business Server 2011. NOTE: This guide has been written using the preview version of SBS2011 therefore some of the screens may …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question