Solved

Can't telnet to exchange 2003

Posted on 2008-11-03
15
271 Views
Last Modified: 2010-03-06
When i attempt to telnet machine_name 25 (exchange server 2003)  the command window goes black for short time then goes back to the c:\ prompt.  I can send and receive email fine.  This occurs from local pc (on the local network) and from the exchange server itself.  Any ideas?
0
Comment
Question by:wannabit
  • 7
  • 6
  • 2
15 Comments
 
LVL 32

Expert Comment

by:gupnit
ID: 22868073
Hi
Telnet using IP and let me know
Thanks
Nitin
0
 

Author Comment

by:wannabit
ID: 22868087
samething
0
 

Author Comment

by:wannabit
ID: 22868107
the dos shell goes blank till i type something then goes back to the c:\
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22868133
Hi.
See if any Anti Virus is blocking it
Thanks
Nitin
0
 
LVL 5

Assisted Solution

by:buddhole
buddhole earned 250 total points
ID: 22868135
Is your SMTP virtual server running (and on port 25) ?
0
 

Author Comment

by:wannabit
ID: 22868211
i disabled the antivirus (symantec) and verified smtp port number to be 25
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22868237
Hi,
Check both places. Also verify that there is no other Firewall etc blocking it
Thanks
Nitin
0
Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

 
LVL 32

Expert Comment

by:gupnit
ID: 22868240
Is Telnet allow in the first place...check that too!!
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22868266
Telnet should be allowed. If you are on teh server, does telnet 127.0.0.1 works ? Also, check firewalls and check if Simple Mail Transfer Protocol is working. Do you have anti-spam software installed ?
0
 

Author Comment

by:wannabit
ID: 22868287
where do u want me to check if allowed av?  There is no other firewall between the exchange server and myself
0
 

Author Comment

by:wannabit
ID: 22868686
it acts as if it does want to load but quit instantly
0
 

Author Comment

by:wannabit
ID: 22868775
when i use putty it tells me that the remote host forced the connection to end
0
 

Accepted Solution

by:
wannabit earned 0 total points
ID: 22869593
Ok the problem was within exchange under connections tab within the smtp connector i had to add the ip address of my workstation
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22869616
I thought your PC was part of Domain and you were logged in with Domain User privileges onto the PC,
See I would not recommend you putting IP of your PC in SMTP Connector. Rather make sure that CheckBox is checked "Allow all that authenticate successfully" (sth like that)
Cheers
Nitin
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22869680
What you have done it not the actual solution, still cheers to you !!!!
0

Featured Post

Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
how to add IIS SMTP to handle application/Scanner relays into office 365.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now