Troubles Enabling SCR

Hi,

I seem to be having some troubles enabling SCR for mailbox databases
on one of my exchange 2007 servers.  Both servers are in the same
domain, same room, same rack and on the same switch @ gigabit.  Both
host only the mailbox role.  The 'Source' server (AKA ATLANTIS) is the
main mailbox server in our organization and hosts 5 storage groups,
each with a single database.  The 'Target' server (AKA EX-MBX-BKP) is
a virtual machine running in hyperv that has the ex2007 mailbox role
installed and currently has no storage groups or databases and will be
strictly a SCR target.


On the source I ran..


-------------------------------------------
[PS] C:\Windows\System32>Enable-StorageGroupCopy Misc -StandbyMachine
EX-MBX-BKP


WARNING: Misc copy is enabled but seeding is needed for the copy. The
storage
group copy is temporaily suspended. Please resume the copy after
seeding the
database.
-------------------------------------------


Then on the Target I ran... (see brackets for text color).  After
running this the directories were created on the target server for the
data automatically and the database file was put into /sg/db/temp-
seeding/db.edb


-------------------------------------------
[PS] C:\Windows\System32>Update-StorageGroupCopy ATLANTIS\Misc -
StandbyMachine E
X-MBX-BKP


[yellow text]WARNING: Replication for storage group 'ATLANTIS\Misc' is
still suspended. If
needed, you can use the Resume-StorageGroupCopy cmdlet in the Exchange
Management Shell to resume replication.[/yellow text]


[red text]Update-StorageGroupCopy : Seeding failed : Database seeding
error: Error return
ed from an ESE function call (0xc7ff1004), error code (0x0).
At line:1 char:24
+ Update-StorageGroupCopy  <<<< ATLANTIS\Misc -StandbyMachine EX-MBX-
BKP[/red text]
-------------------------------------------


At that point on the SOURCE I ran the status command and saw that it
was listed as suspended, so I ran the resume command and then it was
listed as healthy (see below)


-------------------------------------------
[PS] C:\Windows\System32>Get-StorageGroupCopyStatus Misc -
StandbyMachine EX-MBX-
BKP | FL Name,SummaryCopyStatus


SummaryCopyStatus : Suspended


[PS] C:\Windows\System32>Resume-StorageGroupCopy Misc -StandbyMachine
EX-MBX-BKP


[PS] C:\Windows\System32>Get-StorageGroupCopyStatus Misc -
StandbyMachine EX-MBX-
BKP | FL Name,SummaryCopyStatus


SummaryCopyStatus : Healthy
-------------------------------------------


Then after a few minutes I wanted to check the status of the logs etc
and ran the following....


-------------------------------------------
[PS] C:\Windows\System32>Get-StorageGroupCopyStatus Misc -
StandbyMachine EX-MBX-
BKP | FL Identity,*status*,*log*,*length*


Identity                      : ATLANTIS\Misc
SummaryCopyStatus             : Failed
LatestAvailableLogTime        :
LastCopyNotificationedLogTime :
LastCopiedLogTime             :
LastInspectedLogTime          :
LastReplayedLogTime           :
LastLogGenerated              : 34224
LastLogCopyNotified           : 0
LastLogCopied                 : 0
LastLogInspected              : 0
LastLogReplayed               : 0
CopyQueueLength               : 0
ReplayQueueLength             : 0
-------------------------------------------


This obviously was NOT good so I ran the full Copy status command and
coudl see the following error....


-------------------------------------------
[PS] C:\Windows\System32>Get-StorageGroupCopyStatus Misc -
StandbyMachine EX-MBX-
BKP | FL


Identity                         : ATLANTIS\Misc
StorageGroupName                 : Misc
SummaryCopyStatus                : Failed
NotSupported                     : False
NotConfigured                    : False
Disabled                         : False
ServiceDown                      : False
Failed                           : True
Initializing                     : False
Resynchronizing                  : False
Seeding                          : False
Suspend                          : False
CCRTargetNode                    :
FailedMessage                    : The Microsoft Exchange Replication
Service e
                                   ncountered an error while
inspecting the log
                                   s and database for ATLANTIS\Misc on
startup.
                                    The specific error code returned
is: Micros


oft.Exchange.Cluster.Replay.FileCheckLogfile
                                   MissingException: File check
failed : Logfil
                                   e 'F:\ExData\misc\log
\E0400000001.log' was n
                                   ot found.
                                      at
Microsoft.Exchange.Cluster.Replay.File
                                   Checker.CheckLogfiles(Int64
minimumGeneratio
                                   n, Int64 maximumGeneration)
                                      at
Microsoft.Exchange.Cluster.Replay.File
                                   Checker.RunChecks()
                                      at
Microsoft.Exchange.Cluster.Replay.Repl


icaInstance.ConfigurationChecker(Object stat
                                   eIgnored).
-------------------------------------------


I am stumped as to what is going on, from what I can tell this should
be pretty straightforward.  Can anyone direct me where I might be
going wrong?


Thanks!
wingnut691983Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wingnut691983Author Commented:
I have solved the issue, the database properly seeds after adding Windows powershell to the list of firewall exceptions on both the target and the source.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bepsoccer1Commented:
I am having this exact problem, but Windows Firewall is disabled on both our exchange servers.  Please help!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.