Links in outlook take me to my documents

When I get an email with a link, when I click it, instead of taking me to the internet, I am taken to my documents. A dialog box also appears as if it is looking for a file to execute.
xzay1967Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

war1Commented:
Hello xzay1967,

Are you tring to open the email in Internet Explorer?

1. You may need to register some dll files
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q281679&sd=tech
1. Quit all programs that are running.
2. Click Start, and then click Run.
3. Type regsvr32 urlmon.dll, and then click OK.
4. When you receive the "DllRegisterServer in urlmon.dll succeeded" message, click OK.

If using Vista and you get an error, run regsvr32.exe from an elevated command prompt. To get an elevated command prompt, right-click on the "Command Prompt" shortcut and select "Run as Administrator".

If this does not resolve the problem, repeat steps 2 through 4 for each of the following files (in step 3, replace Urlmon.dll with each of the file names below):

Shdocvw.dll
Actxprxy.dll
Oleaut32.dll
Mshtml.dll
Browseui.dll
Shell32.dll

OR
Run this script if using IE6
http://windowsxp.mvps.org/IEFIX.htm

2. If no joy, try this fix here
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Q_22807984.html

Hope this helps!
war1
0
xzay1967Author Commented:
This is in Microsoft Outlook 2003. The links are in the body of the email. When clicked, instead of going to the internet, it takes me to the my documents folder.
0
war1Commented:
Outlook and IE are closing related.  Register the above files and test.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

xzay1967Author Commented:
I will try your solution from the second link and I will let you know if it worked.
0
xzay1967Author Commented:
I tried your solution, still no joy. Some of the dll were not there, namely shdocvw.dll, mshtml.dll, and browseui.dll. This is a vista computer, I do not know if that makes a difference. When I tried the file type association option, it was already associated with it. A bit more info: When I click on the link in the email, it open a dialog box, thinking it is an executable file type. I will download the missing dll and register them, then see if that solves the issue.
0
war1Commented:
Make IE the default in open URL

1. On the desktop, double-click My Computer.  
2. On the Tools menu, click Folder Options, and then click the File Types tab.  
3. In the Registered File Types list, click URL:HyperText Transfer Protocol, click Advanced, and then click Edit.  
4. In the Actions box, type open.  
5. In the Application used to perform action box, locate Internet Explorer (Iexplore.exe), and then click Open.
6. In the Application box, type IExplore, and then click OK.
0
xzay1967Author Commented:
war1, thanks, but you missed what I mentioned in my prior post. I tried that option to associate the file type to IE already. It was already associated, and there is no file type tab in vista. Either way, none of those options worked. I down loaded the missing dll and will copy them to the system32 folder when the user returns to the office. Maybe that will solve the issue.
0
war1Commented:
Here is how to get to File Types in Vista
http://www.annoyances.org/exec/show/article02-500
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
xzay1967Author Commented:
Thanks again war1, but I had already figured out how to get to file types in Vista, but that is irrelevant at this point. The file type association does not resolve the issue because it was already associated. I am waiting for the user to return so I can try to fix the issue with the dll that you said to register. When I try to register the dll, I get an error about the entry point not found. I did some research and it seems that with IE7, you cannot register dlls like that any more. I am still trying to find out how to do it. Once again, I appreciate your efforts.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.