• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3783
  • Last Modified:

Free/Busy Data public folder does not work after migration.

I have migrated from a 2k3 Exchange server to a 2k7 exchange server and did not get the free/busy information replicated to the new server.

Unfortunately the 2k3 Exchange Server has been removed from the organization.

If i try ti update this folder in the EMS tool for public folders i receive this error.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Action 'Update Content' could not be performed on object 'SCHEDULE+ FREE BUSY'.

SCHEDULE+ FREE BUSY
Failed
Error:
The server '<Exchangesvr>' specified does not hold a replica of public folder '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY'. Synchronizing public folder content can only occur from a server which holds a replica of that public folder.

If i try to add the new exchange server to the replication tab under the properties for the free/busy folder I receive this error.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

set-publicfolder
Failed
Error:
Cannot save the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY'. Please make sure that you specified the correct Identity and that you have the necessary permissions to save it.

MapiExceptionNotFound: Unable to set properties on object. (hr=0x8004010f, ec=-2147221233)
Diagnostic context:
    Lid: 18969   EcDoRpcExt2 called [length=182]
    Lid: 27161   EcDoRpcExt2 returned [ec=0x0][length=532][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropSetProps [10]
    Lid: 17082   ROP Error: 0x8004010F
    Lid: 30561  
    Lid: 21921   StoreEc: 0x8004010F
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 1238    Remote Context Overflow
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x3D210102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67870102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x3D210102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67870102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67870102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x66980102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678D0102
    Lid: 3362    StoreEc: 0x8004010F
    Lid: 9206    StoreEc: 0x8004010F
    Lid: 4559    StoreEc: 0x8004010F
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0x8004010F
    Lid: 25761  
    Lid: 1940    StoreEc: 0x8004010F
    Lid: 25297  
    Lid: 21201   StoreEc: 0x8004010F

And if i try to delete the Free/Busy folder in an attempt to recreate it I receive the error.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Action 'Remove' could not be performed on object 'SCHEDULE+ FREE BUSY'.

SCHEDULE+ FREE BUSY
Failed
Error:
The folder '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY' or some of its subfolder(s) encountered errors and could not be deleted.

MapiExceptionPartialCompletion: Unable to delete folder. (hr=0x40680, ec=0)
Diagnostic context:
    Lid: 18969   EcDoRpcExt2 called [length=54]
    Lid: 27161   EcDoRpcExt2 returned [ec=0x0][length=85][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropDeleteFolder [29]
    Lid: 17082   ROP Error: 0x80070005
    Lid: 19297  
    Lid: 21921   StoreEc: 0x80070005
    Lid: 27962   ROP: ropNone [0]
    Lid: 26881  
    Lid: 21817   ROP Failure: 0x80070005
    Lid: 24721  
    Lid: 20625   StoreEc: 0x80070005

Any assistance would be greatly appreciated.
0
kb5ozcjwb
Asked:
kb5ozcjwb
1 Solution
 
Exchange_GeekCommented:
Why are you trying to rebuild Free/Busy folder ??
By default the information will get slowly populated as and when OL2k3 users start connecting to your PF store on E2k7 box. {Read this}

"By default, Outlook publishes the free/busy data for a user one time every 15 minutes, and again when Outlook shuts down. When publishing, Outlook updates the entire free/busy message instead of just adding changes to the existing message. The message includes free/busy data that ranges from the current month to two months in the future."

Ref: http://technet.microsoft.com/en-us/library/aa996946(EXCHG.65).aspx

So, by patient. And with regards to OL2k7 - they do not even look at PF Free/Busy at all - they're spoilt brat using Autodiscovery now.
0
 
kb5ozcjwbAuthor Commented:
This Exchange server has been up and running for over a month and this has not populated. If i try to run outlook.exe /cleanfreebusy I get this error.

Unable to Clean your Free/Busy Information on the server.

I also see this error in the event log.

Unable to update public free/busy data.

90% of my Clients are using Outlook 2k3
0
 
Exchange_GeekCommented:
Have you ever taken any public folder backup taken ?? If yes restore that if not try working with isinteg -fix commands.

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
GastrigCommented:
Do you have a public folder store on the 2k7 server?  Assuming you.do, you need to go to the org information under schedule+ free busy, and add a replica.  Sounds like you don't have a replica there at all, so you just need to add one.
0
 
kb5ozcjwbAuthor Commented:
Gastrig,

If i try to add the new exchange server to the replication tab under the properties for the free/busy folder I receive this error.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

set-publicfolder
Failed
Error:
Cannot save the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY'. Please make sure that you specified the correct Identity and that you have the necessary permissions to save it.

MapiExceptionNotFound: Unable to set properties on object. (hr=0x8004010f, ec=-2147221233)
Diagnostic context:
    Lid: 18969   EcDoRpcExt2 called [length=182]
    Lid: 27161   EcDoRpcExt2 returned [ec=0x0][length=532][latency=0]
    Lid: 23226   --- ROP Parse Start ---
    Lid: 27962   ROP: ropSetProps [10]
    Lid: 17082   ROP Error: 0x8004010F
    Lid: 30561  
    Lid: 21921   StoreEc: 0x8004010F
    Lid: 27962   ROP: ropExtendedError [250]
    Lid: 1494    ---- Remote Context Beg ----
    Lid: 1238    Remote Context Overflow
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x3D210102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67870102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x3D210102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67870102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x67870102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678A0102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x668F0040
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x66980102
    Lid: 21970   StoreEc: 0x8004010F PropTag: 0x678D0102
    Lid: 3362    StoreEc: 0x8004010F
    Lid: 9206    StoreEc: 0x8004010F
    Lid: 4559    StoreEc: 0x8004010F
    Lid: 1750    ---- Remote Context End ----
    Lid: 26849  
    Lid: 21817   ROP Failure: 0x8004010F
    Lid: 25761  
    Lid: 1940    StoreEc: 0x8004010F
    Lid: 25297  
    Lid: 21201   StoreEc: 0x8004010F
0
 
kb5ozcjwbAuthor Commented:
Exchange_Geek

I will take a look at the is isinteg  command. The backup we did have was only from the original Exchange 2k3 server.
0
 
Exchange_GeekCommented:
Before IsInteg let us do one thing.

Open IIS - Sites - default Web Site - Public (go to properties) Directory Security - uncheck SSL, perform the same thing with ExADMIN and ExchWeb. (Screen shot attached)

Once done, please download PFDavAdmin from

http://www.microsoft.com/downloads/details.aspx?FamilyId=635BE792-D8AD-49E3-ADA4-E2422C0AB424&displaylang=en

You would have to logon and add replica to the E2k7 System folder Free/Busy (this makes life much simpler than using shell)

http://www.msexchange.org/articles/PFDavAdmin-tool-Part2.html

Check the site under tag "Managing Public Folder Replicas" from step 1 -5.
0
 
kb5ozcjwbAuthor Commented:
I changed the SSL settings as stated but when I attempt to connect using PFDAVadmin and try to set the replicas I am returned this error.

Folder filter: (&)
Failed to get child folders of folder: https://exchangeserver/ExAdmin/Admin/Domain.COM/public%20folders/non_ipm_subtree
     Exception: Name cannot begin with the '0' character, hexadecimal value 0x30. Line 1, position 421.
0
 
Exchange_GeekCommented:
So, basically you do not have the check box for SSL for public / exadmin / exchweb virtual directories.

Else, you could try to use the command.

Set-publicfolder -identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Replicas "E2k7 box\Storage Group Name\Public Folder Database"

0
 
kb5ozcjwbAuthor Commented:
[PS] C:\Windows\System32>Set-PublicFolder -identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Replicas "exch2k7srv\Second Storage Group\Public Folde
r Database"
Set-PublicFolder : Cannot save the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY'. Please make sure that you specified the correct Identity and th
at you have the necessary permissions to save it.
At line:1 char:17
+ Set-PublicFolder  <<<< -identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Replicas "exch2k7srv\Second Storage Group\Public Folder Database"
0
 
Exchange_GeekCommented:
Ok seems shell isn't co-operating in our case, please download powergui

http://powergui.org/downloads.jspa

and have the replica added manually using GUI interface.
0
 
jmateknikCommented:
i have the exact same problem. How do I do this:
"and have the replica added manually using GUI interface."

From PowerGUI?
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now