CD-rom doesn't even show up on "My Computer".

One of my laptops doesn't even show an icon on "My Computer" for the CD-rom.  What would be the reason for this?  Because even if the drive was bad, the icon would still show up, wouldn't it?
allmar7am7777Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jeff BrownGlobal Helpdesk SupervisorCommented:
well it really depends ona  few things.

first what operating system

second does the drive eject normally?  if a drive does not get power it will not show in my computer

third do you have any dvd copying software installed.  (primarily anydvd)  it is known to cause this issue as it edits the aspi layer driver.

--wild
0
dathhoCommented:
Depends on how 'Bad'.  If it had no power it wouldn't show up would it?
Is it recognized in the BIOS?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aleonard99Commented:
You would need to check the unit id as if it were set the same as the hard drive by mistake you would not see a CD-ROM drive and the Hard drive may still work properly. Otherwise you may have a bad interface to the CD-ROM.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

dougstechCommented:
No, if the drive was bad, or had a bad connection, it would not show up.

Right click on your my computer icon, and click manage. Look in the device manager tree to see if there is a CD drive listed. If so, check to make sure it is enabled.

If you don't see it there, check to see if the connection to the drive is bad, or if the drive itself is bad.
0
aleonard99Commented:
You would need to check the unit id as if it were set the same as the hard drive by mistake you would not see a CD-ROM drive and the Hard drive may still work properly. Otherwise you may have a bad interface to the CD-ROM.
0
allmar7am7777Author Commented:
the OS is XP.
the drive does eject normally.  When a CD is inserted it sounds like it's booting up, like it's trying to read it, but again, no icon in "My Computer", and nothing autoruns.
I've even tried replacing the drive with another known working drive and....same thing.
I looked and I didn't see any DVD copying software on her computer, although that may not be true...
If that is the case, how do I go about editing the aspi layer driver back to it's original settings?
0
dougstechCommented:
Perhaps you misunderstood my suggestion. Right click on the "my computer" icon itself.
0
allmar7am7777Author Commented:
Dougstech,

right clicking on my computer didn't give me any option to manage, or device manager...
0
allmar7am7777Author Commented:
dougstech,

ok, yeah, I'm an idiot...hold on
0
MarkCommented:
I believe you need to do some registry editing to remove the upper and lower filters for the cd drive.
You can try Doug Knox's fix found here http://www.dougknox.com/xp/scripts_desc/xp_cd_dvd_fix.htm
Or you can manually edit the registry. ( this is meant for people with  registry editing experience)

Step 1: Start Registry Editor
Start--> RUN --> type in -->regedit click OK
Step 2: Delete the UpperFilters registry entry
1.      In Registry Editor, expand My Computer, and then expand HKEY_LOCAL_MACHINE.
2.      Expand SYSTEM, and then expand CurrentControlSet.
3.      Expand Control, and then expand Class.
4.      Under Class, click {4D36E965-E325-11CE-BFC1-08002BE10318}.
5.      In the details pane of Registry Editor, on the right side, click UpperFilters.

Note You may also see an UpperFilters.bak registry entry. You do not have to remove that entry. Click UpperFilters only.
"      If you see the UpperFilters registry entry in the details pane of Registry Editor, go to step 6.
"      If you do not see the UpperFilters registry entry, you still might have to remove the LowerFilters registry entry. To do this, go to "Step 3: Delete the LowerFilters registry entry."
6.      On the Edit menu, click Delete.
7.      Click Yes when you receive the following message:
Are you sure you want to delete this value?
The UpperFilters registry entry is removed.
Step 3: Delete the LowerFilters registry entry
1.      In the details pane of Registry Editor, on the right side, click LowerFilters.

Note You might see a LowerFilters.bak registry entry. You do not have to remove that entry. Click LowerFilters only.

If you do not see the LowerFilters registry entry, unfortunately this content is unable to help you any more. Go to the "Next Steps" section for information about how you can find more solutions or more help on the Microsoft Web site.
2.      On the Edit menu, click Delete.
3.      Click Yes when you receive the following message:
Are you sure you want to delete this value?
The LowerFilters registry entry is removed.
4.      Exit Registry Editor.
Step 4: Restart your computer
Restart your computer. After you have done this, try to access the CD or DVD drive. If you can access the CD or DVD drive, and if you do not receive an error message, the problem is resolved. You can reinstall your CD or DVD writing or recording software.
0
allmar7am7777Author Commented:
sparkmaker,

I followed your instructions.  The UpperFilters registry wasn't visible.  I deleted the LowerFilters registry entry, restarted the computer, but no icon for the CD drive, wasn't accessible.
0
allmar7am7777Author Commented:
dougstech,

I followed your instructions and there appears to be a device that I'm assuming is the C drive, although I'm not sure.  The only thing connected to the laptop is the monitor and the mouse, so there isn't any other peripherals connected, so I'm assuming this is the CD drive.  I right-clicked on it and there wasn't an option to enable it or not...I went into properties and nothing there either...
0
dougstechCommented:
The C drive is the main hard drive of the computer, you are not able to disable it. It appears you have a bad CD drive, or a bad connection. Check all power/data connections, and if it still doesnt work, I would suggest replacing the drive.
0
netminder69Commented:
Have you tried reinstalling drivers for it?
0
allmar7am7777Author Commented:
netminder69,
where do I find the drivers for it?

I want to state again that I have replaced the original drive with another known working drive ending in the same results.  I'm thinking it's got to be the drivers at this point....
0
Jeff BrownGlobal Helpdesk SupervisorCommented:
Drivers for cd roms  dvd's  are a function of the controller card.  The sata controller, the Ide controller, The usb controller.   depending on how the device interfaces with the computer.  There are no "cd drivers"  for windows anymore they are built into the os if the os recognises the controller and the controller regognises the drive then it should work with the exception of  aspi layer changes and drive letter filtering mentioned earlier.   Lets go back to more of a base level.   We know the drive gets power.  We know the drive spins.  but does the bios level  recognise the drive.  If thats not happening nothing we do in windows is going to do anything.  What make and model of laptop are we talking about so i can find the way to tell if the bios is recognising the drive and what interface is being used

--wild
0
allmar7am7777Author Commented:
Wildstar10,

it's a Dell Inspiron 8500
0
dougstechCommented:
If it were a driver problem, it would still show up in device manager, but would not be functional. If its not listed in device manager, its a hardware problem.
0
Jeff BrownGlobal Helpdesk SupervisorCommented:
oik  the 8500 connects to standard ide ports.  first thing to do.  go into the bios of the 8500  should be the del key  during startup to enter bios  (could possibly be f2).  once in the bios go thru the pages until you see the list of connected drives.  make sure the cd rom appears there (if it doesn't the drive is bad or the connector is bad on the mother board.  If it appears there  reboot and go into windows safe mode.  press f8  to get to the list and choose safe mode.   See if the cdrom appears in safe mode. (if it does then you have some software issues but too many to list here)  If it does not appear in safe mode you have serious software issues with the possiblity for hard ware issue.  Get back to me with what you find.   My week next week is quite a bit lighter so i will be checking my paticipated questions alot more frequently

--Wild
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.