Change Password in OWA 2003 for multiple websites

I am currently hosting multiple storage groups with different domains for each on a single Exchange 2003 server.  I use OWA for each of the domains and I have set up the ability for the passwords to be changed through OWA after they login through the Options screen.  It works great for the default website but does not work for any of the other sites.  Can someone please help.  Thanks
OKDRSAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeDerbyshireCommented:
I've never tried to do that, but the first thing I would check is that you created the IISADMPWD VDir for each site, not just the Default Web Site.
0
OKDRSAuthor Commented:
I have added the virtual directory to the other web site in IIS.  I have also tried changing around the App Pool that it is looking at one for the Default and one at the ExchangeAppPool.  Neither one would work.
0
LeeDerbyshireCommented:
What happens when you try to use it?  Any error messages, or status codes (401,403,404,500, etc.)?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

OKDRSAuthor Commented:
HTTP/1.1 503 Service Unavailable is the error in the new window that pops up.  Sorry it took so long to post again.  Wife just had a baby.
0
LeeDerbyshireCommented:
Congratulations!  I hope they are both well.

When you created the extra sites for OWA, did you use ESM, or IIS Manager?  The reason I ask is that when you do it in ESM, you get a site that is dedicated to OWA, and I'm not sure how it would then behave if you tried to add VDirs under it in IIS Manager.  And yet this is what you would need to do in order to add IISADMPWD.  Have a look at the IISADMPWD VDir, and see if it is still configured to use DAVEX.DLL as the wildcard application.  If it's there, it will need to be removed.
0
OKDRSAuthor Commented:
I did use the ESM to create the new site for OWA.  How do I check IISADMPWD vdirto see if it is configured to use DAVEX.DLL as the wildcard app.  Also the IISADMPWD isnot listed in IIS as a Vdir under the new OWA site, should it be?  It is only listed under the default site.

Thank you very much and yes  both are well.
0
LeeDerbyshireCommented:
Ah, I thought you said in post 22901226 that you'd added it to the new OWA site.  You will need to do that because when you are in OWA at http://secondsitename , then clicking the password button will send you to http://secondsitename/iisadmpwd .  Try adding it first, before worrying about DAVEX.DLL .
0
OKDRSAuthor Commented:
You're right it is added and the application pool is ExchangeApplicationPool.  Sorry about that I guess I am more sleep deprived than I thought.
0
LeeDerbyshireCommented:
Heh, no problem.  And you said you already tried setting it to DefaultAppPool?

Anyway, it sounds like you have IIS6 (since IIS5 didn't use Application Pools).  Have a look at the properties of the IISADMPWD VDir on the second site, and click the Configuration button (click Create if it's disabled).  you should be able to see if an Application Wildcard Mapping is configured.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OKDRSAuthor Commented:
You are right the DAVEX.DLL is listed as the wildcard application.  I have removed it and restarted IISADMIN service and everything seems to be working great.  I think we can change passwords without having to enter in the domain name as well which is less confusing for our users.

Thanks so much!
0
OKDRSAuthor Commented:
Well it worked one time and has not worked since.  It brings up the window and lets me enter in all the appropriate settings to change the password but now it comes back with the same error message everytime saying that:
  Internet Service Manager
for Internet Information Server 6.0

Either the password is too short or password uniqueness restrictions have not been met.


But when I go in to Active Directory and reset the password using the same one that got denied through the web it lets me.  It is like it is not talking correctly with Active Directory throught he password reset screen.  Any ideas?
0
LeeDerbyshireCommented:
Hm.  Try sitting at the console of the IIS server, logging in as the same user, and then use CTRL-ALT-DEL to change the password.  See if it complains then.
0
OKDRSAuthor Commented:
I don't think I can do a CTRL-ALT-DEL since I am remoting in to the server from a different location.  The users never actually log in to the domain they only use OWA as a service through the internet.  If you know of a way that I can try your suggestion from a remote location I am willing to try just about anything at this point.

Thanks
0
LeeDerbyshireCommented:
Are you using Terminal Server?  If so, select Windows Security from the Start menu.  I think you can change the password from there.
0
OKDRSAuthor Commented:
I am using remote desktop as the app to connect in tot he server.  I deleted everything and started over with the OWA site for them including all of your suggestions and again upon first try it allowed me to do a password change but then after that first time it has not allowed another password change for the same user with the window appearing with the following message.

Internet Service Manager
for Internet Information Server 6.0

Either the password is too short or password uniqueness restrictions have not been met.

0
OKDRSAuthor Commented:
Problem was in group policy settings, specifically the password age.  It was set for 1 day and that is why it appeared to work once and then not again.  Once I changed it to 0 everything started working as it should.

Thanks for all of your help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.