A BIOS flash rendered my encrypted drive useless. How do I get my data?

I have a HP dc5700S desktop machine with WinXPPsp2 running GuardianEdge Encryption Anywhere on bootup.  I did a BIOS flash from within Windows (the HPQFlash thing).  I'm certain that the version and method was correct, except after the reboot my drive wouldn't boot.  I tried many other flashes from a bootable usb stick (there's actually 2 things to flash: a microcode and the BIOS so I tried many versions of each).  All flashes seem successful, and BIOS is available, yet no boot.  Just a black screen after a few HDD flashes.

I moved the drive into another similar machine and (while booted into this machine's working C drive) I see that my encrypted drive from the dc5700s is unreadable and asks me to format it.  I deduce that my original BIOS flash within Windows has overwritten my MBR or something which makes my encrypted drive unreadable.  I have no reason at all to believe that my hardware is actually faulty.  Note also that I can see the HP recovery partition from the drive, so only the C drive is unreadable.

So the obvious question, assuming my deduction is correct, is how do I get back at my data on the encrypted drive.  We install Encryption Anywhere via group policy so there's no CD or anything in my office and some quick googling hasn't given me anything.  Can anyone help me?  I'm going home and will check your suggestions in 12 hours when I return.  Thanks in advance.
LVL 14
theras2000Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TolomirAdministratorCommented:
you should contact support for that:

http://www.guardianedge.com/support/
0
akahanCommented:
By temporarily installing another hard drive (or booting from a USB drive), are you able to re-flash the BIOS back to the version previously installed on the machine, and then re-install your encrypted drive and boot from it?  I have, honestly, NO idea if this will work (in fact, some BIOS updaters will not let you "update" to an older BIOS than the currently-installed one)....but it might be worth a try.

0
theras2000Author Commented:
Thank you but nah that won't do it.  It's not the version of BIOS that's my problem, it's the fact that my first flash would have used part of the boot partition to store it's info (and therefore wrote over some of the encryption stuff).  Besides I already tried all versions of the BIOS and microcode available, before I'd realised that this was what had happened.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

akahanCommented:
Ah, got it.  I didn't realize that those BIOS update programs destructively used part of the boot record.  I don't suppose you have a backup of the drive that contains the boot record, complete with encryption stuff, as it appeared prior to the mangling?  I understand that such a backup would not have the DATA you want, but if you could transfer the boot record from the backup drive to your existing, munged drive, that might do it.  You could copy the MBR from the backup  disk onto this one using MBRWizard:  http://www.mbrwizard.com/


0
TolomirAdministratorCommented:
As said, contact support of the software.

At least they can give you help with the 1st steps with THEIR software to recover YOUR data.
0
theras2000Author Commented:
akahan, thanks for your suggestions.  If I'd had a backup of the MBR, that probably would have worked.
I ended up finding some documentation that my company had cerated years ago with some steps to try for these situations.  There was a Recoevry CD I burnt and it managed to decrypt the whole drive for me this morning.
If anyone looks up this post in years to come, here's the steps:  1st try the Access Utility CD to boot and see the drive.  Then try booting the Emergency Recovery CD and run the command recover /a.  If the drive is still unreadable, boot the Emergency Recovery Cd and try recover /d.  There is probably some proper guides from GuardianEdge about this, but you need support contracts and logins to access it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Encryption

From novice to tech pro — start learning today.