• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 211
  • Last Modified:

Sending mail between internal mail servers on different domains

We have to domains setup in our organization old.com and new.com (for instance).  Obviously old.com has been setup for a while and everything is functioning good.  New.com works for the most part....I can send and receive mail from another outside domain and I can send mail to old.com but i cannot receive from it.  When I try to send to new.com from old.com I get this error message:

Your message did not reach some or all of the intended recipients.

      Subject:      test
      Sent:      11/03/2008 5:53 PM

The following recipient(s) could not be reached:

      kim@new.com on 11/03/2008 5:52 PM
            The e-mail system was unable to deliver the message, but did not report a specific reason.  Check the address and try again.  If it still fails, contact your system administrator.
            <scweb-web.new.local #5.0.0>

Now I know some of that looks funny because our email server is scweb-email not scweb-web so I'm not sure about that either.
0
red24698
Asked:
red24698
  • 10
  • 10
1 Solution
 
Exchange_GeekCommented:
Firstly i would recommend you to perform a message tracking and check where these messages are going to.

Secondly, please do tell me if there a smart host located on the old.com server SMTP Virtual Server.

Thirdly, perform a telnet test from old.com server to new.com server and see if the mail goes through.

Are these both servers part of same Administrative Group (for example First Administrative Group) or is it part of separate ones ?
0
 
red24698Author Commented:
Well i think i see the problem after your first suggestion....when i track a message from old.com to new.com it goes to the webserver and not the email server and bounces back....but like i said it works fine from the outside....even if i send a message from new.com to old.com and then just reply to that message it still goes to the webserver rather than the email server
0
 
Exchange_GeekCommented:
Now, your answer lies in the the very second solution i offerred.

Secondly, please do tell me if there a smart host located on the old.com server SMTP Virtual Server

Open Exchange System Manager - Organization - Administrative Group - Servers - Your Old.com Exchange server - Protocols - SMTP - Default SMTP Virtual Server - properties - remove the webserver entry mentioned on the first page and select use DNS check box.

You may be required to restart SMTP Service after this.
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
red24698Author Commented:
I checked it and it was already set to use dns and there was no smart host listed
0
 
Exchange_GeekCommented:
Can you attach a screen shot please (I would want the particular tab which talks about smart host setting of old.com SMTP Virtual Server)

Also, do we have any SMTP Connector created on old.com Exchange server ?

Thanks.
0
 
red24698Author Commented:
Ok here ya go I think I took a picture of the right screen, and you can see the connectors folder in the background of it
screenshot.bmp
0
 
Exchange_GeekCommented:
Great, this SMTP Connector does not have the local bridgehead server configured ?? Not sure why you have not added there ??

"Can you attach a screen shot please (I would want the particular tab which talks about smart host setting of old.com SMTP Virtual Server)"

Could you please provide screen shot for the default SMTP VS as asked above.

Thanks for providing such quick response.
0
 
red24698Author Commented:
Sorry i couldnt find the option you were talking about under the default smtp so I guessed at what you meant....here is a shot of the default smtp if you can tell me where to look from there...also i added the bridgehead while i was there....
screenshot2.bmp
0
 
Exchange_GeekCommented:
"On the Delivery tab, click Advanced to open the Advanced Delivery dialog box."

Screen shot for this, sorry i had presumed that you would know. :)

0
 
red24698Author Commented:
No problem....here ya go...and thanks for all the help!
screenshot3.bmp
0
 
Exchange_GeekCommented:
Technically speaking your SMTP Connector is done perfectly (except i have not checked the address space - which should have only * in it)

Secondly, your default SMTP VS looks also good.

Is there any Third-Party Application on the old.com Exchange server.
You may want to restart SMTP and Routing Engine service on old.com Exchange box once these changes / settings are verified.

thanks.
0
 
red24698Author Commented:
Only third party are symantec and backup exec but they have been on there for a while and the server can send to everyone else fine just not to domain B......
0
 
red24698Author Commented:
oops sry by domain B i meant new.com
0
 
red24698Author Commented:
New Info: Now I no longer get that error message....i found out i had pop installed on the new.com webserver which made no sense because we have a new.com email server so i uninstalled that and now when i send an email from old.com to new.com it just gets stuck in the queue of the old.com server.....hope this helps some....
0
 
Exchange_GeekCommented:
Gets stuck in which queue ??? Whats message tracking telling you ??

I just realised that your new.com Exchange server is not part of this Exchange organization - is that the case ?
0
 
red24698Author Commented:
Right they are on 2 seperate machines on 2 seperate domains with 2 seperate organizations...but they are all on the same internal subnet and router.

Its the queue of the old.com server when sending to the new.com server.  I will attach a screenshot of the tracking center...this is as far as it gets....
I guess the thing that gets me the most about the situation is that i can send from new.com to old.com just fine but i cant send to or even reply to new.com when i just received a message fine
screenshot4.bmp
0
 
Exchange_GeekCommented:
Well, this should be as simple as buying a beer on the street.

Create a new SMTP Connector with address space new.com and at the smart host add the ip address of the Exchange server of new.com. Restart SMTP service.

Now, tell me if there is any problem.
0
 
Exchange_GeekCommented:
The track states simply that it does not know where to send the messages. So by creating this new smtp connector and providing it with the Exchange server of new.com we should be able to provide it the route.

Hope i made myself clear. :)
0
 
red24698Author Commented:
WOOOOOOOOOOOOOOO its works...thanks so much for you help!
0
 
Exchange_GeekCommented:
Glad to have helped you. Njoi.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 10
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now